summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHunter Peavey2020-12-11 13:18:58 -0800
committerHunter Peavey2020-12-11 13:18:58 -0800
commitbbbf056fc8dc3b619995d62a00229a7d1d8a05ff (patch)
treead3c246ae8ec069a02bab966a08b152fecd14a59
downloadaur-bbbf056fc8dc3b619995d62a00229a7d1d8a05ff.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD24
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..741842626e76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = weakauras-companion-bin
+ pkgdesc = A cross-platform application built to provide the missing link between Wago.io and World of Warcraft. (This is a repackage of the official RPM package.)
+ pkgver = 3.1.1
+ pkgrel = 1
+ url = https://github.com/WeakAuras/WeakAuras-Companion
+ arch = x86_64
+ license = GPL2
+ depends = electron
+ source = https://github.com/WeakAuras/WeakAuras-Companion/releases/download/v3.1.1/weakauras-companion-3.1.1.x86_64.rpm
+ sha512sums = c31665ac829a5ff3ec3ba7fe84f5a73932e63d10dc9535635128a94c68b3c0e6a5764d7b55472f20c3275a594b739494a93a80a6a847339dfe35f578abd15db6
+
+pkgname = weakauras-companion-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..485c8507e679
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!PKGBUILD
+!.gitignore
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..45afb40098e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Hunter Peavey < printf "srht@die.bots" | sed "s/die.bots/krathalan.net/g" >
+
+# General package information
+pkgname=weakauras-companion-bin
+pkgver=3.1.1
+pkgrel=1
+pkgdesc="A cross-platform application built to provide the missing link between Wago.io and World of Warcraft. (This is a repackage of the official RPM package.)"
+url="https://github.com/WeakAuras/WeakAuras-Companion"
+license=("GPL2")
+arch=("x86_64")
+
+source=("${url}/releases/download/v${pkgver}/weakauras-companion-${pkgver}.x86_64.rpm")
+sha512sums=("c31665ac829a5ff3ec3ba7fe84f5a73932e63d10dc9535635128a94c68b3c0e6a5764d7b55472f20c3275a594b739494a93a80a6a847339dfe35f578abd15db6")
+
+depends=("electron")
+
+package() {
+ cd "${srcdir}" || exit
+ cp -r opt/ usr/ "${pkgdir}"
+ chmod 755 "${pkgdir}/opt" "${pkgdir}/usr"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -sf "${pkgdir}/opt/WeakAuras Companion/weakauras-companion" "${pkgdir}/usr/bin/weakauras-companion"
+}