summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRayrsn2022-08-14 15:30:57 +0300
committerRayrsn2022-08-14 15:30:57 +0300
commitb360fd39f13a8e8b6d8f93271fe3b3e030cbb646 (patch)
tree756d4ee90f2dbca06b30e506ee2862a39fd43066
downloadaur-b360fd39f13a8e8b6d8f93271fe3b3e030cbb646.tar.gz
First Commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae5f2573da47
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = weather-cli
+ pkgdesc = An app made to get weather information through the terminal written in Go
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/Rayrsn/Weather-Cli
+ arch = x86_64
+ license = GPL
+ makedepends = cargo
+ source = https://github.com/Rayrsn/Weather-Cli/archive/refs/tags/1.2.0.zip
+ md5sums = 7c670163a2c57538eb915aa19947c630
+
+pkgname = weather-cli
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..249993b70f75
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Rayr https://rayr.ml/LinkInBio/
+
+pkgname=weather-cli
+pkgver=1.2.0
+pkgrel=1
+pkgdesc="An app made to get weather information through the terminal written in Go"
+arch=('x86_64')
+url="https://github.com/Rayrsn/Weather-Cli"
+license=('GPL')
+makedepends=('cargo')
+source=("https://github.com/Rayrsn/Weather-Cli/archive/refs/tags/$pkgver.zip")
+md5sums=('7c670163a2c57538eb915aa19947c630')
+build() {
+ cd "Weather-Cli-$pkgver"
+ go build
+}
+
+package() {
+ cd "Weather-Cli-$pkgver"
+ install -Dm755 "weather-Cli" "$pkgdir/usr/bin/weather-Cli"
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}