summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiguel de Val-Borro2015-07-09 14:11:41 -0400
committerMiguel de Val-Borro2015-07-09 14:11:41 -0400
commit6e25f5fd4d4c29e1541a80ab1e53a184b3958a3b (patch)
tree8f9c64feb1430519cb816ad555f9e8db476756d1
downloadaur-6e25f5fd4d4c29e1541a80ab1e53a184b3958a3b.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a27e47bebf52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = weatherman
+ pkgdesc = Display weather information from the command line.
+ pkgver = 1.2.2
+ pkgrel = 2
+ url = https://github.com/subrosa/weatherman
+ arch = any
+ license = custom
+ depends = curl
+ source = https://github.com/subrosa/weatherman/archive/1.2.2.tar.gz
+ md5sums = 5da26fa890238c0b2a2105d0ae43e9d5
+
+pkgname = weatherman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdc55ed5457e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Rob Hunter <subrosa@github>
+
+pkgname=weatherman
+pkgver=1.2.2
+pkgrel=2
+pkgdesc="Display weather information from the command line."
+arch=('any')
+license=('custom')
+depends=("curl")
+url=("https://github.com/subrosa/weatherman")
+source=("https://github.com/subrosa/$pkgname/archive/$pkgver.tar.gz")
+md5sums=("5da26fa890238c0b2a2105d0ae43e9d5")
+
+build() {
+ true
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 weatherman $pkgdir/usr/bin/weatherman
+ install -Dm644 weatherman.1.gz $pkgdir/usr/share/man/man1/weatherman.1.gz
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}