summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-01-10 10:58:54 +0100
committerDaniel Peukert2020-01-10 10:58:54 +0100
commit03dd68162c0313342a841617a36c2e0240704045 (patch)
treed80c96b332538222b99ae285dca2416cd8d73787
downloadaur-03dd68162c0313342a841617a36c2e0240704045.tar.gz
Added weatherspect-git
-rw-r--r--.SRCINFO18
-rw-r--r--.editorconfig8
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD35
-rw-r--r--weatherspect.169
5 files changed, 144 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a31c3cbf35e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = weatherspect-git
+ pkgdesc = A virtual weather environment in ASCII - git version
+ pkgver = 2.0.r2.gb7ac282
+ pkgrel = 1
+ url = https://github.com/AnotherFoxGuy/weatherspect
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = perl
+ depends = perl-term-animation
+ provides = weatherspect
+ conflicts = weatherspect
+ source = weatherspect-git::git+https://github.com/AnotherFoxGuy/weatherspect
+ source = weatherspect.1
+ sha256sums = SKIP
+ sha256sums = 8b0d7bb995e44190cc005ec3b604f147dcb233744a262cbbf9a9ad8f9214ab0c
+
+pkgname = weatherspect-git
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..a467ee9a97a6
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,8 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..82b3c183d5d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,14 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+*/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..607006608976
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Contributor: Kevin MacMartin <prurigro at gmail dot com>
+# Contributor: Lara Maia <lara@craft.net.br>
+# Contributor: archlinux.info:tdy
+_pkgname='weatherspect'
+pkgname="$_pkgname-git"
+pkgver='2.0.r2.gb7ac282'
+pkgrel='1'
+pkgdesc='A virtual weather environment in ASCII - git version'
+arch=('any')
+url="https://github.com/AnotherFoxGuy/$_pkgname"
+license=('GPL2')
+depends=('perl' 'perl-term-animation')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=(
+ "$pkgname::git+$url"
+ "$_pkgname.1"
+)
+sha256sums=('SKIP'
+ '8b0d7bb995e44190cc005ec3b604f147dcb233744a262cbbf9a9ad8f9214ab0c')
+
+_sourcedirectory="$pkgname"
+
+pkgver() {
+ cd "$srcdir/$_sourcedirectory/"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/"
+ install -Dm755 "$_sourcedirectory/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ install -Dm644 "$_pkgname.1" "$pkgdir/usr/share/man/man1/$_pkgname.1"
+}
diff --git a/weatherspect.1 b/weatherspect.1
new file mode 100644
index 000000000000..1fd52c138dee
--- /dev/null
+++ b/weatherspect.1
@@ -0,0 +1,69 @@
+.TH "WEATHERSPECT" "1" "2019-12-30"
+.
+.SH "NAME"
+weatherspect \- a virtual weather environment in ASCII
+.
+.SH SYNOPSIS
+\fBweatherspect\fR [\fB\-f\fR \fIFILE\fR]
+.PP
+\fBweatherspect\fR \fB\-c\fR [\fB\-f\fR \fIFILE\fR]
+.PP
+\fBweatherspect\fR \fB\-h\fR
+.
+.SH "DESCRIPTION"
+\fBweatherspect\fR provides a reasonably accurate simulation of what the weather looks like outside, in ASCII art\. It includes rain, snow, lightning, sleet, and hail\. The windspeed and cloudiness are reflected in the velocity and quantity of clouds\. There are trees that age, reproduce and die over the course of an hour, and a sun and moon that follow the actual sun and moonrise\. There\'s also a dancing turtle\.
+.
+.SH "OPTIONS"
+.TP
+\fB\-f\fR \fIFILE\fR
+Supply a config file to use instead of the default
+.TP
+\fB\-c\fR
+Generate a config file
+.TP
+\fB\-h\fR
+Print a help message
+.
+.SH "USAGE"
+Before \fBweatherspect\fR will work, you have to create a config file for it\. Running it with the \fB\-c\fR option will prompt you for info to create a config file in \fI~/\.weatherspect\fR\.
+.PP
+While \fBweatherspect\fR is running, the following commands are available:
+.TP
+\fBq\fR
+Quit
+.TP
+\fBh\fR
+Toggle the help window
+.TP
+\fBw\fR
+Toggle the detailed weather info window
+.TP
+\fBd\fR
+Toggle the debug window
+.TP
+\fBu\fR
+Force an update of weather data
+.TP
+\fBr\fR
+Redraw. This will remove all objects and recreate them, probably in different places.
+.
+.SH "CREDITS"
+.IP "\(bu" 4
+Kirk Baucom \<\fIkbaucom@schizoid\.com\fR\> \- \fIhttp://www\.robobunny\.com\fR
+.
+.IP "\(bu" 4
+Kevin Ferree \- \fIhttp://chavo\-one\.com\fR: All art in the code marked with \'kf\'
+.
+.IP "\(bu" 4
+Hayley Wakenshaw \- \fIhttp://www\.bornsquishy\.com/flump/index\.html\fR: All art in the code marked with \'hjw\'
+.
+.IP "\(bu" 4
+Joan Stark \- \fIhttp://www\.geocities\.com/SoHo/7373/\fR: All art in the code marked with \'jgs\'
+.
+.IP "\(bu" 4
+AnotherFoxGuy \- \fIhttp://anotherfoxguy.com\fR: Replaced Underground with OpenWeatherMap
+.
+.IP "" 0
+.
+.PP
+You can grep for ATTRIB in the code to get a list of credits for all the ASCII art\.