summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornltimv2023-08-04 22:06:36 +0200
committernltimv2023-08-04 22:06:36 +0200
commitdb5ad6107d17c03b5e4b5d12004913829942f796 (patch)
treedd4885150953803601bfb65ed87035d9de0a4775
downloadaur-db5ad6107d17c03b5e4b5d12004913829942f796.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD49
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..afbcbdb97d6b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = weave-gitops-git
+ pkgdesc = Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise.
+ pkgver = v0.29.0.r7.g6f053dfbe
+ pkgrel = 1
+ url = https://github.com/weaveworks/weave-gitops
+ arch = i686
+ arch = pentium4
+ arch = x86_64
+ arch = arm
+ arch = armv7h
+ arch = armv6h
+ arch = aarch64
+ arch = riscv64
+ license = MPL2
+ makedepends = git
+ makedepends = go>=1.20.0
+ depends = glibc
+ optdepends = helm>=3: For installation in a Kubernetes cluster
+ provides = gitops
+ provides = gitops-server
+ conflicts = gitops
+ conflicts = gitops-server
+ source = git+https://github.com/weaveworks/weave-gitops#branch=main
+ sha256sums = SKIP
+
+pkgname = weave-gitops-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..89790543d1f6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+src/
+pkg/
+weave-gitops/
+**/*.tar.gz
+**/*.tar.zst
+**/*.log \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d2b1c8d91caf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: nltimv <git at nltimv dot com>
+pkgname='weave-gitops-git'
+pkgver=v0.29.0.r7.g6f053dfbe
+pkgrel=1
+pkgdesc='Weave GitOps is a simple open source developer platform for people who want cloud native applications, without needing Kubernetes expertise.'
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64' 'riscv64')
+url='https://github.com/weaveworks/weave-gitops'
+license=('MPL2')
+depends=(
+ 'glibc'
+)
+makedepends=(
+ 'git'
+ 'go>=1.20.0'
+)
+optdepends=(
+ 'helm>=3: For installation in a Kubernetes cluster'
+)
+provides=('gitops' 'gitops-server')
+conflicts=('gitops' 'gitops-server')
+source=("git+https://github.com/weaveworks/weave-gitops#branch=main")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/weave-gitops"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ export GOPATH="$srcdir"/gopath
+
+ cd "$srcdir/weave-gitops"
+ echo $LDFLAGS
+ go build -buildmode=pie -trimpath -ldflags="-linkmode=external -extldflags \"$LDFLAGS\"" -mod=readonly -modcacherw -o bin/gitops cmd/gitops/main.go
+ go build -buildmode=pie -trimpath -ldflags="-linkmode=external -extldflags \"$LDFLAGS\"" -mod=readonly -modcacherw -o bin/gitops-server cmd/gitops-server/main.go
+}
+
+check() {
+ cd "$srcdir/weave-gitops"
+ make test
+}
+
+package() {
+ cd "$srcdir/weave-gitops"
+ install -Dm 755 bin/gitops $pkgdir/usr/bin/gitops
+ install -Dm 755 bin/gitops-server $pkgdir/usr/bin/gitops-server
+
+ go clean -modcache
+}