summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2025-03-18 12:29:36 -0600
committerMark Wagie2025-03-18 12:29:36 -0600
commit5168e841dadcf8984da72511fcceeac35be0fb34 (patch)
treea13d1fb3b0406e655770a382c45a8269fa00302e
downloadaur-5168e841dadcf8984da72511fcceeac35be0fb34.tar.gz
initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--.gitignore10
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD58
-rw-r--r--fix-appstream-validation-errors.patch147
5 files changed, 250 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c39f2ccfc12f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = web-archives
+ pkgdesc = A web archives reader
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/birros/web-archives
+ arch = x86_64
+ license = GPL-3.0-or-later
+ checkdepends = appstream
+ makedepends = meson
+ makedepends = vala
+ depends = gtk3
+ depends = libhandy
+ depends = libisocodes
+ depends = libsoup3
+ depends = libzim-glib
+ depends = sqlite
+ depends = tinysparql
+ depends = webkit2gtk-4.1
+ source = web-archives-0.5.0.tar.gz::https://github.com/birros/web-archives/archive/refs/tags/v0.5.0.tar.gz
+ source = https://github.com/birros/web-archives-darkreader/releases/download/v0.0.1/web-archives-darkreader_v0.0.1.js
+ source = fix-appstream-validation-errors.patch
+ sha256sums = 10bdaf25633d9b23385c31000a5dce02146da5d2daf73b13a03881b1ecaf77f5
+ sha256sums = 8ee840aacd9e09864a7ab2e75f736f696dcd4b4b8e86a07ba727ff3d10ef32a1
+ sha256sums = bb4bbec3852b373939ed21c26c14b98b015a8038597c5bd95c47078648f9d88c
+
+pkgname = web-archives
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad2c75445bc9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+# Ignore everything
+/*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!.nvchecker.toml
+!LICENSE
+!fix-appstream-validation-errors.patch
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..733e88560b9d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Binary files, as well as any files describing changes ("patches") to the software that is being built are excluded from this license. They are provided under the license terms of the software they describe changes for.
+
+Any files containing a license notice are excluded from this license. They are provided under the license terms defined in their respective notices.
+
+Copyright 2024 Arch Linux Contributors
+
+Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is hereby granted.
+
+THE SOFTWARE IS PROVIDED “AS IS” AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1eaa4c35a346
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
+pkgname=web-archives
+_app_id=com.github.birros.WebArchives
+pkgver=0.5.0
+pkgrel=1
+_dr_ver=0.0.1
+pkgdesc="A web archives reader"
+arch=('x86_64')
+url="https://github.com/birros/web-archives"
+license=('GPL-3.0-or-later')
+depends=(
+ 'gtk3'
+ 'libhandy'
+ 'libisocodes'
+ 'libsoup3'
+ 'libzim-glib'
+ 'sqlite'
+ 'tinysparql'
+ 'webkit2gtk-4.1'
+)
+makedepends=(
+ 'meson'
+ 'vala'
+)
+checkdepends=('appstream')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz"
+ "https://github.com/birros/web-archives-darkreader/releases/download/v${_dr_ver}/web-archives-darkreader_v${_dr_ver}.js"
+ 'fix-appstream-validation-errors.patch')
+sha256sums=('10bdaf25633d9b23385c31000a5dce02146da5d2daf73b13a03881b1ecaf77f5'
+ '8ee840aacd9e09864a7ab2e75f736f696dcd4b4b8e86a07ba727ff3d10ef32a1'
+ 'bb4bbec3852b373939ed21c26c14b98b015a8038597c5bd95c47078648f9d88c')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # Copy darkreader script to build-aux directory
+ cp -f "$srcdir/web-archives-darkreader_v${_dr_ver}.js" build-aux/darkreader
+
+ # Don't download darkreader script
+ sed -i '/curl -L/d' build-aux/darkreader/Makefile
+
+ # Fixed upstream
+ patch -Np1 -i "$srcdir/fix-appstream-validation-errors.patch"
+}
+
+build() {
+ arch-meson "$pkgname-$pkgver" build
+ meson compile -C build
+}
+
+check() {
+ appstreamcli validate --no-net "build/data/appdata/${_app_id}.appdata.xml"
+ desktop-file-validate "build/data/desktop/${_app_id}.desktop"
+}
+
+package() {
+ meson install -C build --no-rebuild --destdir "$pkgdir"
+}
diff --git a/fix-appstream-validation-errors.patch b/fix-appstream-validation-errors.patch
new file mode 100644
index 000000000000..6d7e095a1b9e
--- /dev/null
+++ b/fix-appstream-validation-errors.patch
@@ -0,0 +1,147 @@
+From 5c2e59e157a77b8f514b9a64c64190543b97debc Mon Sep 17 00:00:00 2001
+From: birros <birros@protonmail.com>
+Date: Mon, 17 Mar 2025 14:55:28 +0100
+Subject: [PATCH] fix: fix appstream validation errors
+
+---
+ README.md | 6 ++
+ ...m.github.birros.WebArchives.appdata.xml.in | 61 ++++++++++---------
+ 2 files changed, 38 insertions(+), 29 deletions(-)
+
+diff --git a/README.md b/README.md
+index af8e9a3..803c321 100644
+--- a/README.md
++++ b/README.md
+@@ -92,11 +92,17 @@ $ flatpak install -y \
+ $ flatpak run --command=flatpak-builder-lint org.flatpak.Builder \
+ --exceptions \
+ manifest build-aux/flatpak/com.github.birros.WebArchives.yml
++$ flatpak run --command=flatpak-builder-lint org.flatpak.Builder \
++ --exceptions \
++ appstream data/appdata/com.github.birros.WebArchives.appdata.xml.in
+ $ flatpak-builder \
+ --ccache \
+ --force-clean \
+ --repo=.flatpak-repo \
+ .flatpak-builddir build-aux/flatpak/com.github.birros.WebArchives.yml
++$ flatpak run --command=flatpak-builder-lint org.flatpak.Builder \
++ --exceptions \
++ repo .flatpak-repo
+ $ flatpak remote-add --no-gpg-verify webarchives-repo .flatpak-repo
+ $ flatpak install -y webarchives-repo com.github.birros.WebArchives
+ ```
+diff --git a/data/appdata/com.github.birros.WebArchives.appdata.xml.in b/data/appdata/com.github.birros.WebArchives.appdata.xml.in
+index 8377953..9d1b6e7 100644
+--- a/data/appdata/com.github.birros.WebArchives.appdata.xml.in
++++ b/data/appdata/com.github.birros.WebArchives.appdata.xml.in
+@@ -2,78 +2,81 @@
+ <!-- Copyright 2017 Birros <birros@protonmail.com> -->
+ <component type="desktop">
+ <id>com.github.birros.WebArchives.desktop</id>
++ <launchable type="desktop-id">com.github.birros.WebArchives.desktop</launchable>
+ <metadata_license>CC0</metadata_license>
+ <project_license>GPL-3.0+</project_license>
++ <developer id="com.github.birros">
++ <name>birros</name>
++ </developer>
+ <name>WebArchives</name>
+- <name xml:lang="fr">WebArchives</name>
+ <summary>A web archives viewer</summary>
+- <summary xml:lang="fr">Un visionneur d'archives web</summary>
++ <!-- <summary xml:lang="fr">Un visionneur d'archives web</summary> -->
+ <description>
+ <p>
+ A web archives viewer offering the ability to browse offline
+ millions of articles from large community projects such as Wikipedia
+ or Wikisource.
+ </p>
++ <p xml:lang="fr">
++ Un visionneur d'archives web qui offre la possibilité de parcourir
++ hors-ligne des millions d'articles provenant de grands projets
++ communautaires tels que Wikipédia ou Wikisource.
++ </p>
+ <p>Features:</p>
++ <p xml:lang="fr">Fonctionnalités :</p>
+ <ul>
+ <li>List recently opened web archives</li>
++ <li xml:lang="fr">Liste des archives web récemment ouvertes</li>
+ <li>List available local web archives</li>
++ <li xml:lang="fr">Liste des archives web locales disponibles</li>
+ <li>List of web archives available to download</li>
++ <li xml:lang="fr">Liste des archives web à télécharger</li>
+ <li>Print a page</li>
++ <li xml:lang="fr">Imprimer une page</li>
+ <li>Night mode (Darkreader)</li>
++ <li xml:lang="fr">Mode nuit (Darkreader)</li>
+ <li>Zoom controls</li>
++ <li xml:lang="fr">Commandes de zoom</li>
+ <li>Search in page</li>
++ <li xml:lang="fr">Chercher dans la page</li>
+ <li>History</li>
++ <li xml:lang="fr">Historique</li>
+ <li>Bookmarks</li>
++ <li xml:lang="fr">Signets</li>
+ <li>Search a page</li>
++ <li xml:lang="fr">Chercher une page</li>
+ <li>Keyboard shortcuts</li>
++ <li xml:lang="fr">Raccourcis clavier</li>
+ <li>Multi-windows</li>
++ <li xml:lang="fr">Multi-fenêtres</li>
+ <li>Multi-tabs</li>
++ <li xml:lang="fr">Multi-onglets</li>
+ <li>Random page</li>
++ <li xml:lang="fr">Page au hasard</li>
+ <li>Sandboxed pages (Pages are isolated from the web)</li>
++ <li xml:lang="fr">Pages en bac à sable (les pages sont isolées du Web)</li>
+ <li>Ask for confirmation when opening an external link</li>
++ <li xml:lang="fr">Demander confirmation lors de l'ouverture d'un lien externe</li>
+ <li>Handle the opening of zim files from external applications (Nautilus...)</li>
+- </ul>
+- </description>
+- <description xml:lang="fr">
+- <p>
+- Un visionneur d'archives web qui offre la possibilité de parcourir
+- hors-ligne des millions d'articles provenant de grands projets
+- communautaires tels que Wikipédia ou Wikisource.
+- </p>
+- <p>Fonctionnalités :</p>
+- <ul>
+- <li>Liste des archives web récemment ouvertes</li>
+- <li>Liste des archives web locales disponibles</li>
+- <li>Liste des archives web à télécharger</li>
+- <li>Imprimer une page</li>
+- <li>Mode nuit (Darkreader)</li>
+- <li>Commandes de zoom</li>
+- <li>Chercher dans la page</li>
+- <li>Historique</li>
+- <li>Signets</li>
+- <li>Chercher une page</li>
+- <li>Raccourcis clavier</li>
+- <li>Multi-fenêtres</li>
+- <li>Multi-onglets</li>
+- <li>Page au hasard</li>
+- <li>Pages en bac à sable (les pages sont isolées du Web)</li>
+- <li>Demander confirmation lors de l'ouverture d'un lien externe</li>
+- <li>Gérer l'ouverture des fichiers zim depuis une application externe (Nautilus...)</li>
++ <li xml:lang="fr">Gérer l'ouverture des fichiers zim depuis une application externe (Nautilus...)</li>
+ </ul>
+ </description>
+ <screenshots>
+ <screenshot type="default">
+ <image width="800" height="450">https://raw.githubusercontent.com/birros/web-archives/master/data/appdata/screenshots/home.png</image>
++ <caption>Home page</caption>
+ </screenshot>
+ <screenshot>
+ <image width="800" height="450">https://raw.githubusercontent.com/birros/web-archives/master/data/appdata/screenshots/web-wikipedia.png</image>
++ <caption>Wikipedia home page example</caption>
+ </screenshot>
+ <screenshot>
+ <image width="800" height="450">https://raw.githubusercontent.com/birros/web-archives/master/data/appdata/screenshots/search.png</image>
++ <caption>Search example</caption>
+ </screenshot>
+ <screenshot>
+ <image width="800" height="450">https://raw.githubusercontent.com/birros/web-archives/master/data/appdata/screenshots/web-earth.png</image>
++ <caption>Wikipedia page example</caption>
+ </screenshot>
+ </screenshots>
+ <content_rating type="oars-1.1">