summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevku2023-05-04 19:03:36 +0300
committerkevku2023-05-04 19:03:36 +0300
commit40571999ecd822216cbb9adfa3e96c9fcb7d6959 (patch)
treed7926386368db20775d5e82629f55d0b69ea0c17
parentccdff314512365ffa7604c4004d9cff1bb08f697 (diff)
downloadaur-40571999ecd822216cbb9adfa3e96c9fcb7d6959.tar.gz
v2.3.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
-rw-r--r--pcsc-mock-gcc13-cstdint.patch12
3 files changed, 27 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9256550a02b..850cf2dc4e5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = web-eid
- pkgver = 2.3.0.619
+ pkgver = 2.3.1.619
pkgrel = 1
url = https://www.id.ee/
arch = x86_64
@@ -15,16 +15,18 @@ pkgbase = web-eid
depends = pcsclite
depends = hicolor-icon-theme
conflicts = chrome-token-signing
- source = web-eid::git+https://github.com/web-eid/web-eid-app.git?signed#tag=v2.3.0
+ source = web-eid::git+https://github.com/web-eid/web-eid-app.git?signed#tag=v2.3.1
source = web-eid-libelectronic-id::git+https://github.com/web-eid/libelectronic-id.git
source = web-eid-libpcsc-cpp::git+https://github.com/web-eid/libpcsc-cpp.git
source = web-eid-libpcsc-mock::git+https://github.com/web-eid/libpcsc-mock.git
+ source = pcsc-mock-gcc13-cstdint.patch
validpgpkeys = 1282B0F8809D0DC632C85A3F86B611CE24492160
validpgpkeys = D1EBC666EFCBFBD3CFC2EBAA90C0B5E75C3B195D
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 9562b20ad20fe45ef13d61e6ac71438a64a3a4acb990ff976d1428200b2db175
pkgname = web-eid-native
pkgdesc = Web eID native application
diff --git a/PKGBUILD b/PKGBUILD
index a5089d211f6b..cce7c3756242 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: kevku <kevku@gmx.com>
pkgbase=web-eid
pkgname=("web-eid-native" "web-eid-firefox" "web-eid-chrome")
-pkgver=2.3.0.619
-_rls_tag=v2.3.0
+pkgver=2.3.1.619
+_rls_tag=v2.3.1
pkgrel=1
arch=('x86_64')
url="https://www.id.ee/"
@@ -13,8 +13,13 @@ makedepends=('git' 'qt6-tools' 'gtest' 'gmock' 'cmake')
source=("$pkgbase::git+https://github.com/web-eid/web-eid-app.git?signed#tag=$_rls_tag"
"web-eid-libelectronic-id::git+https://github.com/web-eid/libelectronic-id.git"
"web-eid-libpcsc-cpp::git+https://github.com/web-eid/libpcsc-cpp.git"
- "web-eid-libpcsc-mock::git+https://github.com/web-eid/libpcsc-mock.git")
-sha256sums=("SKIP" "SKIP" "SKIP" "SKIP")
+ "web-eid-libpcsc-mock::git+https://github.com/web-eid/libpcsc-mock.git"
+ "pcsc-mock-gcc13-cstdint.patch")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '9562b20ad20fe45ef13d61e6ac71438a64a3a4acb990ff976d1428200b2db175')
validpgpkeys=(
'1282B0F8809D0DC632C85A3F86B611CE24492160' # Mart Somermaa https://github.com/mrts.gpg
'D1EBC666EFCBFBD3CFC2EBAA90C0B5E75C3B195D' # Raul Metsma
@@ -38,6 +43,8 @@ prepare() {
git submodule init
git config submodule.tests/lib/libpcsc-mock.url $srcdir/web-eid-libpcsc-mock
git -c protocol.file.allow=always submodule update
+ cd "tests/lib/libpcsc-mock"
+ patch -p1 -i "$srcdir/pcsc-mock-gcc13-cstdint.patch"
}
build() {
diff --git a/pcsc-mock-gcc13-cstdint.patch b/pcsc-mock-gcc13-cstdint.patch
new file mode 100644
index 000000000000..080ccde87b87
--- /dev/null
+++ b/pcsc-mock-gcc13-cstdint.patch
@@ -0,0 +1,12 @@
+diff --git a/include/pcsc-mock/pcsc-mock.hpp b/include/pcsc-mock/pcsc-mock.hpp
+index e9e9837..a0da0cb 100644
+--- a/include/pcsc-mock/pcsc-mock.hpp
++++ b/include/pcsc-mock/pcsc-mock.hpp
+@@ -27,6 +27,7 @@
+ #include <map>
+ #include <vector>
+ #include <stdexcept>
++#include <cstdint>
+
+ #ifdef _WIN32
+ using MOCK_LONG = int32_t;