summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkevku2023-08-18 09:26:44 +0300
committerkevku2023-08-18 09:26:44 +0300
commit0c0393ae8f571f555552641930f25db5721ecaa7 (patch)
tree9e3c725bb394e5e33662018487c7e8f96ac6ae83
parentce343a02aa1f91b32ad1cea5d418f50218c0e8b4 (diff)
downloadaur-0c0393ae8f571f555552641930f25db5721ecaa7.tar.gz
fix crx manifest
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fe8ee39b23d1..180b7062e4a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = web-eid-webextension
pkgdesc = Web eID browser extension
pkgver = 2.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://web-eid.eu/
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 4f7fd7616b32..7ff988b9fa80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgbase=web-eid-webextension
pkgname=("firefox-extension-web-eid" "chromium-extension-web-eid")
pkgver=2.2.1
-pkgrel=2
+pkgrel=3
pkgdesc="Web eID browser extension"
arch=('any')
url="https://web-eid.eu/"
@@ -26,7 +26,7 @@ prepare() {
build() {
cd "$srcdir/$pkgbase"
npm install --cache "${srcdir}/npm-cache"
- SOURCE_DATE_EPOCH=$(git log -1 --pretty=%ct) npm run clean build package
+ SOURCE_DATE_EPOCH=$(git log -1 --pretty=%ct) TOKEN_SIGNING_BACKWARDS_COMPATIBILITY=true npm run clean build package
}
package_firefox-extension-web-eid() {
@@ -60,7 +60,7 @@ package_chromium-extension-web-eid() {
openssl rsa -pubout -outform DER < "$pkgbase.pem" > "$pkgbase.pub" 2>/dev/null
crx_id=$(xxd -p -c0 "$pkgbase.crxid" | tr '0-9a-f' 'a-p')
cd chrome
- jq --ascii-output --arg key $(cat "../$pkgbase.pub" | base64 -w0) '. + {key: $key}' manifest.json > manifest.json.new
+ jq --ascii-output --arg key $(cat "../$pkgbase.pub" | base64 -w0) '. + {key: $key, default_locale: "en"}' manifest.json > manifest.json.new
mv manifest.json.new manifest.json
zip -qr -9 -X "../$pkgbase.zip" .
cd ..