summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathas2015-06-09 23:17:38 -0300
committerJonathas2015-06-09 23:17:38 -0300
commit6a680bf0364905a1293b7e212fc62c6d4f86ee31 (patch)
tree8f4a2e2d0611ee22492781830c1e23bb0fafed72
downloadaur-6a680bf0364905a1293b7e212fc62c6d4f86ee31.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e88a08e6f818
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = web-to-webm
+ pkgdesc = Gui tool for extracting webm clips from Youtube and many other video hosting services
+ pkgver = 0.7.2
+ pkgrel = 1
+ url = https://solusipse.github.io/web-to-webm/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = youtube-dl
+ depends = ffmpeg
+ depends = qt5-base
+ source = https://github.com/solusipse/web-to-webm/archive/0.7.2.tar.gz
+ sha256sums = e97327b5ec2fbdaf67b945357bb188fd2451a831463d73bdb81aadc4f6a2b5e1
+
+pkgname = web-to-webm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d35c8102d0f4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jon Ribeiro <contact@jonathas.com>
+pkgname=web-to-webm
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="Gui tool for extracting webm clips from Youtube and many other video hosting services"
+arch=("i686" "x86_64")
+url="https://solusipse.github.io/web-to-webm/"
+license=('MIT')
+depends=('youtube-dl' 'ffmpeg' 'qt5-base')
+
+source=("https://github.com/solusipse/${pkgname}/archive/${pkgver}.tar.gz")
+
+sha256sums=('e97327b5ec2fbdaf67b945357bb188fd2451a831463d73bdb81aadc4f6a2b5e1')
+
+package() {
+ install -d "$pkgdir"/opt
+ qmake-qt5 "$srcdir"/${pkgname}-${pkgver}/${pkgname}.pro
+ make || return 1
+ make clean
+ cp -R "$srcdir" "$pkgdir"/opt/${pkgname}
+
+ find "$pkgdir"/opt/${pkgname}/ -type f -exec chmod 755 {} \;
+ chmod 755 "$pkgdir"/opt/${pkgname}/${pkgname}
+
+ install -d "$pkgdir"/usr/bin
+ ln -s "$pkgdir"/opt/${pkgname}/${pkgname} "$pkgdir"/usr/bin/${pkgname}
+
+ rm "$pkgdir"/opt/${pkgname}/${pkgver}.tar.gz #Removing the symbolic link
+ rm "$pkgdir"/opt/${pkgname}/Makefile
+ rm -R "$pkgdir"/opt/${pkgname}/${pkgname}-${pkgver}
+}
+