summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorinfury2021-10-16 00:10:40 -0400
committerinfury2021-10-16 00:10:40 -0400
commit21ee3ee5659fa00cc38115245f36af26559ff77a (patch)
treef4a7b4f7bb217a9be2b4afced0ede8031f80f83b
parent6f4bc4892039104780ceb97eef4966ebeee35339 (diff)
downloadaur-21ee3ee5659fa00cc38115245f36af26559ff77a.tar.gz
update to 29.3.1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f710cc7e350..1dd16aac522a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = webbrowser-git
pkgdesc = A Goanna/UXP based browser with no spyware.
- pkgver = v29.3.0.r0.g81f63a8
+ pkgver = v29.3.1.r1.g61f7aaa
pkgrel = 1
url = https://git.nuegia.net/webbrowser.git/
arch = i686
@@ -14,6 +14,7 @@ pkgbase = webbrowser-git
makedepends = zip
makedepends = yasm
makedepends = ffmpeg
+ makedepends = gcc10
makedepends = libxt
makedepends = libffi
makedepends = dbus
@@ -32,10 +33,12 @@ pkgbase = webbrowser-git
optdepends = hunspell: spell checker and morphological analyzer
optdepends = hyphen: library for hyphenation and justification
provides = palemoon
+ provides = firefox
+ conflicts = palemoon
+ conflicts = palemoon-git
source = git+https://git.nuegia.net/webbrowser.git
source = git+https://git.nuegia.net/UXP
md5sums = SKIP
md5sums = SKIP
pkgname = webbrowser-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f01d783c084c..24ade0a94cc5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,20 @@
# Maintainer <veryangry at snopyta dot org>
_pkgname=webbrowser
-_pkgver=29.3.0
+_pkgver=29.3.1
pkgname="$_pkgname"-git
-pkgver=v29.3.0.r0.g81f63a8
+pkgrel=1
+pkgver=v29.3.1.r1.g61f7aaa
pkgrel=1
pkgdesc="A Goanna/UXP based browser with no spyware."
arch=('i686' 'x86_64')
url="https://git.nuegia.net/webbrowser.git/"
license=('MPL' 'GPL')
depends=('gtk2' 'dbus-glib' 'libxt' 'alsa-lib')
-makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'ffmpeg' 'libxt' 'libffi' 'dbus' 'dbus-glib' 'gtk2' 'alsa-lib' 'libvpx' 'fontconfig' 'jack2' 'libpng' 'freetype2')
+makedepends=('git' 'python2' 'autoconf2.13' 'unzip' 'zip' 'yasm' 'ffmpeg' 'gcc10' 'libxt' 'libffi' 'dbus' 'dbus-glib' 'gtk2' 'alsa-lib' 'libvpx' 'fontconfig' 'jack2' 'libpng' 'freetype2')
optdepends=('hunspell: spell checker and morphological analyzer'
'hyphen: library for hyphenation and justification')
-provides=('palemoon')
+conflicts=('palemoon' 'palemoon-git')
+provides=('palemoon' 'firefox')
source=(git+"https://git.nuegia.net/webbrowser.git"
git+"https://git.nuegia.net/UXP")
md5sums=('SKIP'
@@ -22,16 +24,17 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "$_pkgname"
+ cd webbrowser
git submodule init
- git config submodule.platform.url ${srcdir}/UXP
- git submodule update --recursive
+ git submodule update
cp doc/mozconfig.example .mozconfig
sed -i "4d" .mozconfig
sed -i "4imk_add_options MOZ_OBJDIR=../wbbuild/" .mozconfig
}
build() {
cd "$_pkgname"
+ export CC=gcc-10
+ export CXX=g++-10
./mach build
./mach package
}