summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2015-06-08 11:00:05 -0300
committerGonzalo Exequiel Pedone2015-06-08 11:00:05 -0300
commit73b8a05804e9625b0cd9cf0b2abb9dc868134fcf (patch)
tree07a8ed9cfcec901deba3274ab462c5a09bd773c6
downloadaur-73b8a05804e9625b0cd9cf0b2abb9dc868134fcf.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD26
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0604f86eaef2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = webcamoid
+ pkgdesc = Webcamoid is a full featured webcam capture application.
+ pkgver = 6.0.0
+ pkgrel = 3
+ url = https://github.com/hipersayanX/webcamoid
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-tools
+ depends = qt5-quickcontrols
+ depends = qt5-multimedia
+ depends = qt5-graphicaleffects
+ depends = qt5-svg
+ depends = ffmpeg
+ depends = opencv
+ provides = webcamoid
+ conflicts = kdeplasma-applets-webcamoid
+ conflicts = webcamoid-git
+ source = https://github.com/hipersayanX/webcamoid/archive/6.0.0.tar.gz
+ md5sums = 866ac8f0243ee54c30e997448eb44e8a
+
+pkgname = webcamoid
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3f20606ec3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
+
+pkgname=webcamoid
+pkgver=6.0.0
+pkgrel=3
+pkgdesc="Webcamoid is a full featured webcam capture application."
+url='https://github.com/hipersayanX/webcamoid'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('qt5-quickcontrols' 'qt5-multimedia' 'qt5-graphicaleffects' 'qt5-svg' 'ffmpeg' 'opencv')
+makedepends=('qt5-tools')
+provides=('webcamoid')
+conflicts=('kdeplasma-applets-webcamoid' 'webcamoid-git')
+source=("https://github.com/hipersayanX/${pkgname}/archive/${pkgver}.tar.gz")
+md5sums=('866ac8f0243ee54c30e997448eb44e8a')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ qmake-qt5 Webcamoid.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ make INSTALL_ROOT="${pkgdir}" install
+}