summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSin Kim2022-07-15 00:02:17 +0900
committerSin Kim2022-07-15 00:02:17 +0900
commitf3b2348754267b9df29b10ee5b7336eb751847e3 (patch)
treeef8c3840bb6b685398eba2ea27ee98c86ec367c8
downloadaur-f3b2348754267b9df29b10ee5b7336eb751847e3.tar.gz
publish package
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD43
2 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..219504286224
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,40 @@
+pkgbase = webchanges
+ pkgdesc = Check web content for changes and notify
+ pkgver = 3.10.3
+ pkgrel = 1
+ url = https://pypi.org/project/webchanges
+ arch = any
+ license = MIT
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-cssselect
+ depends = python-html2text
+ depends = python-lxml
+ depends = python-markdown2
+ depends = python-msgpack
+ depends = python-platformdirs
+ depends = python-yaml
+ depends = python-requests
+ depends = python-urllib3
+ optdepends = python-playwright: option to use browser
+ optdepends = python-psutil: option to use browser
+ optdepends = google-chrome: option to use browser
+ optdepends = python-beautifulsoup4: beautify filter and one of html2text filter methods
+ optdepends = python-jsbeautifier: beautify filter
+ optdepends = python-cssbeautifier: beautify filter
+ optdepends = python-vobject: ical2text filter
+ optdepends = python-jq: jq filter
+ optdepends = python-pytesseract: ocr filter
+ optdepends = python-pillow: ocr filter
+ optdepends = python-pdftotext: pdf2text filter
+ optdepends = python-deepdiff: deep difference
+ optdepends = python-matrix-client: matrix reporter
+ optdepends = python-pushbullet.py: pushbullet reporter
+ optdepends = python-chump: pushover reporter
+ optdepends = python-aioxmpp: xmpp reporter
+ optdepends = python-redis: redis database
+ optdepends = python-keyring: password keyring storage
+ source = https://files.pythonhosted.org/packages/source/w/webchanges/webchanges-3.10.3.tar.gz
+ sha256sums = f6f519500fb9cbac92c2863127987158852ec6e4bfd9494180f30c0f4932962e
+
+pkgname = webchanges
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..803718dfa351
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Sin Kim <kimsin98@gmail.com>
+
+pkgname=webchanges
+pkgver=3.10.3
+pkgrel=1
+pkgdesc='Check web content for changes and notify'
+arch=('any')
+url='https://pypi.org/project/webchanges'
+license=('MIT' 'BSD')
+depends=('python-cssselect' 'python-html2text' 'python-lxml' 'python-markdown2' 'python-msgpack'
+ 'python-platformdirs' 'python-yaml' 'python-requests' 'python-urllib3')
+makedepends=('python-setuptools')
+optdepends=('python-playwright: option to use browser'
+ 'python-psutil: option to use browser'
+ 'google-chrome: option to use browser'
+ 'python-beautifulsoup4: beautify filter and one of html2text filter methods'
+ 'python-jsbeautifier: beautify filter'
+ 'python-cssbeautifier: beautify filter'
+ 'python-vobject: ical2text filter'
+ 'python-jq: jq filter'
+ 'python-pytesseract: ocr filter'
+ 'python-pillow: ocr filter'
+ 'python-pdftotext: pdf2text filter'
+ 'python-deepdiff: deep difference'
+ 'python-matrix-client: matrix reporter'
+ 'python-pushbullet.py: pushbullet reporter'
+ 'python-chump: pushover reporter'
+ 'python-aioxmpp: xmpp reporter'
+ 'python-redis: redis database'
+ 'python-keyring: password keyring storage')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=('f6f519500fb9cbac92c2863127987158852ec6e4bfd9494180f30c0f4932962e')
+
+build() {
+ cd "$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE
+}