summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2022-08-11 04:11:33 +0500
committerHanabishi2022-08-11 04:11:33 +0500
commit05baccb5e6725f0326ea6a472660e41968149cb5 (patch)
tree7a7be9465a132b351ad740d14e32856ec47eb1a7
parent430816e32f80df512f9142645a92bfe24b4585f4 (diff)
downloadaur-05baccb5e6725f0326ea6a472660e41968149cb5.tar.gz
Reinit package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 30 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3a82a202081..9f403deb83fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = webcord-bin
- pkgdesc = A Discord web-based client made with the Electron API, developed with Electron Forge.
- pkgver = 2.1.0
+ pkgdesc = A Discord and Fosscord client made with the Electron.
+ pkgver = 3.7.1
pkgrel = 1
url = https://github.com/SpacingBat3/WebCord
- arch = x86_64
+ arch = any
license = MIT
- provides = webcord-bin
+ provides = webcord
conflicts = webcord
- conflicts = webcord-git
- source = https://github.com/SpacingBat3/WebCord/releases/download/v2.1.0/webcord_2.1.0_amd64.deb
- sha512sums = 5396770ab8380281d75d6ee43e43643096c967ec91011b2b6f22a59f5985ce499d8815952d1a9159389a3c946f5c322f03fedb1f0675885c9cdd629c8911c639
+ noextract = webcord-3.7.1-1.x86_64.rpm
+ options = !strip
+ options = !emptydirs
+ source = webcord-3.7.1-1.x86_64.rpm::https://github.com/SpacingBat3/WebCord/releases/download/v3.7.1/webcord-3.7.1-1.x86_64.rpm
+ sha256sums = e3f9c6569c852e61d26d2cccfd9e155a25ba8560d75fbd9602b3581a227c1cb9
pkgname = webcord-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b5dc87a8dbbd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.rpm
+*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 67702edb248d..df409281a0d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,24 @@
-# Maintainer: zapp-brannigan <fuerst.reinje@web.de>
pkgname=webcord-bin
-pkgver=2.1.0
+pkgver=3.7.1
pkgrel=1
-pkgdesc="A Discord web-based client made with the Electron API, developed with Electron Forge."
-arch=('x86_64')
+pkgdesc="A Discord and Fosscord client made with the Electron."
+arch=('any')
url="https://github.com/SpacingBat3/WebCord"
license=('MIT')
-depends=()
-provides=("webcord-bin")
-conflicts=("webcord" "webcord-git")
-source=("${url}/releases/download/v${pkgver}/webcord_${pkgver}_amd64.deb")
-sha512sums=('5396770ab8380281d75d6ee43e43643096c967ec91011b2b6f22a59f5985ce499d8815952d1a9159389a3c946f5c322f03fedb1f0675885c9cdd629c8911c639')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+options=('!strip' '!emptydirs')
+
+_archive="webcord-${pkgver}-1.x86_64.rpm"
+
+source=("${_archive}::${url}/releases/download/v${pkgver}/${_archive}")
+sha256sums=('e3f9c6569c852e61d26d2cccfd9e155a25ba8560d75fbd9602b3581a227c1cb9')
+noextract=("${_archive}")
package() {
- bsdtar -xf "${srcdir}/webcord_${pkgver}_amd64.deb" -C "${srcdir}" --include data.tar.xz
- bsdtar -xf ${srcdir}/data.tar.xz -C ${pkgdir}
- install -d ${pkgdir}/usr/bin/
+ cd "${srcdir}"
+ bsdtar -C "${pkgdir}" \
+ -xf "${_archive}" \
+ --exclude=".build-id" \
+ --no-same-owner --no-same-permissions
}