summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2023-04-08 17:01:55 +0500
committerHanabishi2023-04-08 17:01:55 +0500
commit839de7d920459296bd87bb1196cc25ad362d0378 (patch)
tree5cd811677b967332acc0effe3c05da8e63540c20
parent37ebccf583d8249529a68e5c446d1522516f40c5 (diff)
downloadaur-839de7d920459296bd87bb1196cc25ad362d0378.tar.gz
New version (4.2.0)
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD30
2 files changed, 21 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e07ba44ec5fb..e2e0050747eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = webcord-bin
pkgdesc = A Discord and Fosscord client made with the Electron API.
- pkgver = 4.1.1
+ pkgver = 4.2.0
pkgrel = 1
url = https://github.com/SpacingBat3/WebCord
arch = x86_64
@@ -9,17 +9,15 @@ pkgbase = webcord-bin
license = MIT
provides = webcord
conflicts = webcord
- noextract = webcord-4.1.1-1.x86_64.rpm
- noextract = webcord-4.1.1-1.arm64.rpm
- noextract = webcord-4.1.1-1.armv7hl.rpm
+ noextract = webcord-4.2.0-1.x86_64.rpm
+ noextract = webcord-4.2.0-1.arm64.rpm
+ noextract = webcord-4.2.0-1.armv7hl.rpm
options = !emptydirs
- source = webcord-bin-4.1.1-LICENSE::https://raw.githubusercontent.com/SpacingBat3/WebCord/v4.1.1/LICENSE
- sha256sums = 7e8ddf98c883358508999fe6c1296b44353e624f8a4f7b6754fcfcc9aafa4456
- source_x86_64 = webcord-4.1.1-1.x86_64.rpm::https://github.com/SpacingBat3/WebCord/releases/download/v4.1.1/webcord-4.1.1-1.x86_64.rpm
- sha256sums_x86_64 = c5db73918a914bab6b00bb7f79d8e1fc41c008be5345d5ef7d9330168294f888
- source_aarch64 = webcord-4.1.1-1.arm64.rpm::https://github.com/SpacingBat3/WebCord/releases/download/v4.1.1/webcord-4.1.1-1.arm64.rpm
- sha256sums_aarch64 = 39acef53e4e6ea5f5243a0d567153a4ccad0833aea25832fb590f1e624b4d753
- source_armv7h = webcord-4.1.1-1.armv7hl.rpm::https://github.com/SpacingBat3/WebCord/releases/download/v4.1.1/webcord-4.1.1-1.armv7hl.rpm
- sha256sums_armv7h = 492e3169a54fbadd54dc165d083870b761fd3a9b28a6cbc9242175984b802a02
+ source_x86_64 = https://github.com/SpacingBat3/WebCord/releases/download/v4.2.0/webcord-4.2.0-1.x86_64.rpm
+ sha256sums_x86_64 = 121135f288d6ee654a41ab350622f91844e03af5fc55c31e544fd712b1c47d7b
+ source_aarch64 = https://github.com/SpacingBat3/WebCord/releases/download/v4.2.0/webcord-4.2.0-1.arm64.rpm
+ sha256sums_aarch64 = 95ae14f55cee899b96ef10e14dcd6af8d6e9df4f8ed74dc2929d460b2ff8caed
+ source_armv7h = https://github.com/SpacingBat3/WebCord/releases/download/v4.2.0/webcord-4.2.0-1.armv7hl.rpm
+ sha256sums_armv7h = d6a7300bd346aac11a95bcd28cf488dd198f837fe55da05a44d7df5f0a0e153a
pkgname = webcord-bin
diff --git a/PKGBUILD b/PKGBUILD
index c2493b9e019e..39f07a140227 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,43 @@
_name=webcord
pkgname=${_name}-bin
-pkgver=4.1.1
+pkgver=4.2.0
pkgrel=1
pkgdesc="A Discord and Fosscord client made with the Electron API."
arch=('x86_64' 'aarch64' 'armv7h')
-_repo='SpacingBat3/WebCord'
-url="https://github.com/${_repo}"
+url="https://github.com/SpacingBat3/WebCord"
license=('MIT')
-_name="${pkgname%-*}"
provides=("${_name}")
conflicts=("${_name}")
options=('!emptydirs')
_get_source() {
- local archive="webcord-${pkgver}-1.$1.rpm"
- echo "${archive}::${url}/releases/download/v${pkgver}/${archive}"
+ echo "${url}/releases/download/v${pkgver}/webcord-${pkgver}-1.$1.rpm"
}
-source=("${pkgname}-${pkgver}-LICENSE::https://raw.githubusercontent.com/${_repo}/v${pkgver}/LICENSE")
source_x86_64=("$(_get_source x86_64)")
source_aarch64=("$(_get_source arm64)")
source_armv7h=("$(_get_source armv7hl)")
-sha256sums=('7e8ddf98c883358508999fe6c1296b44353e624f8a4f7b6754fcfcc9aafa4456')
-sha256sums_x86_64=('c5db73918a914bab6b00bb7f79d8e1fc41c008be5345d5ef7d9330168294f888')
-sha256sums_aarch64=('39acef53e4e6ea5f5243a0d567153a4ccad0833aea25832fb590f1e624b4d753')
-sha256sums_armv7h=('492e3169a54fbadd54dc165d083870b761fd3a9b28a6cbc9242175984b802a02')
+sha256sums_x86_64=('121135f288d6ee654a41ab350622f91844e03af5fc55c31e544fd712b1c47d7b')
+sha256sums_aarch64=('95ae14f55cee899b96ef10e14dcd6af8d6e9df4f8ed74dc2929d460b2ff8caed')
+sha256sums_armv7h=('d6a7300bd346aac11a95bcd28cf488dd198f837fe55da05a44d7df5f0a0e153a')
noextract=(
- "${source_x86_64[0]%%::*}"
- "${source_aarch64[0]%%::*}"
- "${source_armv7h[0]%%::*}"
+ "${source_x86_64[0]##*/}"
+ "${source_aarch64[0]##*/}"
+ "${source_armv7h[0]##*/}"
)
package() {
local sname="source_${CARCH}"
- bsdtar -xf "${!sname[0]%%::*}" \
+ bsdtar -xf "${!sname[0]##*/}" \
-C "${pkgdir}" \
--exclude="usr/lib/.build-id" \
--exclude="usr/bin" \
--exclude="usr/share/doc"
local bin="${pkgdir}/usr/bin"
- local licenses="${pkgdir}/usr/share/licenses/${pkgname}"
- install -dm755 "${bin}" "${licenses}"
-
+ install -dm755 "${bin}"
mv "${pkgdir}/usr/lib" "${pkgdir}/opt"
ln -s "/opt/${_name}/${_name}" "${bin}/${_name}"
- install -Dm644 "${source[0]%%::*}" "${licenses}/LICENSE"
}