summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHanabishi2022-09-11 21:42:15 +0500
committerHanabishi2022-09-11 21:42:15 +0500
commita2f8df0429f2cafc54866ab11ecff800c21e3e64 (patch)
tree72949ffd1cc1dba8486833b8d048f9e99ff3f009
parent24cf836b61fa14889b7bf6348c89059a199b9534 (diff)
downloadaur-a2f8df0429f2cafc54866ab11ecff800c21e3e64.tar.gz
New version (3.8.2)
+ package more architectures
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD28
2 files changed, 33 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b99e6ae16e0d..5c417310a28f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,23 @@
pkgbase = webcord-bin
pkgdesc = A Discord and Fosscord client made with the Electron.
- pkgver = 3.8.1
+ pkgver = 3.8.2
pkgrel = 1
url = https://github.com/SpacingBat3/WebCord
arch = x86_64
+ arch = aarch64
+ arch = armv7h
license = MIT
provides = webcord
conflicts = webcord
- noextract = webcord-3.8.1-1.x86_64.rpm
+ noextract = webcord-3.8.2-1.x86_64.rpm
+ noextract = webcord-3.8.2-1.arm64.rpm
+ noextract = webcord-3.8.2-1.armv7hl.rpm
options = !emptydirs
- source = webcord-3.8.1-1.x86_64.rpm::https://github.com/SpacingBat3/WebCord/releases/download/v3.8.1/webcord-3.8.1-1.x86_64.rpm
- sha256sums = 0adfa4a162233ca3f3a5c393f1e34427f06a2ab6e087e42092990a32a59ffcce
+ source_x86_64 = webcord-3.8.2-1.x86_64.rpm::https://github.com/SpacingBat3/WebCord/releases/download/v3.8.2/webcord-3.8.2-1.x86_64.rpm
+ sha256sums_x86_64 = 45a907a71cb915d54f9d7a8fb0f6f98a5415724fc1063915bbbe455a5477e412
+ source_aarch64 = webcord-3.8.2-1.arm64.rpm::https://github.com/SpacingBat3/WebCord/releases/download/v3.8.2/webcord-3.8.2-1.arm64.rpm
+ sha256sums_aarch64 = 933479235fba0a795e4bd4baa6217e33368e6c87ccef6faca2b4eab53f38f4ab
+ source_armv7h = webcord-3.8.2-1.armv7hl.rpm::https://github.com/SpacingBat3/WebCord/releases/download/v3.8.2/webcord-3.8.2-1.armv7hl.rpm
+ sha256sums_armv7h = 442748115aad8c102fea34e9543685e8d65575a89e73b3d22af7cacc4bf9cbea
pkgname = webcord-bin
diff --git a/PKGBUILD b/PKGBUILD
index d6b2ec8f265e..98280da65e78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=webcord-bin
-pkgver=3.8.1
+pkgver=3.8.2
pkgrel=1
pkgdesc="A Discord and Fosscord client made with the Electron."
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'armv7h')
url="https://github.com/SpacingBat3/WebCord"
license=('MIT')
_name="${pkgname%-bin}"
@@ -10,16 +10,30 @@ provides=("${_name}")
conflicts=("${_name}")
options=('!emptydirs')
-_archive="webcord-${pkgver}-1.x86_64.rpm"
+_get_source() {
+ local archive="webcord-${pkgver}-1.$1.rpm"
+ echo "${archive}::${url}/releases/download/v${pkgver}/${archive}"
+}
+
+source_x86_64=("$(_get_source x86_64)")
+source_aarch64=("$(_get_source arm64)")
+source_armv7h=("$(_get_source armv7hl)")
+
+sha256sums_x86_64=('45a907a71cb915d54f9d7a8fb0f6f98a5415724fc1063915bbbe455a5477e412')
+sha256sums_aarch64=('933479235fba0a795e4bd4baa6217e33368e6c87ccef6faca2b4eab53f38f4ab')
+sha256sums_armv7h=('442748115aad8c102fea34e9543685e8d65575a89e73b3d22af7cacc4bf9cbea')
-source=("${_archive}::${url}/releases/download/v${pkgver}/${_archive}")
-sha256sums=('0adfa4a162233ca3f3a5c393f1e34427f06a2ab6e087e42092990a32a59ffcce')
-noextract=("${_archive}")
+noextract=(
+ "${source_x86_64[0]%%::*}"
+ "${source_aarch64[0]%%::*}"
+ "${source_armv7h[0]%%::*}"
+)
package() {
cd "${srcdir}"
- bsdtar -xf "${_archive}" \
+ local sname="source_${CARCH}"
+ bsdtar -xf "${!sname[0]%%::*}" \
-C "${pkgdir}" \
--exclude="usr/lib/.build-id" \
--exclude="usr/bin"