summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Sulfrian2021-05-12 12:25:47 +0200
committerAlexander Sulfrian2021-05-12 12:26:26 +0200
commitb34f5e546719025a73e4546f8fa8f45280b5bedd (patch)
treec932c73c3343163fa6446ceee832829bf8209724
downloadaur-b34f5e546719025a73e4546f8fa8f45280b5bedd.tar.gz
Initial port of the deb package
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 84 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..308a5e053b32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = webex-bin
+ pkgdesc = Webex for Linux
+ pkgver = 41.5.0.18815
+ pkgrel = 1
+ url = https://www.webex.com/
+ arch = x86_64
+ license = custom
+ depends = binutils
+ depends = xdg-utils
+ depends = mesa
+ depends = nss
+ depends = nspr
+ depends = libcups
+ depends = upower
+ depends = libnotify
+ depends = libsecret
+ depends = wayland
+ depends = atk
+ depends = at-spi2-atk
+ depends = pango
+ depends = at-spi2-core
+ depends = krb5
+ depends = alsa-lib
+ depends = systemd-libs
+ depends = libpulse
+ depends = libxcb
+ depends = xcb-util-renderutil
+ depends = xcb-util-keysyms
+ depends = xcb-util-image
+ depends = xcb-util-wm
+ depends = libxkbcommon-x11
+ source = webex-bin-41.5.0.18815.deb::https://binaries.webex.com/WebexDesktop-Ubuntu-Official-Package/Webex.deb
+ sha256sums = 9aae10d54026f93da034baf2b5f1167a1e6f80d7b9f6ffcd1b1b9db66e1ff274
+
+pkgname = webex-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1012f5b27d02
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src
+/pkg
+*.pkg*
+*.deb
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a3802a895bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Alexander Sulfrian <asulfrian@zedat.fu-berlin.de>
+pkgname=webex-bin
+pkgver=41.5.0.18815
+pkgrel=1
+pkgdesc="Webex for Linux"
+arch=('x86_64')
+url="https://www.webex.com/"
+license=('custom')
+depends=('binutils'
+ 'xdg-utils'
+ 'mesa'
+ 'nss'
+ 'nspr'
+ 'libcups'
+ 'upower'
+ 'libnotify'
+ 'libsecret'
+ 'wayland'
+ 'atk'
+ 'at-spi2-atk'
+ 'pango'
+ 'at-spi2-core'
+ 'krb5'
+ 'alsa-lib'
+ 'systemd-libs'
+ 'libpulse'
+ 'libxcb'
+ 'xcb-util-renderutil'
+ 'xcb-util-keysyms'
+ 'xcb-util-image'
+ 'xcb-util-wm'
+ 'libxkbcommon-x11')
+source=("$pkgname-$pkgver.deb::https://binaries.webex.com/WebexDesktop-Ubuntu-Official-Package/Webex.deb")
+sha256sums=('9aae10d54026f93da034baf2b5f1167a1e6f80d7b9f6ffcd1b1b9db66e1ff274')
+
+prepare() {
+ mkdir -p "$pkgname-$pkgver"
+ tar -Jxf data.tar.xz -C "$pkgname-$pkgver"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ cp -a opt/ "$pkgdir/"
+}