summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduard Toloza2018-11-14 20:17:53 -0500
committerEduard Toloza2018-11-14 20:17:53 -0500
commitc2c09f0b25af1d8c390d568e0cf065f6ebf10e99 (patch)
treeeb09808962c16d21dc6c0ef049282105d603cb29
parent7e5514e798c60f68b22ff07f116718c59f8f934b (diff)
downloadaur-webhackshl.tar.gz
Update tool
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c5d7daefc986..a70f67b24983 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = webhackshl
pkgdesc = Herramienta para hacking ético y auditorías en sitios web y servidores.
- pkgver = 9.ef1f3fb
+ pkgver = 10.1d9afd5
pkgrel = 1
url = https://gitlab.com/sechacklabs/webhackshl
install = webhackshl.install
arch = any
license = GPL
makedepends = git
- makedepends = ruby-bundler
depends = nmap
depends = fierce
depends = sqlmap
@@ -25,6 +24,7 @@ pkgbase = webhackshl
depends = python2-requests
depends = python2-yaml
depends = python2-flask
+ depends = ruby-bundler
source = git+https://gitlab.com/sechacklabs/webhackshl.git
sha1sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 3534d0d1d522..05f7a6a0d4be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Maintainer: Eduard Toloza <edu4rdshl@securityhacklabs.net>
pkgname='webhackshl'
-pkgver=9.ef1f3fb
+pkgver=10.1d9afd5
pkgrel=1
pkgdesc='Herramienta para hacking ético y auditorías en sitios web y servidores.'
arch=('any')
url='https://gitlab.com/sechacklabs/webhackshl'
license=('GPL')
-depends=('nmap' 'fierce' 'sqlmap' 'dnsenum' 'nikto' 'whatweb' 'wpscan' 'ruby' 'git' 'curl' 'tor' 'gzip' 'john' 'python' 'python2-requests' 'python2-yaml' 'python2-flask')
-makedepends=('git' 'ruby-bundler')
+depends=('nmap' 'fierce' 'sqlmap' 'dnsenum' 'nikto' 'whatweb' 'wpscan' 'ruby' 'git' 'curl' 'tor' 'gzip' 'john' 'python' 'python2-requests' 'python2-yaml' 'python2-flask' 'ruby-bundler')
+makedepends=('git')
source=('git+https://gitlab.com/sechacklabs/webhackshl.git')
install='webhackshl.install'
sha1sums=('SKIP')
@@ -26,18 +26,14 @@ package() {
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/webhackshl"
- #make DESTDIR="$pkgdir" install
-
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/webhackshl/LICENSE"
- rm README.md LICENSE uninstall.sh update.sh install.sh
-
cp -a * "$pkgdir/usr/share/webhackshl"
cat > "$pkgdir/usr/bin/webhackshl" << EOF
#!/bin/sh
cd /usr/share/webhackshl
-exec python webhackshl "\${@}"
+exec python webhackshl "\$@"
EOF
chmod a+x "$pkgdir/usr/bin/webhackshl"