summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdu4rdSHL2018-06-12 15:38:38 -0500
committerEdu4rdSHL2018-06-12 15:38:38 -0500
commit64db6fef2adb32e74c09e52a4bd047d921a36842 (patch)
tree3a7eed942523afbc28df82992d1d71ff9c7f9686
downloadaur-64db6fef2adb32e74c09e52a4bd047d921a36842.tar.gz
First upload
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD44
-rw-r--r--webhackshl.install9
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5751dd201a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = webhackshl
+ pkgdesc = Herramienta para hacking ético y auditorías en sitios web y servidores.
+ pkgver = 8.6ee163f
+ pkgrel = 1
+ url = https://gitlab.com/sechacklabs/webhackshl
+ install = webhackshl.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = ruby-bundler
+ depends = nmap
+ depends = fierce
+ depends = sqlmap
+ depends = dnsenum
+ depends = nikto
+ depends = whatweb
+ depends = wpscan
+ depends = ruby
+ depends = git
+ depends = curl
+ depends = tor
+ depends = gzip
+ depends = john
+ depends = python
+ depends = python2-requests
+ depends = python2-yaml
+ depends = python2-flask
+ source = git+https://gitlab.com/sechacklabs/webhackshl.git
+ sha1sums = SKIP
+
+pkgname = webhackshl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21e838a0ad6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# It file is part of Security Hack Labs Team.
+# Maintainer: Eduard Toloza <edu4rdshl@securityhacklabs.net>
+
+pkgname='webhackshl'
+pkgver=8.6ee163f
+pkgrel=1
+pkgdesc='Herramienta para hacking ético y auditorías en sitios web y servidores.'
+arch=('any')
+url='https://gitlab.com/sechacklabs/webhackshl'
+license=('GPL')
+depends=('nmap' 'fierce' 'sqlmap' 'dnsenum' 'nikto' 'whatweb' 'wpscan' 'ruby' 'git' 'curl' 'tor' 'gzip' 'john' 'python' 'python2-requests' 'python2-yaml' 'python2-flask')
+makedepends=('git' 'ruby-bundler')
+source=('git+https://gitlab.com/sechacklabs/webhackshl.git')
+install='webhackshl.install'
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/webhackshl"
+
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$srcdir/webhackshl"
+
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/webhackshl"
+
+ #make DESTDIR="$pkgdir" install
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/webhackshl/LICENSE"
+
+ rm README.md LICENSE uninstall.sh update.sh install.sh
+
+ cp -a * "$pkgdir/usr/share/webhackshl"
+
+ cat > "$pkgdir/usr/bin/webhackshl" << EOF
+#!/bin/sh
+cd /usr/share/webhackshl
+exec python webhackshl "\${@}"
+EOF
+
+ chmod a+x "$pkgdir/usr/bin/webhackshl"
+}
diff --git a/webhackshl.install b/webhackshl.install
new file mode 100644
index 000000000000..f0648d005814
--- /dev/null
+++ b/webhackshl.install
@@ -0,0 +1,9 @@
+post_install() {
+ set -e
+ cd /usr/share/webhackshl
+ bundle install --path vendor/bundle
+}
+
+post_upgrade() {
+ post_install "${@}"
+}