summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaarten de Vries2020-12-20 17:13:11 +0100
committerMaarten de Vries2020-12-20 17:18:24 +0100
commit728388145055776ce404c580e34bb21d8b092c54 (patch)
treed17b368a72c35529761e095e056692ecd6f09950
downloadaur-728388145055776ce404c580e34bb21d8b092c54.tar.gz
Initial AUR release at version 0.1.1.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1637c9e74e29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = webhook-httpd
+ pkgdesc = simple HTTP(S) server for receiving webhooks and running commands
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/de-vri-es/webhook-httpd
+ arch = x86_64
+ license = BSD
+ makedepends = rust
+ source = webhook-httpd-v0.1.1.tar.gz::https://github.com/de-vri-es/webhook-httpd/archive/v0.1.1.tar.gz
+ sha512sums = e180c8a845dd63a42105b3ee9e611f9254c20c35b2ac52633d06ae943191e3b8287149d033269bc85f29d5c519e83469c34b4acc30128293a0c513d95c9607b1
+
+pkgname = webhook-httpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f166bae1fc9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Maarten de Vries <maarten@de-vri.es>
+pkgname=webhook-httpd
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="simple HTTP(S) server for receiving webhooks and running commands"
+arch=("x86_64")
+license=(BSD)
+url="https://github.com/de-vri-es/webhook-httpd"
+
+source=("$pkgname-v$pkgver.tar.gz::https://github.com/de-vri-es/webhook-httpd/archive/v$pkgver.tar.gz")
+sha512sums=('e180c8a845dd63a42105b3ee9e611f9254c20c35b2ac52633d06ae943191e3b8287149d033269bc85f29d5c519e83469c34b4acc30128293a0c513d95c9607b1')
+
+makedepends=(rust)
+
+_dir="$pkgname-$pkgver"
+
+build() {
+ cd "$_dir"
+ cargo build --release --features 'static-openssl'
+}
+
+package() {
+ cd "$_dir"
+ install -m 755 -Dt "$pkgdir/usr/bin/" "target/release/$pkgname"
+ install -m 644 -Dt "$pkgdir/usr/share/licenses/$pkgname/" "LICENSE.md"
+}
+
+check() {
+ cd "$_dir"
+ cargo test --release --features 'static-openssl'
+}