summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxime “pep” Buquet2019-09-06 11:20:03 +0200
committerMaxime “pep” Buquet2019-09-06 11:20:55 +0200
commit75fd616cdbbab464ed864a74782175256b7fb28d (patch)
tree39f93979405b922385e504cd6dd35de7516efcae
parenteaa468113235ebfd05494f6e763e0dee61f8156d (diff)
downloadaur-75fd616cdbbab464ed864a74782175256b7fb28d.tar.gz
New patch: Update gitlab dependency
Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
-rw-r--r--.SRCINFO1
-rw-r--r--0007-Update-gitlab-dependency-to-0.1202.0.patch144
-rw-r--r--PKGBUILD5
3 files changed, 149 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36de80a8c775..ae8c284e10e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,6 +20,7 @@ pkgbase = webhook2muc-git
source = 0004-Use-proper-Presence-structure-when-receiving-stanzas.patch
source = 0005-Update-xmpp-parsers-to-0.14.patch
source = 0006-Joining-a-MUC-requires-a-FullJid-nick-as-resource.patch
+ source = 0007-Update-gitlab-dependency-to-0.1202.0.patch
sha256sums = SKIP
sha256sums = 3a3878cf71075383074bb9cea0613fc590f98285652db3d39c8fd97c1d79e0e7
sha256sums = 1f1cad56ba6f5a7b2558a3bcae96fad2fe686081d4c36d24188991d11a275348
diff --git a/0007-Update-gitlab-dependency-to-0.1202.0.patch b/0007-Update-gitlab-dependency-to-0.1202.0.patch
new file mode 100644
index 000000000000..abd7c4561c41
--- /dev/null
+++ b/0007-Update-gitlab-dependency-to-0.1202.0.patch
@@ -0,0 +1,144 @@
+From d2edaed52e094560b0a20079b55e3ad7e01720d5 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Maxime=20=E2=80=9Cpep=E2=80=9D=20Buquet?= <pep@bouah.net>
+Date: Fri, 6 Sep 2019 11:16:18 +0200
+Subject: [PATCH] Update gitlab dependency to 0.1202.0
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Maxime “pep” Buquet <pep@bouah.net>
+---
+ Cargo.lock | 42 +++++++++++++++++++++++++++++++++++++-----
+ Cargo.toml | 2 +-
+ 2 files changed, 38 insertions(+), 6 deletions(-)
+
+diff --git a/Cargo.lock b/Cargo.lock
+index ff7f654..b730dd3 100644
+--- a/Cargo.lock
++++ b/Cargo.lock
+@@ -1,3 +1,5 @@
++# This file is automatically @generated by Cargo.
++# It is not intended for manual editing.
+ [[package]]
+ name = "MacTypes-sys"
+ version = "2.1.0"
+@@ -430,7 +432,7 @@ dependencies = [
+
+ [[package]]
+ name = "gitlab"
+-version = "0.1104.1"
++version = "0.1202.0"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
+ dependencies = [
+ "chrono 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
+@@ -440,7 +442,6 @@ dependencies = [
+ "percent-encoding 1.0.1 (registry+https://github.com/rust-lang/crates.io-index)",
+ "reqwest 0.9.9 (registry+https://github.com/rust-lang/crates.io-index)",
+ "serde 1.0.85 (registry+https://github.com/rust-lang/crates.io-index)",
+- "serde_derive 1.0.85 (registry+https://github.com/rust-lang/crates.io-index)",
+ "serde_json 1.0.37 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+@@ -599,6 +600,16 @@ dependencies = [
+ "minidom 0.10.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
++[[package]]
++name = "jid"
++version = "0.6.2"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++dependencies = [
++ "failure 0.1.5 (registry+https://github.com/rust-lang/crates.io-index)",
++ "failure_derive 0.1.5 (registry+https://github.com/rust-lang/crates.io-index)",
++ "minidom 0.10.0 (registry+https://github.com/rust-lang/crates.io-index)",
++]
++
+ [[package]]
+ name = "keccak"
+ version = "0.1.0"
+@@ -1283,6 +1294,9 @@ source = "registry+https://github.com/rust-lang/crates.io-index"
+ name = "serde"
+ version = "1.0.85"
+ source = "registry+https://github.com/rust-lang/crates.io-index"
++dependencies = [
++ "serde_derive 1.0.85 (registry+https://github.com/rust-lang/crates.io-index)",
++]
+
+ [[package]]
+ name = "serde_derive"
+@@ -1719,14 +1733,14 @@ version = "0.0.1"
+ dependencies = [
+ "clap 2.32.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "futures 0.1.25 (registry+https://github.com/rust-lang/crates.io-index)",
+- "gitlab 0.1104.1 (registry+https://github.com/rust-lang/crates.io-index)",
++ "gitlab 0.1202.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "hyper 0.12.23 (registry+https://github.com/rust-lang/crates.io-index)",
+ "log 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
+ "pretty_env_logger 0.3.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ "serde_json 1.0.37 (registry+https://github.com/rust-lang/crates.io-index)",
+ "tokio 0.1.15 (registry+https://github.com/rust-lang/crates.io-index)",
+ "tokio-xmpp 1.0.0 (registry+https://github.com/rust-lang/crates.io-index)",
+- "xmpp-parsers 0.12.2 (registry+https://github.com/rust-lang/crates.io-index)",
++ "xmpp-parsers 0.14.0 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
+ [[package]]
+@@ -2032,6 +2046,22 @@ dependencies = [
+ "try_from 0.3.2 (registry+https://github.com/rust-lang/crates.io-index)",
+ ]
+
++[[package]]
++name = "xmpp-parsers"
++version = "0.14.0"
++source = "registry+https://github.com/rust-lang/crates.io-index"
++dependencies = [
++ "base64 0.10.1 (registry+https://github.com/rust-lang/crates.io-index)",
++ "blake2 0.8.0 (registry+https://github.com/rust-lang/crates.io-index)",
++ "chrono 0.4.6 (registry+https://github.com/rust-lang/crates.io-index)",
++ "digest 0.8.0 (registry+https://github.com/rust-lang/crates.io-index)",
++ "jid 0.6.2 (registry+https://github.com/rust-lang/crates.io-index)",
++ "minidom 0.10.0 (registry+https://github.com/rust-lang/crates.io-index)",
++ "sha-1 0.8.1 (registry+https://github.com/rust-lang/crates.io-index)",
++ "sha2 0.8.0 (registry+https://github.com/rust-lang/crates.io-index)",
++ "sha3 0.8.1 (registry+https://github.com/rust-lang/crates.io-index)",
++]
++
+ [metadata]
+ "checksum MacTypes-sys 2.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "eaf9f0d0b1cc33a4d2aee14fb4b2eac03462ef4db29c8ac4057327d8a71ad86f"
+ "checksum adler32 1.0.3 (registry+https://github.com/rust-lang/crates.io-index)" = "7e522997b529f05601e05166c07ed17789691f562762c7f3b987263d2dedee5c"
+@@ -2086,7 +2116,7 @@ dependencies = [
+ "checksum futures 0.1.25 (registry+https://github.com/rust-lang/crates.io-index)" = "49e7653e374fe0d0c12de4250f0bdb60680b8c80eed558c5c7538eec9c89e21b"
+ "checksum futures-cpupool 0.1.8 (registry+https://github.com/rust-lang/crates.io-index)" = "ab90cde24b3319636588d0c35fe03b1333857621051837ed769faefb4c2162e4"
+ "checksum generic-array 0.12.0 (registry+https://github.com/rust-lang/crates.io-index)" = "3c0f28c2f5bfb5960175af447a2da7c18900693738343dc896ffbcabd9839592"
+-"checksum gitlab 0.1104.1 (registry+https://github.com/rust-lang/crates.io-index)" = "30c1cb0a4f5b93483c0dd65c0c9b25ce9dafa44ebcea561b3bacf76c5693231b"
++"checksum gitlab 0.1202.0 (registry+https://github.com/rust-lang/crates.io-index)" = "94fe81db7f9744c25b40d3b27eb0f0c9d6a5d41db0eb0764d948896dfb245887"
+ "checksum h2 0.1.16 (registry+https://github.com/rust-lang/crates.io-index)" = "ddb2b25a33e231484694267af28fec74ac63b5ccf51ee2065a5e313b834d836e"
+ "checksum hmac 0.7.0 (registry+https://github.com/rust-lang/crates.io-index)" = "f127a908633569f208325f86f71255d3363c79721d7f9fe31cd5569908819771"
+ "checksum hostname 0.1.5 (registry+https://github.com/rust-lang/crates.io-index)" = "21ceb46a83a85e824ef93669c8b390009623863b5c195d1ba747292c0c72f94e"
+@@ -2102,6 +2132,7 @@ dependencies = [
+ "checksum itertools 0.7.11 (registry+https://github.com/rust-lang/crates.io-index)" = "0d47946d458e94a1b7bcabbf6521ea7c037062c81f534615abcad76e84d4970d"
+ "checksum itoa 0.4.3 (registry+https://github.com/rust-lang/crates.io-index)" = "1306f3464951f30e30d12373d31c79fbd52d236e5e896fd92f96ec7babbbe60b"
+ "checksum jid 0.5.3 (registry+https://github.com/rust-lang/crates.io-index)" = "24e8a3f2ab860aa08074136e3144a2425e678d8823206e5adcc6145dc136503a"
++"checksum jid 0.6.2 (registry+https://github.com/rust-lang/crates.io-index)" = "24e19dd087b96c214a3982d0d366f13f354c28cacda8302d6de5cdcd0d2a9726"
+ "checksum keccak 0.1.0 (registry+https://github.com/rust-lang/crates.io-index)" = "67c21572b4949434e4fc1e1978b99c5f77064153c59d998bf13ecd96fb5ecba7"
+ "checksum kernel32-sys 0.2.2 (registry+https://github.com/rust-lang/crates.io-index)" = "7507624b29483431c0ba2d82aece8ca6cdba9382bff4ddd0f7490560c056098d"
+ "checksum lazy_static 1.2.0 (registry+https://github.com/rust-lang/crates.io-index)" = "a374c89b9db55895453a74c1e38861d9deec0b01b405a82516e9d5de4820dea1"
+@@ -2260,3 +2291,4 @@ dependencies = [
+ "checksum ws2_32-sys 0.2.1 (registry+https://github.com/rust-lang/crates.io-index)" = "d59cefebd0c892fa2dd6de581e937301d8552cb44489cdff035c6187cb63fa5e"
+ "checksum xml5ever 0.12.1 (registry+https://github.com/rust-lang/crates.io-index)" = "32cd7ebf0203c620906230ce22caa5df0b603c32b6fef72a275a48f6a2ae64b9"
+ "checksum xmpp-parsers 0.12.2 (registry+https://github.com/rust-lang/crates.io-index)" = "58b4400e1ae0d246044db5fa7f2e693fdfe9cc6e8eaa72ef2a68c5dc1d3c96de"
++"checksum xmpp-parsers 0.14.0 (registry+https://github.com/rust-lang/crates.io-index)" = "6d9b3888a76736eb49018263474283390381a2dd693fe5814baf7a95a55143fc"
+diff --git a/Cargo.toml b/Cargo.toml
+index f64896f..2065fc7 100644
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -15,5 +15,5 @@ serde_json = "1.0"
+ tokio = "0.1"
+ tokio-xmpp = "1"
+ xmpp-parsers = "0.14"
+-gitlab = "0.1104"
++gitlab = "0.1202"
+ clap = "2.32"
+--
+2.23.0
+
diff --git a/PKGBUILD b/PKGBUILD
index c4167f159ddc..8b83655e7229 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,6 +22,7 @@ source=(
"0004-Use-proper-Presence-structure-when-receiving-stanzas.patch"
"0005-Update-xmpp-parsers-to-0.14.patch"
"0006-Joining-a-MUC-requires-a-FullJid-nick-as-resource.patch"
+ "0007-Update-gitlab-dependency-to-0.1202.0.patch"
)
backup=("etc/$_pkgbase/$_pkgbase.env")
@@ -42,6 +43,7 @@ prepare() {
patch -p1 < ../0004-Use-proper-Presence-structure-when-receiving-stanzas.patch
patch -p1 < ../0005-Update-xmpp-parsers-to-0.14.patch
patch -p1 < ../0006-Joining-a-MUC-requires-a-FullJid-nick-as-resource.patch
+ patch -p1 < ../0007-Update-gitlab-dependency-to-0.1202.0.patch
}
build() {
@@ -68,4 +70,5 @@ sha256sums=('SKIP'
'dceb8cdc246a48140a7b247886442be56a411716dfd0b833c41e7ca1982fe126'
'7cbad8009b5d319fc35ad064c7504b34a8c34174d87d99b3fd2f90e53baea167'
'86c29a931c5eb0121b84d81985ff9fcd908fcffae98a0e6fb1d95c3d3172ff5a'
- '9d57b4880ed1bc091004937a99881df8cf68c597830805396f123fb12660e472')
+ '9d57b4880ed1bc091004937a99881df8cf68c597830805396f123fb12660e472'
+ '5f05029d53cbf2f19bf857e9a215a77206f1edad8f685e54fd55ce3eb81daa53')