summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohannes Donath2015-10-31 16:11:40 +0100
committerJohannes Donath2015-10-31 16:12:28 +0100
commit288b1d26b908380c75e48c7a607aa676b981d651 (patch)
treea6f7b265609e8a3750475b020ed0e7e203e5a584
downloadaur-288b1d26b908380c75e48c7a607aa676b981d651.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD25
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf244da9c98e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = webify
+ pkgdesc = webfont generator - converts ttf to woff, eot and svg
+ pkgver = 0.1.7.0
+ pkgrel = 1
+ url = https://github.com/ananthakumaran/webify
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = zlib
+ depends = libffi
+ depends = gmp
+ source = LICENSE
+ md5sums = aabfb78191314e2b916dddac818da678
+
+pkgname = webify
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..59b26eb6909e
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+Copyright (c) 2013 Anantha Kumaran <ananthakumaran@gmail.com>
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd5fce1c4246
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Johannes Donath <johannesd@torchmind.com>
+pkgname=('webify')
+pkgdesc="webfont generator - converts ttf to woff, eot and svg"
+url="https://github.com/ananthakumaran/webify"
+license=('MIT')
+pkgver=0.1.7.0
+pkgrel=1
+arch=('i686' 'x86_64')
+depends=('zlib' 'libffi' 'gmp')
+source=('LICENSE')
+source_i686=('https://github.com/ananthakumaran/webify/releases/download/0.1.7.0/webify-linux-x86_32')
+source_x86_64=('https://github.com/ananthakumaran/webify/releases/download/0.1.7.0/webify-linux-x86_64')
+md5sums=('aabfb78191314e2b916dddac818da678')
+md5sums_i686=('2b61c12e9add6a5f47c688c90073ddc0')
+md5sums_x86_64=('75e1660050dd88153231945c16e32cb3')
+
+package() {
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ if [ "${CARCH}" = "i686" ]; then
+ install -D -m755 webify-linux-x86_32 "${pkgdir}/usr/bin/webify"
+ else
+ install -D -m755 webify-linux-x86_64 "${pkgdir}/usr/bin/webify"
+ fi
+}