summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLaramy Black2017-10-22 13:57:38 -0600
committerLaramy Black2017-10-22 13:57:38 -0600
commit8c5b3584a2b76d6bda2ec7f4a6b6de66be22e197 (patch)
treececc8bc73356d6af37b922367a98b95d43599e01
downloadaur-8c5b3584a2b76d6bda2ec7f4a6b6de66be22e197.tar.gz
First Push
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD52
2 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a7a48e8cfde
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = webkit2gtk-mse
+ pkgdesc = GTK+ Web content engine library
+ pkgver = 2.18.1
+ pkgrel = 1
+ url = https://webkitgtk.org/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gtk2
+ makedepends = gperf
+ makedepends = gobject-introspection
+ makedepends = ruby
+ makedepends = gtk-doc
+ makedepends = cmake
+ makedepends = python
+ makedepends = python2
+ makedepends = ninja
+ depends = libxt
+ depends = libxslt
+ depends = enchant
+ depends = geoclue2
+ depends = gst-plugins-base-libs
+ depends = gst-plugins-bad
+ depends = libsecret
+ depends = libwebp
+ depends = harfbuzz-icu
+ depends = gtk3
+ depends = libnotify
+ depends = hyphen
+ optdepends = gtk2: Netscape plugin support
+ optdepends = gst-plugins-base: free media decoding
+ optdepends = gst-plugins-good: media decoding
+ optdepends = gst-libav: nonfree media decoding
+ provides = webkit2gtk
+ conflicts = webkit2gtk
+ source = https://webkitgtk.org/releases/webkitgtk-2.18.1.tar.xz
+ source = https://webkitgtk.org/releases/webkitgtk-2.18.1.tar.xz.asc
+ validpgpkeys = D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3
+ sha256sums = 9cdb7b302fbc8a2a7e1e783b80391e64f8b12d70d6ebad4eb756dd59bf3ed795
+ sha256sums = SKIP
+
+pkgname = webkit2gtk-mse
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24b2af49c5a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# $Id$
+# Contributor: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=webkit2gtk-mse
+_pkgname=webkit2gtk
+pkgver=2.18.1
+pkgrel=1
+pkgdesc="GTK+ Web content engine library"
+arch=(i686 x86_64)
+url="https://webkitgtk.org/"
+license=(custom)
+depends=(libxt libxslt enchant geoclue2 gst-plugins-base-libs gst-plugins-bad
+ libsecret libwebp harfbuzz-icu gtk3 libnotify hyphen)
+makedepends=(gtk2 gperf gobject-introspection ruby gtk-doc cmake python python2 ninja)
+optdepends=('gtk2: Netscape plugin support'
+ 'gst-plugins-base: free media decoding'
+ 'gst-plugins-good: media decoding'
+ 'gst-libav: nonfree media decoding')
+source=(https://webkitgtk.org/releases/webkitgtk-${pkgver}.tar.xz{,.asc})
+sha256sums=('9cdb7b302fbc8a2a7e1e783b80391e64f8b12d70d6ebad4eb756dd59bf3ed795'
+ 'SKIP')
+validpgpkeys=('D7FCF61CF9A2DEAB31D81BD3F3D322D0EC4582C3')
+provides=('webkit2gtk')
+conflicts=('webkit2gtk')
+
+prepare() {
+ mkdir build
+ cd webkitgtk-$pkgver
+
+ sed -i '1s/python$/&2/' Tools/gtk/generate-gtkdoc
+ rm -r Source/ThirdParty/gtest/
+}
+
+build() {
+ cd build
+ cmake -G Ninja -DPORT=GTK -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_SKIP_RPATH=ON -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_INSTALL_DIR=/usr/lib -DLIBEXEC_INSTALL_DIR=/usr/lib/webkit2gtk-4.0 \
+ -DENABLE_GTKDOC=ON -DPYTHON_EXECUTABLE=/usr/bin/python2 -DENABLE_MEDIA_SOURCE=ON ../webkitgtk-$pkgver
+ ninja
+}
+
+package() {
+ cd build
+ DESTDIR="$pkgdir" ninja install
+
+ cd ../webkitgtk-$pkgver/Source
+ while IFS= read -d $'\0' -r _f; do
+ echo "### $_f ###"; cat "$_f"; echo
+ done < <(find . -name 'COPYING*' -or -name 'LICENSE*' -print0) \
+ | install -Dm644 /dev/stdin "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
+}