summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2020-11-21 22:32:09 -0500
committerfrealgagu2020-11-21 22:32:09 -0500
commit27c9ede305cad9f7cc38a28bf642c1490cf7e761 (patch)
treefb19d269b3955c89e501b756cceabf1410b372a9
parent41cc2b0edf05c41bd49ee3f334b9b670f0ad8d07 (diff)
downloadaur-27c9ede305cad9f7cc38a28bf642c1490cf7e761.tar.gz
Adding grammar.patch to fix issues in compilation.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
-rw-r--r--grammar.patch20
3 files changed, 29 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bd3a672a03d2..e8654bccf70a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webkitgtk
pkgdesc = Legacy Web content engine for GTK+ 3
pkgver = 2.4.11
- pkgrel = 19
+ pkgrel = 20
epoch = 3
url = https://webkitgtk.org/
install = webkitgtk.install
@@ -42,11 +42,13 @@ pkgbase = webkitgtk
source = enchant-2.x.patch
source = icu59.patch
source = pkgconfig-enchant-2.patch
+ source = grammar.patch
sha256sums = 588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7
sha256sums = e40f1e08665e1646ebc490141678f26c9c4a2792207fdf7c05978547eae9f61c
sha256sums = 7e37e059f071aaef93e387675de1a0c6a3dcf61ef67a3221a078caca69e22079
sha256sums = 4e94e35b036f8a87a64e02d747d4103c0553dfe637fda372785c2b95211445ca
sha256sums = a1e2f24b28273746b2fbaecef42495f6314c76b16a446c22dc123e6a3afb58c8
+ sha256sums = 24b49319500a79feb014ce2decd41db8ba7769c471bc8bfb42f761e2bc4d1ffb
pkgname = webkitgtk
diff --git a/PKGBUILD b/PKGBUILD
index a1ac84f6a2e1..3671290f1bad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=webkitgtk
pkgver=2.4.11
-pkgrel=19
+pkgrel=20
epoch=3
pkgdesc="Legacy Web content engine for GTK+ 3"
arch=("armv7h" "i686" "x86_64")
@@ -30,6 +30,7 @@ source=(
"enchant-2.x.patch"
"icu59.patch"
"pkgconfig-enchant-2.patch"
+ "grammar.patch"
)
sha256sums=(
"588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7"
@@ -37,6 +38,7 @@ sha256sums=(
"7e37e059f071aaef93e387675de1a0c6a3dcf61ef67a3221a078caca69e22079"
"4e94e35b036f8a87a64e02d747d4103c0553dfe637fda372785c2b95211445ca"
"a1e2f24b28273746b2fbaecef42495f6314c76b16a446c22dc123e6a3afb58c8"
+ "24b49319500a79feb014ce2decd41db8ba7769c471bc8bfb42f761e2bc4d1ffb"
)
prepare() {
@@ -52,6 +54,9 @@ prepare() {
# Needed as autotools-related files are patched
autoreconf -ifv
+
+ # https://www.linuxquestions.org/questions/slackware-14/sbo-scripts-not-building-on-current-read-1st-post-pls-4175561999/page195.html#post6160562
+ patch -Np1 -i "${srcdir}/grammar.patch"
}
build() (
diff --git a/grammar.patch b/grammar.patch
new file mode 100644
index 000000000000..1ce69e247339
--- /dev/null
+++ b/grammar.patch
@@ -0,0 +1,20 @@
+diff --git a/GNUmakefile.in b/GNUmakefile.in
+index 4d151a2..df6b6f5 100644
+--- a/GNUmakefile.in
++++ b/GNUmakefile.in
+@@ -95669,6 +95669,7 @@ $(GENSOURCES_WEBCORE)/XPathGrammar.h: $(GENSOURCES_WEBCORE)/XPathGrammar.cpp
+ $(GENSOURCES_WEBCORE)/XPathGrammar.cpp: $(WebCore)/xml/XPathGrammar.y
+ $(AM_V_GEN)
+ $(AM_V_at)perl $(WebCore)/css/makegrammar.pl --outputDir $(GENSOURCES_WEBCORE) --bison "$(BISON)" --symbolsPrefix xpathyy $<
++ $(AM_V_at)cp $(GENSOURCES_WEBCORE)/XPathGrammar.h $(GENSOURCES_WEBCORE)/XPathGrammar.hpp
+
+ # MathML tag and attribute names, and element factory
+ DerivedSources/WebCore/MathMLElementFactory.h: DerivedSources/WebCore/MathMLElementFactory.cpp
+@@ -95727,6 +95728,7 @@ DerivedSources/WebCore/CSSGrammar.h: $(GENSOURCES_WEBCORE)/CSSGrammar.cpp
+ DerivedSources/WebCore/CSSGrammar.cpp: $(WebCore)/css/CSSGrammar.y.in
+ $(AM_V_GEN)
+ $(AM_V_at)perl -I $(WebCore)/bindings/scripts $(WebCore)/css/makegrammar.pl --extraDefines "$(feature_defines)" --outputDir $(GENSOURCES_WEBCORE) --bison "$(BISON)" --symbolsPrefix cssyy $<
++ $(AM_V_at)cp $(GENSOURCES_WEBCORE)/CSSGrammar.h $(GENSOURCES_WEBCORE)/CSSGrammar.hpp
+
+ DerivedSources/WebCore/UserAgentStyleSheetsData.cpp: DerivedSources/WebCore/UserAgentStyleSheets.h
+ DerivedSources/WebCore/UserAgentStyleSheets.h: $(WebCore)/css/make-css-file-arrays.pl $(WebCore)/bindings/scripts/preprocessor.pm $(USER_AGENT_STYLE_SHEETS)