summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrealgagu2020-12-25 22:52:37 -0500
committerfrealgagu2020-12-25 22:52:37 -0500
commit360d9cddf80fd3d6f86962f001bda081915bf04d (patch)
treecf1438a3533804972c0fb7f7631f981d4934a81e
parent27c9ede305cad9f7cc38a28bf642c1490cf7e761 (diff)
downloadaur-360d9cddf80fd3d6f86962f001bda081915bf04d.tar.gz
Patching for build with icu 68.2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--icu68.patch128
3 files changed, 135 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8654bccf70a..c13f8b7ce290 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webkitgtk
pkgdesc = Legacy Web content engine for GTK+ 3
pkgver = 2.4.11
- pkgrel = 20
+ pkgrel = 21
epoch = 3
url = https://webkitgtk.org/
install = webkitgtk.install
@@ -42,12 +42,14 @@ pkgbase = webkitgtk
source = enchant-2.x.patch
source = icu59.patch
source = pkgconfig-enchant-2.patch
+ source = icu68.patch
source = grammar.patch
sha256sums = 588aea051bfbacced27fdfe0335a957dca839ebe36aa548df39c7bbafdb65bf7
sha256sums = e40f1e08665e1646ebc490141678f26c9c4a2792207fdf7c05978547eae9f61c
sha256sums = 7e37e059f071aaef93e387675de1a0c6a3dcf61ef67a3221a078caca69e22079
sha256sums = 4e94e35b036f8a87a64e02d747d4103c0553dfe637fda372785c2b95211445ca
sha256sums = a1e2f24b28273746b2fbaecef42495f6314c76b16a446c22dc123e6a3afb58c8
+ sha256sums = d1a9ccc1ae5cb042bc47ae846ff84513ca7b9c7bc999c546ffba48572f0373a0
sha256sums = 24b49319500a79feb014ce2decd41db8ba7769c471bc8bfb42f761e2bc4d1ffb
pkgname = webkitgtk
diff --git a/PKGBUILD b/PKGBUILD
index 3671290f1bad..62497b10fcf8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=webkitgtk
pkgver=2.4.11
-pkgrel=20
+pkgrel=21
epoch=3
pkgdesc="Legacy Web content engine for GTK+ 3"
arch=("armv7h" "i686" "x86_64")
@@ -30,6 +30,7 @@ source=(
"enchant-2.x.patch"
"icu59.patch"
"pkgconfig-enchant-2.patch"
+ "icu68.patch"
"grammar.patch"
)
sha256sums=(
@@ -38,6 +39,7 @@ sha256sums=(
"7e37e059f071aaef93e387675de1a0c6a3dcf61ef67a3221a078caca69e22079"
"4e94e35b036f8a87a64e02d747d4103c0553dfe637fda372785c2b95211445ca"
"a1e2f24b28273746b2fbaecef42495f6314c76b16a446c22dc123e6a3afb58c8"
+ "d1a9ccc1ae5cb042bc47ae846ff84513ca7b9c7bc999c546ffba48572f0373a0"
"24b49319500a79feb014ce2decd41db8ba7769c471bc8bfb42f761e2bc4d1ffb"
)
@@ -51,6 +53,7 @@ prepare() {
patch -Np1 -i "${srcdir}/icu59.patch"
# https://www.archlinux.org/todo/enchant-221-rebuild/
patch -Np1 -i "${srcdir}/pkgconfig-enchant-2.patch"
+ patch -Np1 -i "${srcdir}/icu68.patch"
# Needed as autotools-related files are patched
autoreconf -ifv
diff --git a/icu68.patch b/icu68.patch
new file mode 100644
index 000000000000..4cbe68b0899f
--- /dev/null
+++ b/icu68.patch
@@ -0,0 +1,128 @@
+diff --git a/Source/WebCore/platform/text/TextCodecICU.cpp b/Source/WebCore/platform/text/TextCodecICU.cpp
+index f6d16cb..f5c0f68 100644
+--- a/Source/WebCore/platform/text/TextCodecICU.cpp
++++ b/Source/WebCore/platform/text/TextCodecICU.cpp
+@@ -308,7 +308,7 @@ void TextCodecICU::createICUConverter() const
+ m_converterICU = ucnv_open(m_canonicalConverterName, &err);
+ ASSERT(U_SUCCESS(err));
+ if (m_converterICU)
+- ucnv_setFallback(m_converterICU, TRUE);
++ ucnv_setFallback(m_converterICU, true);
+ }
+
+ int TextCodecICU::decodeToBuffer(UChar* target, UChar* targetLimit, const char*& source, const char* sourceLimit, int32_t* offsets, bool flush, UErrorCode& err)
+diff --git a/Source/WebCore/platform/text/icu/UTextProvider.h b/Source/WebCore/platform/text/icu/UTextProvider.h
+index 81a025a..a77aa45 100644
+--- a/Source/WebCore/platform/text/icu/UTextProvider.h
++++ b/Source/WebCore/platform/text/icu/UTextProvider.h
+@@ -81,12 +81,12 @@ inline bool uTextAccessInChunkOrOutOfRange(UText* text, int64_t nativeIndex, int
+ // Ensure chunk offset is well formed if computed offset exceeds int32_t range.
+ ASSERT(offset < std::numeric_limits<int32_t>::max());
+ text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
+- isAccessible = TRUE;
++ isAccessible = true;
+ return true;
+ }
+ if (nativeIndex >= nativeLength && text->chunkNativeLimit == nativeLength) {
+ text->chunkOffset = text->chunkLength;
+- isAccessible = FALSE;
++ isAccessible = false;
+ return true;
+ }
+ } else {
+@@ -95,12 +95,12 @@ inline bool uTextAccessInChunkOrOutOfRange(UText* text, int64_t nativeIndex, int
+ // Ensure chunk offset is well formed if computed offset exceeds int32_t range.
+ ASSERT(offset < std::numeric_limits<int32_t>::max());
+ text->chunkOffset = offset < std::numeric_limits<int32_t>::max() ? static_cast<int32_t>(offset) : 0;
+- isAccessible = TRUE;
++ isAccessible = true;
+ return true;
+ }
+ if (nativeIndex <= 0 && !text->chunkNativeStart) {
+ text->chunkOffset = 0;
+- isAccessible = FALSE;
++ isAccessible = false;
+ return true;
+ }
+ }
+diff --git a/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp b/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
+index ee02763..48ba1eb 100644
+--- a/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
++++ b/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
+@@ -100,23 +100,23 @@ static UBool uTextLatin1Access(UText* uText, int64_t index, UBool forward)
+ if (index < uText->chunkNativeLimit && index >= uText->chunkNativeStart) {
+ // Already inside the buffer. Set the new offset.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return TRUE;
++ return true;
+ }
+ if (index >= length && uText->chunkNativeLimit == length) {
+ // Off the end of the buffer, but we can't get it.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return FALSE;
++ return false;
+ }
+ } else {
+ if (index <= uText->chunkNativeLimit && index > uText->chunkNativeStart) {
+ // Already inside the buffer. Set the new offset.
+ uText->chunkOffset = static_cast<int32_t>(index - uText->chunkNativeStart);
+- return TRUE;
++ return true;
+ }
+ if (!index && !uText->chunkNativeStart) {
+ // Already at the beginning; can't go any farther.
+ uText->chunkOffset = 0;
+- return FALSE;
++ return false;
+ }
+ }
+
+@@ -144,7 +144,7 @@ static UBool uTextLatin1Access(UText* uText, int64_t index, UBool forward)
+
+ uText->nativeIndexingLimit = uText->chunkLength;
+
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextLatin1Extract(UText* uText, int64_t start, int64_t limit, UChar* dest, int32_t destCapacity, UErrorCode* status)
+@@ -336,7 +336,7 @@ static int64_t uTextLatin1ContextAwareNativeLength(UText* text)
+ static UBool uTextLatin1ContextAwareAccess(UText* text, int64_t nativeIndex, UBool forward)
+ {
+ if (!text->context)
+- return FALSE;
++ return false;
+ int64_t nativeLength = uTextLatin1ContextAwareNativeLength(text);
+ UBool isAccessible;
+ if (uTextAccessInChunkOrOutOfRange(text, nativeIndex, nativeLength, forward, isAccessible))
+@@ -356,7 +356,7 @@ static UBool uTextLatin1ContextAwareAccess(UText* text, int64_t nativeIndex, UBo
+ ASSERT(newContext == UTextProviderContext::PriorContext);
+ textLatin1ContextAwareSwitchToPriorContext(text, nativeIndex, nativeLength, forward);
+ }
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextLatin1ContextAwareExtract(UText*, int64_t, int64_t, UChar*, int32_t, UErrorCode* errorCode)
+diff --git a/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp b/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
+index 7aaac48..9ae0d36 100644
+--- a/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
++++ b/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
+@@ -125,7 +125,7 @@ static inline int64_t uTextUTF16ContextAwareNativeLength(UText* text)
+ static UBool uTextUTF16ContextAwareAccess(UText* text, int64_t nativeIndex, UBool forward)
+ {
+ if (!text->context)
+- return FALSE;
++ return false;
+ int64_t nativeLength = uTextUTF16ContextAwareNativeLength(text);
+ UBool isAccessible;
+ if (uTextAccessInChunkOrOutOfRange(text, nativeIndex, nativeLength, forward, isAccessible))
+@@ -145,7 +145,7 @@ static UBool uTextUTF16ContextAwareAccess(UText* text, int64_t nativeIndex, UBoo
+ ASSERT(newContext == UTextProviderContext::PriorContext);
+ textUTF16ContextAwareSwitchToPriorContext(text, nativeIndex, nativeLength, forward);
+ }
+- return TRUE;
++ return true;
+ }
+
+ static int32_t uTextUTF16ContextAwareExtract(UText*, int64_t, int64_t, UChar*, int32_t, UErrorCode* errorCode)