summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2019-12-13 04:32:01 +0100
committerhaawda2019-12-13 04:32:01 +0100
commita9361c2a290da6628ee4c3b1a03c43e2860e0994 (patch)
tree83ad2829ad0f9dd20d129aed9c756df2691b6ac8
parentac5ed688fea214776bd8a6842606abfaf9826f7a (diff)
downloadaur-a9361c2a290da6628ee4c3b1a03c43e2860e0994.tar.gz
python 3.8 rebuild, patch to avoid minibuffer warning
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--minibuffer.patch13
3 files changed, 22 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9b207d81d6f..a375e0dc7612 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = webmacs-git
pkgdesc = browser for keyboard-based web navigation
- pkgver = r525.0fa0010
+ pkgver = r791.35f1743
pkgrel = 1
url = https://github.com/parkouss/webmacs
arch = x86_64
@@ -13,7 +13,9 @@ pkgbase = webmacs-git
depends = python-dateparser
depends = python-dateutil
source = git+https://github.com/parkouss/webmacs
+ source = minibuffer.patch
md5sums = SKIP
+ md5sums = 32db2257938f42f94ca0183e02410125
pkgname = webmacs-git
diff --git a/PKGBUILD b/PKGBUILD
index 083639dbd766..9d17d77412a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=webmacs-git
-pkgver=r525.0fa0010
+pkgver=r791.35f1743
pkgrel=1
-_pythonver=3.6
+_pythonver=3.8
pkgdesc="browser for keyboard-based web navigation"
arch=('x86_64')
url="https://github.com/parkouss/webmacs"
license=('GPL3')
depends=('python-pyqt5' 'qt5-webengine' 'python-dateparser' 'python-dateutil')
makedepends=('python-setuptools' 'python-sphinx' 'git')
-source=("git+https://github.com/parkouss/webmacs")
-md5sums=('SKIP')
+source=("git+https://github.com/parkouss/webmacs" minibuffer.patch)
+md5sums=('SKIP'
+ '32db2257938f42f94ca0183e02410125')
pkgver() {
cd "${pkgname%-git}"
@@ -24,6 +25,7 @@ prepare() {
git config submodule.vendor.url "$srcdir"/vendor
git config submodule.c.url "$srcdir"/c
git submodule update
+ git apply "$srcdir"/minibuffer.patch
}
build() {
diff --git a/minibuffer.patch b/minibuffer.patch
new file mode 100644
index 000000000000..d536617e1a82
--- /dev/null
+++ b/minibuffer.patch
@@ -0,0 +1,13 @@
+diff --git a/webmacs/minibuffer/__init__.py b/webmacs/minibuffer/__init__.py
+index 8ee3b13..80d1e13 100644
+--- a/webmacs/minibuffer/__init__.py
++++ b/webmacs/minibuffer/__init__.py
+@@ -65,7 +65,7 @@ class Popup(QTableView):
+ # Split the columns width, nicer when we have at least two of them.
+ cols = self.model().columnCount()
+ if cols > 0:
+- col_width = w / cols
++ col_width = w // cols
+ for i in range(cols):
+ self.setColumnWidth(i, col_width)
+