summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGilles Hamel2017-09-20 21:17:09 +0200
committerGilles Hamel2017-09-20 21:17:09 +0200
commit7415d26afdb517331b4087bd0053ef23f84c2aa8 (patch)
tree71c0796c15cbaef81f5db4c5f384f3d724aea13e
parent1297911e3cc3319089ce1390610a47e879c13b8b (diff)
downloadaur-7415d26afdb517331b4087bd0053ef23f84c2aa8.tar.gz
Update to 1.3
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ca15cef1849..72c17d6d4656 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = weboob
pkgdesc = Web Out Of Browsers provides several applications to interact with a lot of websites.
- pkgver = 1.2
- pkgrel = 2
+ pkgver = 1.3
+ pkgrel = 1
url = http://weboob.org/
install = weboob.install
arch = any
@@ -22,6 +22,7 @@ pkgbase = weboob
depends = python2-lxml
depends = python2-yaml
depends = python2-futures
+ depends = python2-six
depends = which
optdepends = gnupg: check for repository authenticity
optdepends = python2-routes: contrib backends
@@ -33,8 +34,8 @@ pkgbase = weboob
optdepends = python2-termcolor: color formatting
optdepends = python2-nose: test suite
optdepends = bash-completion: to enable bash completion
- source = https://symlink.me/attachments/download/342/weboob-1.2.tar.gz
- md5sums = a77675b2443e4570d30f569951512b11
+ source = https://symlink.me/attachments/download/356/weboob-1.3.tar.gz
+ md5sums = becbb39232ca9b8f425d81c04b90b9ed
pkgname = weboob
diff --git a/PKGBUILD b/PKGBUILD
index ad464c2aa9cd..d600260cb2f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
Maintainer='Gilles Hamel <hamelg@laposte.net>'
pkgname=weboob
-pkgver=1.2
-pkgrel=2
+pkgver=1.3
+pkgrel=1
pkgdesc="Web Out Of Browsers provides several applications to interact with a lot of websites."
arch=('any')
url="http://weboob.org/"
@@ -11,7 +11,7 @@ depends=('python2-pyqt5' 'phonon-qt5' 'python2-dateutil' 'python2-prettytable'
'python2-requests' 'python2-google-api-python-client'
'python2-feedparser' 'python2-cssselect' 'python2-html2text'
'python2-imaging' 'python2-mechanize' 'python2-simplejson'
- 'python2-lxml' 'python2-yaml' 'python2-futures'
+ 'python2-lxml' 'python2-yaml' 'python2-futures' 'python2-six'
'which')
makedepends=('python2-setuptools')
optdepends=('gnupg: check for repository authenticity'
@@ -24,12 +24,12 @@ optdepends=('gnupg: check for repository authenticity'
'python2-termcolor: color formatting'
'python2-nose: test suite'
'bash-completion: to enable bash completion')
-source=("https://symlink.me/attachments/download/342/$pkgname-$pkgver.tar.gz")
-md5sums=('a77675b2443e4570d30f569951512b11')
+source=("https://symlink.me/attachments/download/356/$pkgname-$pkgver.tar.gz")
+md5sums=('becbb39232ca9b8f425d81c04b90b9ed')
package() {
cd $pkgname-$pkgver
- python2 setup.py install --qt --xdg --prefix=/usr --root="$pkgdir"
+ python2 setup.py install --qt --xdg --prefix=/usr --root="$pkgdir" --optimize=1
install -Dm 644 tools/weboob_bash_completion \
"$pkgdir/etc/bash_completion.d/weboob"
}