summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLouise2021-05-01 17:49:29 +0200
committerLouise2021-05-01 17:49:29 +0200
commit9ede82223daa29117cbee3e34e914d4937bd24db (patch)
treefd510def82eb7e7095ee2fa38a8eff3b5ed54712
parent60e3357080c70cd5860100450ee0e84ca4dd3877 (diff)
downloadaur-9ede82223daa29117cbee3e34e914d4937bd24db.tar.gz
Updated to woob 3.0
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 374fd81bab11..ab769980bb7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = weboob-git
pkgdesc = Core library and modules for Web Outside of Browsers
- pkgver = 2.0.r492.gea2752d36
+ pkgver = 3.0.r73.gfd7610aaa
pkgrel = 1
url = https://weboob.org
arch = any
@@ -23,7 +23,7 @@ pkgbase = weboob-git
provides = weboob-headless
conflicts = weboob-headless
replaces = weboob-headless
- source = weboob::git+https://git.weboob.org/weboob/weboob
+ source = git+https://gitlab.com/woob/woob
sha256sums = SKIP
pkgname = weboob-git
diff --git a/PKGBUILD b/PKGBUILD
index 30f36c2ada50..45956cc27e2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+# Maintainer: Louise Zanier
# Contributor: sputnick <gilles *DOT* quenot *AT* gmail *DOT* com>
# Contributor: ianux <ianux@free.fr>
pkgname=weboob-git
-pkgver=2.0.r492.gea2752d36
+pkgver=3.0.r73.gfd7610aaa
pkgrel=1
pkgdesc="Core library and modules for Web Outside of Browsers"
arch=(any)
-url="https://weboob.org"
+url="https://woob.tech"
license=('LGPL3')
depends=('python-lxml'
'python-cssselect'
@@ -26,20 +26,20 @@ makedepends=('python-setuptools' 'git')
replaces=('weboob-headless')
provides=('weboob-headless')
conflicts=('weboob-headless')
-source=("weboob::git+https://git.weboob.org/weboob/weboob")
+source=("git+https://gitlab.com/woob/woob")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/weboob"
+ cd "${srcdir}/woob"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/weboob"
+ cd "${srcdir}/woob"
python setup.py build
}
package() {
- cd "${srcdir}/weboob"
+ cd "${srcdir}/woob"
python setup.py install --prefix=/usr --root="${pkgdir}" --skip-build --optimize=1
-} \ No newline at end of file
+}