summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-15 19:56:01 +0300
committerDimitris Kiziridis2020-05-15 19:56:01 +0300
commit1dbc87b3521e9b6b2339327c71e9e6b2b2b0dd9e (patch)
treeb405b1190db3404f8f5b0e659253347ba72f0b38
parentd858bba02ab9eec7d147a02cd8bf89f45f99586a (diff)
downloadaur-1dbc87b3521e9b6b2339327c71e9e6b2b2b0dd9e.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c68568620512..33bccbab1cbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,12 +5,13 @@ pkgbase = weboob-qt
url = https://weboob.org
install = weboob.install
arch = any
- license = LGPL-3.0+
+ license = LGPL3
makedepends = python-setuptools
depends = weboob
depends = python-pyqt5
- source = https://files.pythonhosted.org/packages/b5/e5/98adb98776803b4ed49f78edd4737162303b7558ab971d2220722c7cb552/weboob-qt-2.0.tar.gz
- md5sums = fe4eb4478b2b08298acc874501595cac
+ depends = hicolor-icon-theme
+ source = weboob-qt-2.0.tar.gz::https://files.pythonhosted.org/packages/b5/e5/98adb98776803b4ed49f78edd4737162303b7558ab971d2220722c7cb552/weboob-qt-2.0.tar.gz
+ sha256sums = a894c0e685317210c472058c6533a6e02e4d5c1e77c2ec0888e671fb98b99fd0
pkgname = weboob-qt
diff --git a/PKGBUILD b/PKGBUILD
index 6181bd58a155..7e97f493bd5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,13 +6,14 @@ pkgrel=1
pkgdesc="Weboob is a project which provides a core library, modules and applications (QT apps)"
arch=('any')
url="https://weboob.org"
-license=('LGPL-3.0+')
+license=('LGPL3')
install='weboob.install'
depends=('weboob'
- 'python-pyqt5')
+ 'python-pyqt5'
+ 'hicolor-icon-theme')
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/b5/e5/98adb98776803b4ed49f78edd4737162303b7558ab971d2220722c7cb552/weboob-qt-${pkgver}.tar.gz")
-md5sums=('fe4eb4478b2b08298acc874501595cac')
+source=("${pkgname}-${pkgver}.tar.gz::https://files.pythonhosted.org/packages/b5/e5/98adb98776803b4ed49f78edd4737162303b7558ab971d2220722c7cb552/weboob-qt-${pkgver}.tar.gz")
+sha256sums=('a894c0e685317210c472058c6533a6e02e4d5c1e77c2ec0888e671fb98b99fd0')
build() {
cd "${pkgname}-${pkgver}"