summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-10 18:52:43 +0300
committerDimitris Kiziridis2020-04-10 18:52:43 +0300
commitbbc8463e137ebf5af4eadc75419e9fd420aa80a3 (patch)
tree790d412604eae8b8ac132dbf5463e163dc5b4381
downloadaur-bbc8463e137ebf5af4eadc75419e9fd420aa80a3.tar.gz
Initial commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD52
-rw-r--r--post_install4
3 files changed, 86 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6f3de317340
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = weboob-qt
+ pkgdesc = Weboob is a project which provides a core library, modules and applications (QT apps)
+ pkgver = 2.0
+ pkgrel = 1
+ url = http://weboob.org/
+ install = post_install
+ arch = any
+ license = LGPL-3.0+
+ makedepends = python-setuptools
+ depends = weboob
+ depends = python-pyqt5
+ depends = python-lxml
+ depends = python-cssselect
+ depends = python-requests
+ depends = python-dateutil
+ depends = python-yaml
+ depends = python-html2text
+ depends = python-six
+ depends = python-unidecode
+ depends = python-pillow
+ depends = python-babel
+ depends = python-termcolor
+ depends = gnupg
+ optdepends = libyaml: For more performance
+ optdepends = python-simplejson: For more performance
+ source = https://files.pythonhosted.org/packages/b5/e5/98adb98776803b4ed49f78edd4737162303b7558ab971d2220722c7cb552/weboob-qt-2.0.tar.gz
+ md5sums = fe4eb4478b2b08298acc874501595cac
+
+pkgname = weboob-qt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..078f7c663bc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=weboob-qt
+pkgver=2.0
+pkgrel=1
+pkgdesc="Weboob is a project which provides a core library, modules and applications (QT apps)"
+arch=('any')
+url="http://weboob.org/"
+license=('LGPL-3.0+')
+install='post_install'
+depends=('weboob'
+ 'python-pyqt5'
+ 'python-lxml'
+ 'python-cssselect'
+ 'python-requests'
+ 'python-dateutil'
+ 'python-yaml'
+ 'python-html2text'
+ 'python-six'
+ 'python-unidecode'
+ 'python-pillow'
+ 'python-babel'
+ 'python-termcolor'
+ 'gnupg')
+makedepends=('python-setuptools')
+optdepends=('libyaml: For more performance'
+ 'python-simplejson: For more performance')
+source=("https://files.pythonhosted.org/packages/b5/e5/98adb98776803b4ed49f78edd4737162303b7558ab971d2220722c7cb552/weboob-qt-2.0.tar.gz")
+md5sums=('fe4eb4478b2b08298acc874501595cac')
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ rm -rf "${pkgdir}/usr/share/man"
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/__init__.py
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/__pycache__/__init__.cpython-38.opt-1.pyc
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/__pycache__/__init__.cpython-38.pyc
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/applications/__init__.py
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/applications/__pycache__/__init__.cpython-38.opt-1.pyc
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/applications/__pycache__/__init__.cpython-38.pyc
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/tools/__init__.py
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/tools/__pycache__/__init__.cpython-38.opt-1.pyc
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/tools/__pycache__/__init__.cpython-38.pyc
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/tools/application/__init__.py
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/tools/application/__pycache__/__init__.cpython-38.opt-1.pyc
+ rm ${pkgdir}/usr/lib/python3.8/site-packages/weboob/tools/application/__pycache__/__init__.cpython-38.pyc
+} \ No newline at end of file
diff --git a/post_install b/post_install
new file mode 100644
index 000000000000..c9c2df372b6d
--- /dev/null
+++ b/post_install
@@ -0,0 +1,4 @@
+post_upgrade() {
+ echo 'After a package or system installation, you should run "weboob-config update" as your login user.'
+}
+