summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Trioux2021-08-04 21:45:19 +0200
committerRobin Trioux2021-08-04 21:48:30 +0200
commit45841799876c1b6f3146680ca0af42a090a336f6 (patch)
tree070c888c0af8f3e0192611d0dd6adc8ef0eb5e98
downloadaur-45841799876c1b6f3146680ca0af42a090a336f6.tar.gz
Package based on already existing but no longer maintained 'webots' AUR package. 'webots-bin' is the correct name anyway according to AUR package name's convention
-rw-r--r--.SRCINFO78
-rw-r--r--PKGBUILD39
-rw-r--r--webots.install13
3 files changed, 130 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b518bb02d248
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,78 @@
+pkgbase = webots-bin
+ pkgdesc = Mobile robot simulation software.
+ pkgver = 2021b
+ pkgrel = 1
+ url = https://cyberbotics.com/
+ install = webots.install
+ arch = x86_64
+ groups =
+ license = Apache
+ depends = make
+ depends = gcc
+ depends = atk>=1.9.0
+ depends = ffmpeg
+ depends = dbus
+ depends = freeimage>=3.15.4
+ depends = glib2>2.10.0
+ depends = glu
+ depends = gtk3
+ depends = nss
+ depends = gcc-libs
+ depends = libxaw
+ depends = libxrandr
+ depends = libxrender
+ depends = zziplib>=0.13.62
+ depends = libssh
+ depends = libzip
+ depends = libx11
+ depends = xorg-server
+ depends = libxslt
+ depends = gd
+ depends = freetype2
+ optdepends = alsa-lib
+ optdepends = cairo
+ optdepends = dbus
+ optdepends = desktop-file-utils
+ optdepends = expat
+ optdepends = fontconfig
+ optdepends = gdk-pixbuf2
+ optdepends = hicolor-icon-theme
+ optdepends = jre-openjdk-headless
+ optdepends = libcups
+ optdepends = libglvnd
+ optdepends = libjpeg-turbo
+ optdepends = libpulse
+ optdepends = libxaw
+ optdepends = libxcb
+ optdepends = libxcomposite
+ optdepends = libxcursor
+ optdepends = libxdamage
+ optdepends = libxext
+ optdepends = libxfixes
+ optdepends = libxi
+ optdepends = libxkbcommon
+ optdepends = libxkbcommon-x11
+ optdepends = libxrandr
+ optdepends = libxrender
+ optdepends = libxtst
+ optdepends = nspr
+ optdepends = nss
+ optdepends = openal
+ optdepends = openssl
+ optdepends = pango
+ optdepends = qt5-base
+ optdepends = qt5-declarative
+ optdepends = qt5-location
+ optdepends = qt5-multimedia
+ optdepends = qt5-webchannel
+ optdepends = qt5-webengine
+ optdepends = qt5-websockets
+ optdepends = xorg-server
+ optdepends = zlib
+ conflicts = webots
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://github.com/cyberbotics/webots/releases/download/R2021b/webots_2021b_amd64.deb
+ sha512sums_x86_64 = e7e04c872a171f542f960a77a53dd35ebe87a3b1bb5bfe1fc2e3f9b8dcb6c870161d2925c0bee9ca3e2cb38eafb9fd8107380fd23c7321ce63162515592d04a9
+
+pkgname = webots-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d6f0af57ee2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Robin Trioux <robin@trioux.ovh>
+# Maintainer: Dan Trickey
+# Contributor: Dan Trickey
+# Contributor: Robin Trioux
+# This file is inspired by Dan Trickey PKGBUILD's
+
+pkgname=webots-bin
+pkgver=2021b
+pkgrel=1
+pkgdesc="Mobile robot simulation software."
+arch=('x86_64')
+url="https://cyberbotics.com/"
+license=('Apache')
+groups=('')
+depends=("make" "gcc" "atk>=1.9.0" "ffmpeg" "dbus" "freeimage>=3.15.4" "glib2>2.10.0" "glu"
+ "gtk3" "nss" "gcc-libs" "libxaw" "libxrandr" "libxrender"
+ "zziplib>=0.13.62" "libssh" "libzip" "libx11" "xorg-server" "libxslt" "gd"
+ "freetype2")
+optdepends=('alsa-lib' 'cairo' 'dbus' 'desktop-file-utils' 'expat' 'fontconfig' 'gdk-pixbuf2' 'hicolor-icon-theme' 'jre-openjdk-headless' 'libcups' 'libglvnd' 'libjpeg-turbo' 'libpulse' 'libxaw' 'libxcb' 'libxcomposite' 'libxcursor' 'libxdamage' 'libxext' 'libxfixes' 'libxi' 'libxkbcommon' 'libxkbcommon-x11' 'libxrandr' 'libxrender' 'libxtst' 'nspr' 'nss' 'openal' 'openssl' 'pango' 'qt5-base' 'qt5-declarative' 'qt5-location' 'qt5-multimedia' 'qt5-webchannel' 'qt5-webengine' 'qt5-websockets' 'xorg-server' 'zlib')
+conflicts=('webots')
+options=('!strip' '!emptydirs')
+install=webots.install
+source_x86_64=('https://github.com/cyberbotics/webots/releases/download/R2021b/webots_2021b_amd64.deb')
+sha512sums_x86_64=('e7e04c872a171f542f960a77a53dd35ebe87a3b1bb5bfe1fc2e3f9b8dcb6c870161d2925c0bee9ca3e2cb38eafb9fd8107380fd23c7321ce63162515592d04a9')
+
+package(){
+
+ # Extract package data
+ tar xzf data.tar.gz -C "${pkgdir}"
+
+ # Fix directory structure differences
+ cd "${pkgdir}"
+
+ mkdir usr/bin 2> /dev/null; mv usr/local/bin/* usr/bin; rm -rf usr/local/bin
+
+ cd ..
+
+}
+
diff --git a/webots.install b/webots.install
new file mode 100644
index 000000000000..a3ff5b674f7e
--- /dev/null
+++ b/webots.install
@@ -0,0 +1,13 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}