summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdJoPaTo2023-05-18 16:37:42 +0200
committerEdJoPaTo2023-05-18 16:37:42 +0200
commitba7c1fa067c7149bb469be6b02dbcf08186b9e78 (patch)
treee18eea20785914496bf4a668c4ce44d114d77bb5
parent420efec9dcc5d5195f247746702e38dc0a25fb57 (diff)
downloadaur-ba7c1fa067c7149bb469be6b02dbcf08186b9e78.tar.gz
simplify install commands with target dir and include CHANGELOG.md
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD15
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6df5e7f2ee85..1c58f99329aa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = website-stalker
pkgdesc = Track changes on websites via git
pkgver = 0.20.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/EdJoPaTo/website-stalker
arch = x86_64
arch = aarch64
diff --git a/PKGBUILD b/PKGBUILD
index 3e7ea137f0c6..6367f9d1a829 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=website-stalker
pkgver=0.20.0
-pkgrel=2
+pkgrel=3
pkgdesc="Track changes on websites via git"
arch=('x86_64' 'aarch64' 'armv6h' 'armv7h')
url="https://github.com/EdJoPaTo/${pkgname}"
@@ -20,13 +20,14 @@ build() {
package() {
cd $pkgname-$pkgver
- install -Dm755 target/release/$pkgname -t "${pkgdir}/usr/bin"
- install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm755 target/release/$pkgname -t "${pkgdir}/usr/bin/"
+ install -Dm644 CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}/"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}/"
- install -Dm644 "target/completions/${pkgname}.bash" "${pkgdir}/usr/share/bash-completion/completions/${pkgname}.bash"
- install -Dm644 "target/completions/${pkgname}.fish" "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname}.fish"
- install -Dm644 "target/completions/_${pkgname}" "${pkgdir}/usr/share/zsh/site-functions/_${pkgname}"
+ install -Dm644 "target/completions/${pkgname}.bash" -t "${pkgdir}/usr/share/bash-completion/completions/"
+ install -Dm644 "target/completions/${pkgname}.fish" -t "${pkgdir}/usr/share/fish/vendor_completions.d/"
+ install -Dm644 "target/completions/_${pkgname}" -t "${pkgdir}/usr/share/zsh/site-functions/"
install -Dm644 "systemd/system/service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
install -Dm644 "systemd/system/timer" "${pkgdir}/usr/lib/systemd/system/${pkgname}.timer"