summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyrinux2018-09-07 15:02:21 +0200
committerCyrinux2018-09-07 15:04:03 +0200
commit22ea2816ac3b51e678294f1ca42b6200cac7c757 (patch)
treee7b3ecc51da345c5744c8e9bd2605e41f0a5dc06
downloadaur-22ea2816ac3b51e678294f1ca42b6200cac7c757.tar.gz
add websocat v1.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD21
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3a443060bebd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = websocat-bin
+ pkgdesc = Command-line client for WebSockets, like netcat (or curl) for ws:// with advanced socat-like functions
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/vi/websocat/
+ arch = x86_64
+ license = MIT
+ conflicts = websocat-git
+ source = https://github.com/vi/websocat/releases/download/v1.1.0/websocat_amd64-linux
+ sha256sums = d8db1afd26e1d79206687ae8afd05d3f0f7da489984cce5959f1dc9a66232c7c
+
+pkgname = websocat-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f835fe25f3c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Cyril Levis <cyril at levis dot name>
+
+pkgname=websocat-bin
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Command-line client for WebSockets, like netcat (or curl) for ws:// with advanced socat-like functions"
+arch=("x86_64")
+url="https://github.com/vi/websocat/"
+license=("MIT")
+depends=()
+optdepends=()
+conflicts=("websocat-git")
+source=("https://github.com/vi/websocat/releases/download/v${pkgver}/websocat_amd64-linux")
+sha256sums=('d8db1afd26e1d79206687ae8afd05d3f0f7da489984cce5959f1dc9a66232c7c')
+
+package() {
+ install -d "$pkgdir/usr/bin"
+ install -Dm 755 websocat_amd64-linux "${pkgdir}/usr/bin/websocat"
+}
+
+# vim:set ts=4 sw=4 et: