summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2015-06-08 23:46:12 +0800
committerwenLiangcan2015-06-08 23:46:12 +0800
commitaaf5c7af73ee87b50f279ae8fd32b52bf323fa44 (patch)
tree359f05a3db0557f43b5c1d278ac3609b1d3e983b
downloadaur-aaf5c7af73ee87b50f279ae8fd32b52bf323fa44.tar.gz
websocketd 0.2.10-1.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..483cff35f141
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = websocketd
+ pkgdesc = Like inetd, but for WebSockets. Turn any application that uses STDIO/STDOUT into a WebSocket server.
+ pkgver = 0.2.10
+ pkgrel = 1
+ url = https://github.com/joewalnes/websocketd
+ arch = x86_64
+ arch = i686
+ arch = arm
+ license = BSD-2-Clause
+ depends = glibc
+ source_x86_64 = https://github.com/joewalnes/websocketd/releases/download/v0.2.10/websocketd-0.2.10-linux_amd64.zip
+ md5sums_x86_64 = a8c7c05717419be68fcfbb6fe8f652f6
+ source_i686 = https://github.com/joewalnes/websocketd/releases/download/v0.2.10/websocketd-0.2.10-linux_386.zip
+ md5sums_i686 = 1eec5c3471406a38aaa01c9f1708717e
+ source_arm = https://github.com/joewalnes/websocketd/releases/download/v0.2.10/websocketd-0.2.10-linux_arm.zip
+ md5sums_arm = 61c653b9dbaf5cdb4813755973322789
+
+pkgname = websocketd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4f02aec99407
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+pkgname=websocketd
+pkgver=0.2.10
+pkgrel=1
+pkgdesc="Like inetd, but for WebSockets. Turn any application that uses STDIO/STDOUT into a WebSocket server."
+arch=('x86_64' 'i686' 'arm')
+url="https://github.com/joewalnes/websocketd"
+license=('BSD-2-Clause ')
+depends=('glibc')
+
+source_x86_64=("https://github.com/joewalnes/websocketd/releases/download/v${pkgver}/websocketd-${pkgver}-linux_amd64.zip")
+md5sums_x86_64=('a8c7c05717419be68fcfbb6fe8f652f6')
+
+source_i686=("https://github.com/joewalnes/websocketd/releases/download/v${pkgver}/websocketd-${pkgver}-linux_386.zip")
+md5sums_i686=('1eec5c3471406a38aaa01c9f1708717e')
+
+source_arm=("https://github.com/joewalnes/websocketd/releases/download/v${pkgver}/websocketd-${pkgver}-linux_arm.zip")
+md5sums_arm=('61c653b9dbaf5cdb4813755973322789')
+
+package() {
+ cd "${srcdir}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}