summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:40:47 +0200
committerM0Rf302015-06-17 16:40:47 +0200
commite991a2b1fbcb8de58fe8fc89e012263a836787d7 (patch)
treefbe4d21108f83cfe5debd6711a52a754c2126b43
downloadaur-e991a2b1fbcb8de58fe8fc89e012263a836787d7.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52fb458a143e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = websocketd-git
+ pkgdesc = Like inetd, but for WebSockets. Turn any application that uses STDIO/STDOUT into a WebSocket server.
+ pkgver = 147.fbda5f2
+ pkgrel = 1
+ url = https://github.com/joewalnes/websocketd
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = mercurial
+ depends = glibc
+ conflicts = websocketd
+ source = websocketd::git+https://github.com/joewalnes/websocketd.git
+ md5sums = SKIP
+
+pkgname = websocketd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e744857d169
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+#Maintainer: M0Rf30
+
+pkgname=websocketd-git
+_gitpkg=websocketd
+pkgver=147.fbda5f2
+pkgrel=1
+pkgdesc="Like inetd, but for WebSockets. Turn any application that uses STDIO/STDOUT into a WebSocket server."
+arch=('i686' 'x86_64')
+url="https://github.com/joewalnes/websocketd"
+license=('BSD')
+depends=('glibc')
+conflicts=('websocketd')
+makedepends=('git' 'mercurial')
+source=('websocketd::git+https://github.com/joewalnes/websocketd.git')
+
+build() {
+ cd ${_gitpkg}
+ make
+}
+
+package(){
+ cd ${_gitpkg}
+ install -Dm755 "${_gitpkg}" "${pkgdir}/usr/bin/${_gitpkg}"
+}
+
+pkgver() {
+ cd ${_gitpkg}
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')