summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcodemunkii2015-08-05 21:03:37 -0400
committercodemunkii2015-08-05 21:03:37 -0400
commit0a19741bd5ddcab350970d4a49c64ce79da905b3 (patch)
tree2b052f583eaeeeb377af12ee7bd8d3ec0076b19b
downloadaur-0a19741bd5ddcab350970d4a49c64ce79da905b3.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1c0eb1ccb79a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = websploit
+ pkgdesc = An open source project for, social engineering works, scanning, crawling and analysis, automatic exploiter, and network attacks
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://code.google.com/p/websploit/
+ arch = any
+ license = Unknown
+ depends = python2
+ depends = scapy
+ source = http://sourceforge.net/projects/websploit/files/WebSploit%20Framework%20V.3.0.0/WebSploit-Framework-3.0.0.tar.gz
+ md5sums = 3161c57ca6b5c50d5a71df2fef95d846
+
+pkgname = websploit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4f3a561d0d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ari Mizrahi <codemunchies at debugsecurity dot com>
+# Contributor: ArchAssault Project <https://www.archassault.org>
+
+pkgname=websploit
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="An open source project for, social engineering works, scanning, crawling and analysis, automatic exploiter, and network attacks"
+arch=('any')
+url=('http://code.google.com/p/websploit/')
+license=('Unknown')
+source=("http://sourceforge.net/projects/websploit/files/WebSploit%20Framework%20V.3.0.0/WebSploit-Framework-${pkgver}.tar.gz")
+depends=('python2' 'scapy')
+md5sums=('3161c57ca6b5c50d5a71df2fef95d846')
+
+package() {
+ cd "$srcdir"
+ install -dm0755 "$pkgdir"/usr/share
+ tar xf websploit/wsf-300.tar.gz -C "$pkgdir"/usr/share
+ find "$pkgdir" -type f | xargs sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|'
+ find "$pkgdir" -name '*~' -delete
+ chmod -R go=rX,u=rwX "$pkgdir/usr"
+ chown -R root:root "$pkgdir"/usr
+ chmod 0755 "$pkgdir"/usr/share/websploit/*
+ chmod 0755 "$pkgdir"/usr/share/websploit/modules*
+ chmod 0755 "$pkgdir"/usr/share/websploit/modules/fakeupdate/*
+ chmod 0755 "$pkgdir"/usr/share/websploit/core/*
+ install -dm0755 "$pkgdir"/usr/bin
+ ln -s /usr/share/websploit/websploit "$pkgdir"/usr/bin/websploit
+}