summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Stegeman2020-12-03 10:24:03 -0900
committerMichael Stegeman2020-12-03 10:24:03 -0900
commitb72b88c32d80797e0ce731eeace79e9d03dd23ca (patch)
tree7eb5f1a8a401735171d36b9ae96d3e872dc743c6
parent30b3d105706892349c99f505d4711e9afc2de43e (diff)
downloadaur-b72b88c32d80797e0ce731eeace79e9d03dd23ca.tar.gz
Update to 1.0.0.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
-rw-r--r--webthings-gateway.conf87
-rw-r--r--webthings-gateway.sysusers2
4 files changed, 76 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d7ab9feefba..07cfb42699c5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = webthings-gateway
- pkgdesc = WebThings Gateway by Mozilla
- pkgver = 0.12.0
+ pkgdesc = WebThings Gateway
+ pkgver = 1.0.0
pkgrel = 1
- url = https://iot.mozilla.org/gateway/
+ url = https://webthings.io/gateway/
install = webthings-gateway.install
arch = x86_64
license = MPL2
@@ -12,7 +12,7 @@ pkgbase = webthings-gateway
makedepends = python2
depends = lsb-release
depends = nodejs>=10.0.0
- depends = nodejs<13.0.0
+ depends = nodejs<15.0.0
depends = pagekite
depends = python-gateway-addon
optdepends = alsa-utils: required for internet radio add-on
@@ -20,20 +20,20 @@ pkgbase = webthings-gateway
optdepends = ffmpeg: required for video transcoding in ONVIF and virtual things add-on
optdepends = iputils: required for network presence add-on
optdepends = mosquitto: required for some MQTT add-ons
- source = webthings-gateway-0.12.0.tar.gz::https://github.com/mozilla-iot/gateway/archive/0.12.0.tar.gz
+ source = webthings-gateway-1.0.0.tar.gz::https://github.com/WebThingsIO/gateway/archive/1.0.0.tar.gz
source = webthings-gateway.conf
source = webthings-gateway.install
source = webthings-gateway.profile
source = webthings-gateway.service
source = webthings-gateway.sh
source = webthings-gateway.sysusers
- sha256sums = 70297de904cc480396fd71dd2991dd4c45daa9dd67916a92ff1575f6003fc476
- sha256sums = 36d1e319305f7da9f678f614387f6a23cd9d660b704932d566a3308819be2260
+ sha256sums = a5274e370e358c6cdfd667c02cc70dbf599af73605eaecab425f07b8cc2a6e71
+ sha256sums = 02e18af6e5d2b4fa391187b1c61fd04304882e1c38a686660e46b2c07ac23cbf
sha256sums = 6bda15a6d276d5b7f060121bc72f43edb46b40c6670419a1ce3113042fb47381
sha256sums = 1a5e41278b02a8c509edaf86d510b4739efb90bbfed4b85df9f2da9ff4eef9a7
sha256sums = e8f4faa6fb1778157d9927d730038ef0f5520c6c3c5cc33222f155d9979238a5
sha256sums = e516c724bce5fa9ab9f0652f903c778609dd5b8a7682b169b881a8c0fcb41bbf
- sha256sums = 38ac347a82f61525e762ba3dd129faf2eb5af03371599626bef7fc66e8bf8a32
+ sha256sums = aa94d3c56eae58483b6c0cd860c01ecbb7810db10056d18cbdadac4e86b452ca
pkgname = webthings-gateway
diff --git a/PKGBUILD b/PKGBUILD
index f7a21060bef4..1e6dbfebaa4a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: Michael Stegeman <mstegeman@mozilla.com>
+# Maintainer: Michael Stegeman <team@webthings.io>
pkgname=webthings-gateway
-pkgver=0.12.0
+pkgver=1.0.0
pkgrel=1
-pkgdesc='WebThings Gateway by Mozilla'
-url='https://iot.mozilla.org/gateway/'
+pkgdesc='WebThings Gateway'
+url='https://webthings.io/gateway/'
arch=('x86_64')
license=('MPL2')
depends=(
'lsb-release'
'nodejs>=10.0.0' # dubnium (10.x) is what our other distros use
- 'nodejs<13.0.0' # we only test up to 12.x
+ 'nodejs<15.0.0' # we only test up to 14.x
'pagekite'
'python-gateway-addon'
)
@@ -28,7 +28,7 @@ optdepends=(
)
backup=()
source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/mozilla-iot/gateway/archive/${pkgver}.tar.gz"
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/WebThingsIO/gateway/archive/${pkgver}.tar.gz"
"${pkgname}.conf"
"${pkgname}.install"
"${pkgname}.profile"
@@ -37,13 +37,13 @@ source=(
"${pkgname}.sysusers"
)
sha256sums=(
- '70297de904cc480396fd71dd2991dd4c45daa9dd67916a92ff1575f6003fc476'
- '36d1e319305f7da9f678f614387f6a23cd9d660b704932d566a3308819be2260'
+ 'a5274e370e358c6cdfd667c02cc70dbf599af73605eaecab425f07b8cc2a6e71'
+ '02e18af6e5d2b4fa391187b1c61fd04304882e1c38a686660e46b2c07ac23cbf'
'6bda15a6d276d5b7f060121bc72f43edb46b40c6670419a1ce3113042fb47381'
'1a5e41278b02a8c509edaf86d510b4739efb90bbfed4b85df9f2da9ff4eef9a7'
'e8f4faa6fb1778157d9927d730038ef0f5520c6c3c5cc33222f155d9979238a5'
'e516c724bce5fa9ab9f0652f903c778609dd5b8a7682b169b881a8c0fcb41bbf'
- '38ac347a82f61525e762ba3dd129faf2eb5af03371599626bef7fc66e8bf8a32'
+ 'aa94d3c56eae58483b6c0cd860c01ecbb7810db10056d18cbdadac4e86b452ca'
)
install="${pkgname}.install"
diff --git a/webthings-gateway.conf b/webthings-gateway.conf
index 029c8fe70b9d..92c8a2fcf1ab 100644
--- a/webthings-gateway.conf
+++ b/webthings-gateway.conf
@@ -13,68 +13,97 @@ const path = require('path');
const home = os.homedir();
module.exports = {
- // Expose CLI
- cli: false,
-
+ // Base profile directory
profileDir: `/etc/webthings-gateway`,
ports: {
+ // HTTPS port
https: 4443,
+
+ // HTTP port
http: 8080,
+
+ // IPC port -- changing this will likely break all add-ons
ipc: 9500,
},
+
// Whether the gateway is behind port forwarding and should use simplified
// port-free urls
behindForwarding: false,
+
addonManager: {
+ // URLs of add-on lists to parse, in order
listUrls: [
- 'https://api.mozilla-iot.org:8443/addons',
+ 'https://api.webthings.io:8443/addons',
],
+
+ // Whether or not to allow installation of test-only add-ons
testAddons: false,
},
+
database: {
+ // Remove the database before opening. Only useful for testing.
removeBeforeOpen: false,
},
+
settings: {
defaults: {
- domain: {
- localAccess: false,
- mozillaTunnelService: true,
- localControl: {
- mdnsServiceType: 'http',
- mdnsServiceName: 'Mozilla WebThings Gateway',
- mdnsServiceDomain: os.hostname().split('.')[0],
-
- mdnsTxt: {
- desc: 'Web of Things Gateway',
- protocol: 'http, https, Web Sockets',
- power: '6 watts',
- },
- },
+ mdns: {
+ // Whether or not to enable mDNS advertisements
+ enabled: false,
+
+ // Domain to advertise via mDNS
+ domain: os.hostname().split('.')[0],
},
},
},
- authentication: {
- defaultUser: null,
- },
+
ssltunnel: {
+ // Whether or not to enable the PageKite tunnel (if set up)
enabled: true,
- registration_endpoint: 'https://api.mozilla-iot.org:8443',
- domain: 'mozilla-iot.org',
- pagekite_cmd: '/usr/bin/pagekite',
+
+ // Endpoint of the PageKite server
+ registration_endpoint: 'https://api.webthings.io:8443',
+
+ // Base domain
+ domain: 'webthings.io',
+
+ // Command to run PageKite
+ pagekite_cmd: path.normalize(path.join(process.cwd(), 'pagekite.py')),
+
+ // Port the PageKite server is running on
port: 443,
- certemail: 'certificate@mozilla-iot.org',
+
+ // Email address to use during certificate generation
+ certemail: 'noreply@webthings.io',
+ },
+
+ updates: {
+ // URL of update server
+ url: 'https://api.webthings.io:8443/releases',
+
+ // Whether or not to allow prerelease updates
+ allowPrerelease: false,
},
- bcryptRounds: 2,
- updateUrl: 'https://api.mozilla-iot.org:8443/releases',
+
wifi: {
ap: {
+ // IP address to run captive portal on
ipaddr: '192.168.2.1',
+
+ // Base SSID to use for captive portal (suffix will include MAC address
+ // components)
ssid_base: 'WebThings Gateway',
},
},
- oauthPostToken: false,
- oauthTestClients: false,
+
+ oauth: {
+ // Whether or not to post the OAuth token back in the response
+ postToken: false,
+
+ // Whether or not to allow test clients
+ testClients: false,
+ },
};
// vim:set ts=2 sw=2 et ft=javascript:
diff --git a/webthings-gateway.sysusers b/webthings-gateway.sysusers
index af3c9f1637d9..4d891e7012f2 100644
--- a/webthings-gateway.sysusers
+++ b/webthings-gateway.sysusers
@@ -1,2 +1,2 @@
# create webthings user
-u webthings - "Mozilla WebThings Gateway"
+u webthings - "WebThings Gateway"