summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2018-04-23 12:58:41 +0200
committerPieter Goetschalckx2018-04-23 12:58:41 +0200
commit43fc86b296a715dee908b701cc04de504927dfa0 (patch)
tree78755745195d8ff9caf1accc292dc17f8e5ddaa9
parent6c920d9806f9d1e20a1c55e768bd2e4afb2ce240 (diff)
downloadaur-43fc86b296a715dee908b701cc04de504927dfa0.tar.gz
Add patch for tray support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
-rw-r--r--traysupport.patch15
3 files changed, 26 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 623688117c04..12f6db5c5535 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = webtorrent-desktop
pkgdesc = Streaming torrent client.
pkgver = 0.19.0
- pkgrel = 2
+ pkgrel = 3
url = https://webtorrent.io/desktop
arch = i686
arch = x86_64
@@ -9,15 +9,18 @@ pkgbase = webtorrent-desktop
makedepends = yarn
depends = gconf
depends = electron
+ depends = libnotify
conflicts = webtorrent-desktop-git
conflicts = webtorrent-desktop-bin
options = !strip
source = https://github.com/feross/webtorrent-desktop/archive/v0.19.0.tar.gz
source = webtorrent-desktop
source = webtorrent-desktop.desktop
+ source = traysupport.patch
sha256sums = 2622485e1eee66c70446902d9645bb84a407236778d43c81c4555f98c9c2a30f
sha256sums = 4ebe403535a6552333f56e6087355c85fbb1904b06908d62127337c7c593135c
sha256sums = 6af365f47ca47b33cca65f62c3a662218ba38af7d3d52bb891ce3e73bbb60539
+ sha256sums = 111d9eea78a64932b0c0d20e07bca39ccbf372fbe59977255c7a9ae1b39f7d79
pkgname = webtorrent-desktop
diff --git a/PKGBUILD b/PKGBUILD
index ab4e2e0aa8f0..486c19e537f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,23 @@
pkgname=webtorrent-desktop
pkgver=0.19.0
-pkgrel=2
+pkgrel=3
pkgdesc="Streaming torrent client."
arch=('i686' 'x86_64')
url="https://webtorrent.io/desktop"
license=('MIT')
-depends=('gconf' 'electron')
+depends=('gconf' 'electron' 'libnotify')
makedepends=('yarn')
conflicts=('webtorrent-desktop-git' 'webtorrent-desktop-bin')
options=(!strip)
source=("https://github.com/feross/${pkgname}/archive/v${pkgver}.tar.gz"
"webtorrent-desktop"
- "${pkgname}.desktop")
+ "${pkgname}.desktop"
+ "traysupport.patch")
sha256sums=('2622485e1eee66c70446902d9645bb84a407236778d43c81c4555f98c9c2a30f'
'4ebe403535a6552333f56e6087355c85fbb1904b06908d62127337c7c593135c'
- '6af365f47ca47b33cca65f62c3a662218ba38af7d3d52bb891ce3e73bbb60539')
+ '6af365f47ca47b33cca65f62c3a662218ba38af7d3d52bb891ce3e73bbb60539'
+ '111d9eea78a64932b0c0d20e07bca39ccbf372fbe59977255c7a9ae1b39f7d79')
[ "$CARCH" = "i686" ] && _platform=ia32
[ "$CARCH" = "x86_64" ] && _platform=x64
@@ -25,6 +27,7 @@ prepare() {
cd "$pkgname-$pkgver"
sed -i '/"electron.*":/d' package.json
+ patch -p1 -i "$srcdir/traysupport.patch"
}
build() {
diff --git a/traysupport.patch b/traysupport.patch
new file mode 100644
index 000000000000..8891f6b1f78f
--- /dev/null
+++ b/traysupport.patch
@@ -0,0 +1,15 @@
+diff --git a/src/main/tray.js b/src/main/tray.js
+index 889d1c8..cea1081 100644
+--- a/src/main/tray.js
++++ b/src/main/tray.js
+@@ -36,9 +36,7 @@ function setWindowFocus (flag) {
+ }
+
+ function initLinux () {
+- checkLinuxTraySupport(function (err) {
+- if (!err) createTray()
+- })
++ createTray()
+ }
+
+ function initWin32 () { \ No newline at end of file