summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2019-09-17 14:16:46 +0200
committerPieter Goetschalckx2019-09-17 14:16:46 +0200
commit92d079525a0bd37e7d6466f0baac042e222fedf1 (patch)
treeb30e570e8e964d5028ccdeecc1745dfd9a110892
parentcfe84f053def79577f75f798deafc365af4e25b5 (diff)
downloadaur-92d079525a0bd37e7d6466f0baac042e222fedf1.tar.gz
0.21.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD17
-rw-r--r--webtorrent-desktop.desktop29
3 files changed, 10 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e28aa38ecd9f..36d3db328d0c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,22 @@
pkgbase = webtorrent-desktop
pkgdesc = Streaming torrent client.
- pkgver = 0.20.0
- pkgrel = 3
+ pkgver = 0.21.0
+ pkgrel = 1
url = https://webtorrent.io/desktop
arch = i686
arch = x86_64
license = MIT
makedepends = npm
- depends = gconf
depends = electron
depends = libnotify
conflicts = webtorrent-desktop-git
conflicts = webtorrent-desktop-bin
options = !strip
- source = https://github.com/feross/webtorrent-desktop/archive/v0.20.0.tar.gz
+ source = https://github.com/feross/webtorrent-desktop/archive/v0.21.0.tar.gz
source = webtorrent-desktop
- source = webtorrent-desktop.desktop
source = traysupport.patch
- sha256sums = 2eec644337f2e8a47187c54d702491e3b4c1f1236dae48cb494c4e99ba0a9796
+ sha256sums = 6a622ae14a7424604b8a94402156bfdd4b1debf9fe4e6db852f38061910febd4
sha256sums = c1a416dbaefa5da60d236af561d60b7ed86def1c3ee05b7090bc5586da72fb17
- sha256sums = 6af365f47ca47b33cca65f62c3a662218ba38af7d3d52bb891ce3e73bbb60539
sha256sums = dbeff65a109489ce8ce4e89d0b4ad3bc1768d03707bc1a0845db852049296deb
pkgname = webtorrent-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 83bea8689630..f338925ff878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
pkgname=webtorrent-desktop
-pkgver=0.20.0
-pkgrel=3
+pkgver=0.21.0
+pkgrel=1
pkgdesc="Streaming torrent client."
arch=('i686' 'x86_64')
url="https://webtorrent.io/desktop"
license=('MIT')
-depends=('gconf' 'electron' 'libnotify')
+depends=('electron' 'libnotify')
makedepends=('npm')
conflicts=('webtorrent-desktop-git' 'webtorrent-desktop-bin')
options=(!strip)
source=("https://github.com/feross/${pkgname}/archive/v${pkgver}.tar.gz"
"webtorrent-desktop"
- "${pkgname}.desktop"
"traysupport.patch")
-sha256sums=('2eec644337f2e8a47187c54d702491e3b4c1f1236dae48cb494c4e99ba0a9796'
+sha256sums=('6a622ae14a7424604b8a94402156bfdd4b1debf9fe4e6db852f38061910febd4'
'c1a416dbaefa5da60d236af561d60b7ed86def1c3ee05b7090bc5586da72fb17'
- '6af365f47ca47b33cca65f62c3a662218ba38af7d3d52bb891ce3e73bbb60539'
'dbeff65a109489ce8ce4e89d0b4ad3bc1768d03707bc1a0845db852049296deb')
[ "$CARCH" = "i686" ] && _platform=ia32
@@ -26,9 +24,8 @@ sha256sums=('2eec644337f2e8a47187c54d702491e3b4c1f1236dae48cb494c4e99ba0a9796'
prepare() {
cd "$pkgname-$pkgver"
- sed -i '/"electron.*":/d' package.json
+ sed -i '/"\(electron.*\|appdmg\)":/d' package.json
patch -p1 -i "$srcdir/traysupport.patch"
- sed -i 's/app.makeSingleInstance(onAppOpen)/!app.requestSingleInstanceLock()/' src/main/index.js
}
build() {
@@ -44,10 +41,8 @@ package() {
install -dm755 "${pkgdir}/usr/lib/${pkgname}"
cp -a build index.js node_modules package.json static "${pkgdir}/usr/lib/${pkgname}/"
+ cp -a static/linux/share "${pkgdir}/usr/"
install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -Dm644 "static/WebTorrent.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname}.png"
-
install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/webtorrent-desktop.desktop b/webtorrent-desktop.desktop
deleted file mode 100644
index 6dd2c8af4f9c..000000000000
--- a/webtorrent-desktop.desktop
+++ /dev/null
@@ -1,29 +0,0 @@
-[Desktop Entry]
-Name=WebTorrent
-Version=1.0
-GenericName=BitTorrent Client
-X-GNOME-FullName=WebTorrent
-Comment=Download and share files over BitTorrent
-Encoding=UTF-8
-Type=Application
-Icon=webtorrent-desktop
-Terminal=false
-Exec=/usr/bin/webtorrent-desktop %U
-TryExec=/usr/bin/webtorrent-desktop
-StartupNotify=false
-Categories=Network;FileTransfer;P2P;
-MimeType=application/x-bittorrent;x-scheme-handler/magnet;x-scheme-handler/stream-magnet;
-
-Actions=CreateNewTorrent;OpenTorrentFile;OpenTorrentAddress;
-
-[Desktop Action CreateNewTorrent]
-Name=Create New Torrent...
-Exec=/usr/bin/webtorrent-desktop -n
-
-[Desktop Action OpenTorrentFile]
-Name=Open Torrent File...
-Exec=/usr/bin/webtorrent-desktop -o
-
-[Desktop Action OpenTorrentAddress]
-Name=Open Torrent Address...
-Exec=/usr/bin/webtorrent-desktop -u