summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2016-09-01 13:05:29 +0200
committerPieter Goetschalckx2016-09-01 13:05:29 +0200
commit99e4ad9d9c2466795fec44db54f341a6c85cebb0 (patch)
tree36f45abab054c84573713144485fcd60385d61c8
parentb65fa46f4c889c61b6436135fb02cc8d9b21258a (diff)
downloadaur-99e4ad9d9c2466795fec44db54f341a6c85cebb0.tar.gz
Version 0.13.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--webtorrent-desktop.desktop33
3 files changed, 46 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e8808d557a7..415a5694193d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = webtorrent-desktop
pkgdesc = Streaming torrent client.
- pkgver = 0.12.0
+ pkgver = 0.13.1
pkgrel = 1
url = https://webtorrent.io/desktop
arch = i686
@@ -12,8 +12,10 @@ pkgbase = webtorrent-desktop
depends = gconf
conflicts = webtorrent-desktop-git
conflicts = webtorrent-desktop-bin
- source = https://github.com/feross/webtorrent-desktop/archive/v0.12.0.tar.gz
- sha256sums = ba61b1b4b20ed11e98c522ba83384b3d61c7c3e349f457856ae99de1b524633e
+ source = https://github.com/feross/webtorrent-desktop/archive/v0.13.1.tar.gz
+ source = webtorrent-desktop.desktop
+ sha256sums = 820c29c1c29828d9028319481446623f0bead196e202adff58e0b46847046a6e
+ sha256sums = 4eba7b17fd0cd90f77fc1a1005f74d8fcd93dac4f669d1b1abbf71734b5bafa6
pkgname = webtorrent-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 3265b8ef2011..88c5bffee509 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
pkgname=webtorrent-desktop
-pkgver=0.12.0
+pkgver=0.13.1
pkgrel=1
pkgdesc="Streaming torrent client."
arch=('i686' 'x86_64')
@@ -10,8 +10,10 @@ license=('MIT')
depends=('gconf')
makedepends=('npm' 'git' 'zip')
conflicts=('webtorrent-desktop-git' 'webtorrent-desktop-bin')
-source=("https://github.com/feross/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('ba61b1b4b20ed11e98c522ba83384b3d61c7c3e349f457856ae99de1b524633e')
+source=("https://github.com/feross/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}.desktop")
+sha256sums=('820c29c1c29828d9028319481446623f0bead196e202adff58e0b46847046a6e'
+ '4eba7b17fd0cd90f77fc1a1005f74d8fcd93dac4f669d1b1abbf71734b5bafa6')
[ "$CARCH" = "i686" ] && _platform=ia32
[ "$CARCH" = "x86_64" ] && _platform=x64
@@ -32,6 +34,8 @@ package() {
cp -a "WebTorrent-linux-${_platform}" "${pkgdir}/usr/share/${pkgname}"
ln -s "/usr/share/${pkgname}/WebTorrent" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/$pkgname-$pkgver/static/WebTorrent.png" "${pkgdir}/usr/share/icons/hicolor/256x256/apps/${pkgname}.png"
+
install -Dm644 "WebTorrent-linux-${_platform}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
diff --git a/webtorrent-desktop.desktop b/webtorrent-desktop.desktop
new file mode 100644
index 000000000000..cdb87928d306
--- /dev/null
+++ b/webtorrent-desktop.desktop
@@ -0,0 +1,33 @@
+[Desktop Entry]
+Name=WebTorrent
+Version=1.0
+GenericName=BitTorrent Client
+X-GNOME-FullName=WebTorrent
+Comment=Download and share files over BitTorrent
+Encoding=UTF-8
+Type=Application
+Icon=webtorrent-desktop
+Terminal=false
+Path=/usr/share/webtorrent-desktop
+Exec=/usr/bin/webtorrent-desktop %U
+TryExec=/usr/bin/webtorrent-desktop
+StartupNotify=false
+Categories=Network;FileTransfer;P2P;
+MimeType=application/x-bittorrent;x-scheme-handler/magnet;x-scheme-handler/stream-magnet;
+
+Actions=CreateNewTorrent;OpenTorrentFile;OpenTorrentAddress;
+
+[Desktop Action CreateNewTorrent]
+Name=Create New Torrent...
+Exec=/usr/bin/webtorrent-desktop -n
+Path=/usr/share/webtorrent-desktop
+
+[Desktop Action OpenTorrentFile]
+Name=Open Torrent File...
+Exec=/usr/bin/webtorrent-desktop -o
+Path=/usr/share/webtorrent-desktop
+
+[Desktop Action OpenTorrentAddress]
+Name=Open Torrent Address...
+Exec=/usr/bin/webtorrent-desktop -u
+Path=/usr/share/webtorrent-desktop