summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2014-08-14 00:14:31 -0400
committerJames An2014-08-14 00:14:31 -0400
commit73c23fbb5cfe127b67cff83f39fcb8ab8e28dfec (patch)
treefa5546265d3296eadf8eda7cbcd818b2a592e3c8
parent31bca0239fd58f75679bc90070c08d5c03f49c05 (diff)
downloadaur-73c23fbb5cfe127b67cff83f39fcb8ab8e28dfec.tar.gz
Removed unnecessary upstream files and added ChangeLog to webui-aria2 package.
-rw-r--r--.SRCINFO8
-rw-r--r--ChangeLog15
-rw-r--r--PKGBUILD12
3 files changed, 30 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6693b7f64b90..5476c2ca77e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = webui-aria2-git
pkgdesc = Pure HTML/CSS/JS frontend for aria2
pkgver = r305.091fbb0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ziahamza/webui-aria2
+ changelog = ChangeLog
arch = any
license = MIT
makedepends = git
- optdepends = aria2: download utility backend
+ depends = aria2
optdepends = chromium: browser to access front end
optdepends = epiphany: browser to access front end
optdepends = firefox: browser to access front end
@@ -15,12 +16,15 @@ pkgbase = webui-aria2-git
optdepends = netsurf: browser to access front end
optdepends = opera: browser to access front end
optdepends = rekonq: browser to access front end
+ optdepends = xdg-utils: launch main webui-aria2 web page.
source = webui-aria2-git::git+https://github.com/ziahamza/webui-aria2.git
source = aria2d.service
source = webui-aria2
+ source = ChangeLog
md5sums = SKIP
md5sums = e66a1b86f501ae22b41ab69d97a0c4ee
md5sums = da1de4952903892fc0f0b00df1aebb5c
+ md5sums = 8a11be6666d3fb7fb830b1982a95cbdb
pkgname = webui-aria2-git
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..69253b7d6254
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,15 @@
+2014-08-14 James An <james@jamesan.ca>
+
+ * r305.091fbb0-2 :
+ removed .gitignore and screnshots from package.
+ added ChangeLog.
+ added xdg-utils as optional dependencies for shell script.
+ changed aria2 from optional to required dependency.
+
+2014-08-04 James An <james@jamesan.ca>
+
+ * r305.091fbb0-1 :
+ first version of this package.
+ added aria2 and various web browsers as optional depednencies.
+ added a systemd service unit to start aria2 as an RPC-enabled daemon.
+ Added shell script in /usr/bin to launch the main webui-aria2 URL in its default application.
diff --git a/PKGBUILD b/PKGBUILD
index 42603b3ed1dd..e30b9e57ff86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
_pkgname=webui-aria2
pkgname="$_pkgname-git"
pkgver=r305.091fbb0
-pkgrel=1
+pkgrel=2
pkgdesc="Pure HTML/CSS/JS frontend for aria2"
arch=('any')
url="https://github.com/ziahamza/webui-aria2"
license=('MIT')
+depends=('aria2')
optdepends=(
- 'aria2: download utility backend'
'chromium: browser to access front end'
'epiphany: browser to access front end'
'firefox: browser to access front end'
@@ -18,16 +18,20 @@ optdepends=(
'netsurf: browser to access front end'
'opera: browser to access front end'
'rekonq: browser to access front end'
+ 'xdg-utils: launch main webui-aria2 web page.'
)
makedepends=('git')
+changelog=ChangeLog
source=(
"$pkgname"::"git+https://github.com/ziahamza/$_pkgname.git"
aria2d.service
$_pkgname
+ ChangeLog
)
md5sums=('SKIP'
'e66a1b86f501ae22b41ab69d97a0c4ee'
- 'da1de4952903892fc0f0b00df1aebb5c')
+ 'da1de4952903892fc0f0b00df1aebb5c'
+ '8a11be6666d3fb7fb830b1982a95cbdb')
pkgver() {
cd "$pkgname"
@@ -46,6 +50,8 @@ package() {
# install package files
install -dm755 "$pkgdir/usr/share"
cp -R "$pkgname" "$pkgdir/usr/share/$_pkgname"
+ rm -rf "$pkgdir/usr/bin/$_pkgname/.gitignore"
+ rm -rf "$pkgdir/usr/bin/$_pkgname/screenshots"
find "$pkgdir/usr/share/" -type f -exec chmod 0644 {} +
find "$pkgdir/usr/share/" -type d -exec chmod 0755 {} +