summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWalter Dworak2016-02-11 16:09:32 -0600
committerWalter Dworak2016-02-11 16:09:32 -0600
commit20a510c68b9c98bcffed80a41ad5007e08e16c6d (patch)
tree27a234138c7c5cd86665a1f5dbe5c99146d101d8
downloadaur-20a510c68b9c98bcffed80a41ad5007e08e16c6d.tar.gz
Intial Release
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD31
-rw-r--r--webvirtmgr-novnc.service15
-rw-r--r--webvirtmgr.ini8
-rw-r--r--webvirtmgr.install33
5 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71ab2b4f8b6e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Thu Feb 11 22:09:21 UTC 2016
+pkgbase = webvirtmgr
+ pkgdesc = Web front-end for KVM virtual machines
+ pkgver = v4.8.9
+ pkgrel = 1
+ url = https://www.webvirtmgr.net/
+ install = webvirtmgr.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = python2-pip
+ depends = libvirt
+ depends = libvirt-python
+ depends = qemu
+ depends = dnsmasq
+ depends = bridge-utils
+ depends = ebtables
+ depends = dmidecode
+ depends = python2
+ depends = supervisor
+ depends = websockify
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/retspen/webvirtmgr/releases/download/v4.8.9/webvirtmgr.tar.gz
+ source = webvirtmgr.ini
+ source = webvirtmgr-novnc.service
+ sha512sums = 68bd127874e07c37bef0c6e3fd49dece306f2e2f0c5c111c7339638284937e8627576d2b64ac4bda2d09f9de4cc882a5af33ba3d6630f07c0e01509367030761
+ sha512sums = a8a64325750a1a6815c1ff9222373682f2300d0d636bb88675ae113b027a0e6d058e949344ae22357ff1258025ec0d32ca32a4383a37cadb88c9e5d180d2d147
+ sha512sums = 78ae3aef65e4c362a7d70ff3a44d1c3ccd489ed7b77311d0ecb4d795aa587dc75e43356f56e4afbb180e0558859b64cbe78ca45bb234920ff3302b01e59716db
+
+pkgname = webvirtmgr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d74ab258e597
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Walter Dworak <preparationh67@gmail.com>
+
+pkgname='webvirtmgr'
+pkgdesc='Web front-end for KVM virtual machines'
+pkgver=v4.8.9
+pkgrel=1
+arch=('i686' 'x86_64')
+url='https://www.webvirtmgr.net/'
+license=('Apache')
+depends=('libvirt' 'libvirt-python' 'qemu' 'dnsmasq' 'bridge-utils' 'ebtables' 'dmidecode' 'python2' 'supervisor'
+ 'websockify')
+makedepends=('python2-pip')
+options=('!strip' '!emptydirs')
+install="${pkgname}.install"
+source=('https://github.com/retspen/webvirtmgr/releases/download/v4.8.9/webvirtmgr.tar.gz'
+ 'webvirtmgr.ini'
+ 'webvirtmgr-novnc.service')
+sha512sums=('68bd127874e07c37bef0c6e3fd49dece306f2e2f0c5c111c7339638284937e8627576d2b64ac4bda2d09f9de4cc882a5af33ba3d6630f07c0e01509367030761'
+ 'a8a64325750a1a6815c1ff9222373682f2300d0d636bb88675ae113b027a0e6d058e949344ae22357ff1258025ec0d32ca32a4383a37cadb88c9e5d180d2d147'
+ '78ae3aef65e4c362a7d70ff3a44d1c3ccd489ed7b77311d0ecb4d795aa587dc75e43356f56e4afbb180e0558859b64cbe78ca45bb234920ff3302b01e59716db')
+
+package() {
+ outputdir="${pkgdir}/usr/lib/webvirtmgr"
+ install -Dm0644 'webvirtmgr.ini' "${pkgdir}/etc/supervisor.d/webvirtmgr.ini"
+ install -Dm0644 'webvirtmgr-novnc.service' "${pkgdir}/usr/lib/systemd/system/webvirtmgr-novnc.service"
+ install -dm0755 "${outputdir}" "${pkgdir}/var/lib/webvirtmgr"
+ cp -r "${srcdir}/webvirtmgr" "${pkgdir}/usr/lib"
+
+ cd "${outputdir}"
+ pip2 install -r 'requirements.txt' -t "${outputdir}/lib"
+}
diff --git a/webvirtmgr-novnc.service b/webvirtmgr-novnc.service
new file mode 100644
index 000000000000..64c9e90b6659
--- /dev/null
+++ b/webvirtmgr-novnc.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=WebVirtMgr NoVNC proxy
+
+[Service]
+Environment=WEBVIRTMGR_DAEMON=/usr/lib/webvirtmgr/console/webvirtmgr-novnc
+Environment=WEBVIRTMGR_LOCK_DIR=/var/lock/webvirtmgr
+Environment=WEBVIRTMGR_USER=webvirtmgr
+Environment=WEBVIRTMGR_GROUP=webvirtmgr
+User=webvirtmgr
+Group=webvirtmgr
+ExecStart=/usr/bin/python2 /usr/lib/webvirtmgr/console/webvirtmgr-novnc
+Type=simple
+
+[Install]
+WantedBy=multi-user.target
diff --git a/webvirtmgr.ini b/webvirtmgr.ini
new file mode 100644
index 000000000000..413e074a1eb5
--- /dev/null
+++ b/webvirtmgr.ini
@@ -0,0 +1,8 @@
+[program:webvirtmgr]
+command=/usr/bin/python2 /usr/lib/webvirtmgr/manage.py run_gunicorn -c /usr/lib/webvirtmgr/conf/gunicorn.conf.py
+directory=/usr/lib/webvirtmgr
+autostart=true
+autorestart=true
+stdout_logfile=/var/log/supervisor/webvirtmgr.log
+redirect_stderr=true
+user=webvirtmgr
diff --git a/webvirtmgr.install b/webvirtmgr.install
new file mode 100644
index 000000000000..7ec7ac627532
--- /dev/null
+++ b/webvirtmgr.install
@@ -0,0 +1,33 @@
+post_install() {
+ login='webvirtmgr'
+
+ getent group "${login}" > /dev/null || groupadd -r "${login}" > /dev/null
+ getent passwd "${login}" > /dev/null || useradd -r -g "${login}" -d "/var/lib/${login}" "${login}" -m > /dev/null
+
+ cat <<- EOF
+ To finalize the installation you need to run:
+
+ # sudo python2 /usr/lib/webvirtmgr/manage.py syncdb
+ # chown webvirtmgr:webvirtmgr /usr/lib/webvirtmgr/webvirtmgr/local/.secret_key_store /usr/lib/webvirtmgr/webvirtmgr.sqlite3 /usr/lib/webvirtmgr # temporary, see https://github.com/retspen/webvirtmgr/issues/391
+ # sudo python2 /usr/lib/webvirtmgr/manage.py collectstatic
+
+ WebVirtMgr daemon is managed by Supervisord.
+ # systemctl enable supervisord
+ # systemctl start supervisord
+
+ To access VNC console you need to enable the NoVNC proxy.
+ # systemctl enable webvirtmgr-novnc
+ # systemctl start webvirtmgr-novnc
+
+ See the wiki for more details:
+ https://github.com/retspen/webvirtmgr/wiki/Install-WebVirtMgr
+
+ You also need to configure libvirt if you haven't yet done it:
+ https://wiki.archlinux.org/index.php/libvirt#Server_configuration
+ https://wiki.archlinux.org/index.php/libvirt#Remote_access_to_libvirt
+EOF
+}
+
+post_upgrade() {
+ echo
+}