summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Zhang2017-08-31 13:54:35 +0800
committerBruce Zhang2017-08-31 13:54:35 +0800
commit3dfad1edf27cb313a16f98a7f9752efec965969f (patch)
tree5ed1571d4036ca9bcaebc6206fce08c2ea95ce1b
downloadaur-3dfad1edf27cb313a16f98a7f9752efec965969f.tar.gz
1.00.170830
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD22
-rw-r--r--link.install9
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d02a0f05288b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wechat-devtools
+ pkgdesc = WeChat Devtools Linux version.
+ pkgver = 1.00.170830
+ pkgrel = 1
+ epoch = 1
+ url = https://mp.weixin.qq.com/debug/wxadoc/dev/devtools/devtools.html
+ install = link.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = nss
+ optdepends = wine:微信小程序编译
+ provides = wechat_web_devtools_git
+ source = https://github.com/BruceZhang1993/wechat_devtools/archive/1.00.170830_x86_64.tar.gz
+ md5sums = SKIP
+
+pkgname = wechat-devtools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f3b67d165ef9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: bruceutut <zttt183525594@gmail.com>
+pkgname=wechat-devtools
+pkgver=1.00.170830
+pkgrel=1
+epoch=1
+pkgdesc="WeChat Devtools Linux version."
+arch=('i686' 'x86_64')
+_arch="$(uname -m)"
+url="https://mp.weixin.qq.com/debug/wxadoc/dev/devtools/devtools.html"
+license=('unknown')
+depends=('nss')
+optdepends=('wine:微信小程序编译')
+provides=('wechat_web_devtools_git')
+install=link.install
+source=("https://github.com/BruceZhang1993/wechat_devtools/archive/${pkgver}_${_arch}.tar.gz")
+md5sums=("SKIP")
+
+package() {
+ cd "$pkgname-$pkgver"
+ find ./ -type f -exec install -Dm755 {} \
+ "${pkgdir}/opt/tencent/${pkgname}/{}" \;
+}
diff --git a/link.install b/link.install
new file mode 100644
index 000000000000..ad06e6a80e76
--- /dev/null
+++ b/link.install
@@ -0,0 +1,9 @@
+post_install() {
+ ln -s /opt/tencent/wechat-devtools/wechat_devtools /usr/bin/wechat_devtools
+ echo "Type `wechat_devtools` to launch."
+}
+
+post_remove() {
+ rm /usr/bin/wechat_devtools
+ echo "Manually remove config folder."
+}