summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorccat3z2018-12-08 22:29:01 +0800
committerccat3z2018-12-08 22:29:01 +0800
commitb93cd0644f80e3b4b22f1d25b44b2e92e09b3973 (patch)
tree80beb5b61911017ee421fbc62b1845aa39aa700d
parentb82b4f717e90282a9b900e03430f775516c41566 (diff)
downloadaur-b93cd0644f80e3b4b22f1d25b44b2e92e09b3973.tar.gz
1.02.1811290
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD12
3 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3bbcecb35110..1b246e83f489 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wechat-devtools
pkgdesc = WeChat Devtools Linux version.
- pkgver = 1.02.1810190
+ pkgver = 1.02.1811290
pkgrel = 1
epoch = 2
url = https://mp.weixin.qq.com/debug/wxadoc/dev/devtools/devtools.html
@@ -11,11 +11,11 @@ pkgbase = wechat-devtools
depends = wine
options = !strip
source = nwjs.tar.gz::https://npm.taobao.org/mirrors/nwjs/v0.24.4/nwjs-sdk-v0.24.4-linux-x64.tar.gz
- source = wechat_devtools.exe::https://dldir1.qq.com/WechatWebDev/1.0.0/201810190/wechat_devtools_1.02.1810190_x64.exe
+ source = wechat_devtools_1.02.1811290_x64.exe::https://dldir1.qq.com/WechatWebDev/1.0.0/bb9c1558bb234f98b0a5558bcb629fa8/wechat_devtools_1.02.1811290_x64.exe
source = wechat-devtools.desktop
source = logo.svg
md5sums = 82f20fe9081201db81652eb066c29f9b
- md5sums = 8135ee1cc5054d5111cf9b5eb2062438
+ md5sums = b13ece83c9f09094f863c762a6b4c41e
md5sums = 8ce0ac4c3dd29535290970145cd919ae
md5sums = de6f2f282e6d813100474d75d8abfeb9
diff --git a/.gitignore b/.gitignore
index 162c69910f61..301ca3502dab 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-wechat_devtools.exe
+wechat_devtools*.exe
nwjs.tar.gz
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index aaa4d65e8530..6d3e9732ac4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,10 @@
# 方法来自https://github.com/cytle/wechat_web_devtools重新打包
-_wechat_devtools_release_date="201810190"
-_wechat_devtools_ver="1.02.1810190"
+_wechat_devtools_ver="1.02.1811290"
+_wechat_devtools_url="https://dldir1.qq.com/WechatWebDev/1.0.0/bb9c1558bb234f98b0a5558bcb629fa8/wechat_devtools_1.02.1811290_x64.exe"
+
+_wechat_devtools_exe="wechat_devtools_${_wechat_devtools_ver}_x64.exe"
_nwjs_ver="0.24.4"
_arch="x64"
_install_dir="/opt/wechat-devtools"
@@ -21,17 +23,17 @@ license=('unknown')
depends=('wine')
makedepends=('p7zip' 'nvm')
source=("nwjs.tar.gz::https://npm.taobao.org/mirrors/nwjs/v${_nwjs_ver}/nwjs-sdk-v${_nwjs_ver}-linux-${_arch}.tar.gz"
- "wechat_devtools.exe::https://dldir1.qq.com/WechatWebDev/1.0.0/${_wechat_devtools_release_date}/wechat_devtools_${_wechat_devtools_ver}_x64.exe"
+ "${_wechat_devtools_exe}::${_wechat_devtools_url}"
"wechat-devtools.desktop"
"logo.svg")
md5sums=(82f20fe9081201db81652eb066c29f9b
- 8135ee1cc5054d5111cf9b5eb2062438
+ b13ece83c9f09094f863c762a6b4c41e
8ce0ac4c3dd29535290970145cd919ae
de6f2f282e6d813100474d75d8abfeb9)
options=('!strip')
prepare() {
- 7z x -owechat_devtools wechat_devtools.exe
+ 7z x -owechat_devtools ${_wechat_devtools_exe}
}
build() {