summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqvshuo2021-04-29 00:59:54 +0800
committerqvshuo2021-04-29 00:59:54 +0800
commit8840167156e4bd0e8ab3b233a27e909733037f1b (patch)
tree0b52ab1345ff5f5ef48f77a4bd5210cc565f7352
parentc67ada9a471b8d411ca9c0dc6ada5cd17ef1dce9 (diff)
downloadaur-8840167156e4bd0e8ab3b233a27e909733037f1b.tar.gz
window frame
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--wechat-nativefier.css94
3 files changed, 23 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef2721f736ab..0be761fb6d6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wechat-nativefier
- pkgdesc = Built with nativefier (based on electron 12), seemed to Windows version.
- pkgver = 20210314.1
+ pkgdesc = 由nativefier生成(基于Electron 12), 模仿了Windows版微信的界面。
+ pkgver = 20210429.1
pkgrel = 1
url = https://wx.qq.com/
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b3d4b43c98a6..98173689f14a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: qvshuo
pkgname=wechat-nativefier
-pkgver=20210314.1
+pkgver=20210429.1
pkgrel=1
-pkgdesc="Built with nativefier (based on electron 12), seemed to Windows version."
+pkgdesc="由nativefier生成(基于Electron 12), 模仿了Windows版微信的界面。"
arch=("x86_64")
url="https://wx.qq.com/"
license=("MIT")
@@ -23,14 +23,14 @@ _instname=WeChat
build() {
nativefier \
- --name "$_instname" \
- --icon "${pkgname}.png" \
- --internal-urls ".*?" \
- --inject "${pkgname}.css" \
- --hide-window-frame \
- --tray \
- --file-download-options '{"saveAs": true}' \
- "${url}"
+ --name "$_instname" \
+ --icon "${pkgname}.png" \
+ --user-agent 'Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.101 Safari/537.36' \
+ --internal-urls ".*?" \
+ --inject "${pkgname}.css" \
+ --tray \
+ --file-download-options '{"saveAs": true}' \
+ "${url}"
}
package() {
diff --git a/wechat-nativefier.css b/wechat-nativefier.css
index 341f91a3cc93..a0aeecf547cb 100644
--- a/wechat-nativefier.css
+++ b/wechat-nativefier.css
@@ -1,179 +1,107 @@
-/* 语言选项 */
-.lang {
- display: none !important;
-}
-
-/* 版权声明 */
.copyright {
display: none !important;
}
-/* 主体高度 */
.main {
height: 100% !important;
padding-top: 0 !important;
}
-/* 主体宽度 */
.main_inner {
max-width: 100% !important;
}
-/* 左侧面板背景 */
.panel {
background: #eeeae8 !important;
}
-/* 自己的昵称 */
.header .info .nickname .display_name {
color: #000 !important;
}
-/* 搜索框 */
.search_bar .frm_search {
background-color: #dad8d8 !important;
color: #989898 !important;
}
-/* 搜索候选菜单标题 */
.recommendation .contact_title {
color: #000 !important;
- margin-top: 0 !important;
background-color: #ddddde !important;
}
-/* 搜索项 */
.recommendation .contact_item {
- border-bottom: 0 !important;
background-color: #e9e7e6 !important;
}
-/* 选中搜索项 */
.recommendation .contact_item.on {
background: #c6c6c6 !important;
}
-/* 搜索项文字 */
.recommendation .info .nickname {
color: #000 !important;
}
-/* 导航栏 */
.tab {
background: #eeeae8 !important;
- padding-top: 0 !important;
- padding-bottom: 0 !important;
+ display: flex !important;
+ flex-direction: row !important;
+ justify-content: space-around !important;
+}
+
+.tab .tab_item.ng-scope {
+ display: none;
}
-/* 导航栏分割线 */
.tab .tab_item::after {
- border-right: 0 !important;
+ display: none !important;
}
-/* 导航栏底边 */
.tab::after {
- border-bottom: 0 !important;
+ display: none !important;
}
-/* 聊天列表 */
.chat_item {
background-color: #e9e7e6 !important;
- border-bottom: 0 !important;
+ border-color: #00000000 !important;
}
-/* 置顶聊天 */
.chat_item.top {
background-color: #ddddde !important;
}
-/* 当前聊天 */
.chat_item.active {
background: #c6c6c6 !important;
}
-/* 聊天名称 */
.chat_item .info .nickname {
color: #000 !important;
}
-/* 选中聊天的时间 */
.chat_item.active .ext, .chat_item.active .info .msg {
color: #989898 !important;
}
-/* 选中聊天的内容 */
.chat_item .info .msg {
color: #989898 !important;
}
-/* 公众号标题背景 */
-.read_item_hd {
- background-color: #ddddde !important;
-}
-
-/* 公众号标题 */
-.read_item_hd .info .username {
- color: #000 !important;
-}
-
-/* 公众号列表 */
-.read_item {
- border-bottom: 0 !important;
- background-color: #e9e7e6 !important;
-}
-
-/* 当前公众号 */
-.read_item.active {
- background-color: #c6c6c6 !important;
-}
-
-/* 公众号文章标题 */
-.read_item .title {
- color: #000 !important;
-}
-
-/* 公众号间隔 */
-.read_list .just_for_bg {
- padding-top: 0 !important;
-}
-
-/* 联系人列表标题 */
.contact_list .contact_title {
background: #ddddde !important;
}
-/* 联系人列表 */
.contact_list .contact_item {
- border-bottom: 0 !important;
+ border-color: #00000000 !important;
background-color: !important;
}
-/* 选中联系人背景 */
.contact_list .active {
background: #c6c6c6 !important;
}
-/* 联系人名称 */
.contact_list .info .nickname {
color: #000 !important;
}
-/* 聊天框背景 */
-.box {
- background-color: #f5f5f5 !important;
-}
-
-/* 聊天框标题 */
-.box_hd .title_wrap {
- background-color: #f5f5f5 !important;
-}
-
-/* 自己发送的消息 */
-.bubble.bubble_primary {
- background-color: #9eea6a !important;
-}
-
-/* 截图按钮 */
.web_wechat_screencut {
display: none !important;
}