summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqvshuo2021-05-01 20:21:48 +0800
committerqvshuo2021-05-01 20:21:48 +0800
commitcec9e3c1f8996f3582a710e5cff3706eb3fdd9cb (patch)
tree8a53aebab6e85fbd504ca0d18edeb78a94ee79a0
parentc2d27f6a8aa39660a457ad1284d5ea67421fcac9 (diff)
downloadaur-cec9e3c1f8996f3582a710e5cff3706eb3fdd9cb.tar.gz
fix css
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
-rw-r--r--wechat-nativefier.css85
-rw-r--r--wechat-nativefier.desktop3
-rw-r--r--wechat-nativefier.js1
5 files changed, 22 insertions, 97 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2673158ef8e9..5d236ef18e36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = wechat-nativefier
- pkgdesc = 由nativefier生成(基于Electron 12), 模仿了Windows版微信的界面。
- pkgver = 20210429.4
+ pkgdesc = WeChat desktop built with nativefier (electron)
+ pkgver = 20210501.1
pkgrel = 1
url = https://wx.qq.com/
arch = x86_64
license = MIT
makedepends = nodejs-nativefier
+ makedepends = electron
source = wechat-nativefier.css
+ source = wechat-nativefier.js
source = wechat-nativefier.desktop
source = wechat-nativefier.png
- sha512sums = 1891c4f990b53bcca7dcfc2c4401d6afae82028d802fc0861b706be4fc02c3ea432af8d7fd47f0565822ff4435aeaf0b23acb2ca9af3804093a30b350c4178df
- sha512sums = 1d7f3f2b11f689b22149b369dd1d6261c2c5ffc77a27e5351596597d790a1066a1765511975e8260188db8d48f8c5dbabb2375dba60027316c8e3809591c9b4f
+ sha512sums = 7fd2eddefe52776fc5125be318a444540deec6166ea7d4fb1b9504a9341ec741915a8c74cfb6c16a909f7e74668c6721d2b416a2c2b453a56606de3b571ca376
+ sha512sums = d0fff3abb41f93104e60d1659cfe27a5512836fa4dd7a0ab859438345f016681465959e907346d840f26b9d8f850758f81ee92b576d71b6fed9659d50602286e
+ sha512sums = 7386c8f93d262a09baac34f815487c10e8998439416bd9276a61405e2b85e2087f77db91a1bb4b34d428c01775bdb40f8ea6f68f4927ae527cd4e42c8b505bb8
sha512sums = 718d0a44567a32a9ae4e875df8ee905b93f52bc6570dd7b75120bd5f801d2d350ae6d378e84b243cb8af80ccf85c1c873f43a8138efb880f27df8e356a2bcfce
pkgname = wechat-nativefier
diff --git a/PKGBUILD b/PKGBUILD
index 0e79fc374ebb..95493c36beb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: qvshuo
+_instname=WeChat
pkgname=wechat-nativefier
-pkgver=20210429.4
+pkgver=20210501.1
pkgrel=1
-pkgdesc="由nativefier生成(基于Electron 12), 模仿了Windows版微信的界面。"
+pkgdesc="WeChat desktop built with nativefier (electron)"
arch=("x86_64")
url="https://wx.qq.com/"
license=("MIT")
-makedepends=("nodejs-nativefier")
+makedepends=("nodejs-nativefier" "electron")
source=(
"${pkgname}.css"
+ "${pkgname}.js"
"${pkgname}.desktop"
"${pkgname}.png"
)
sha512sums=(
- "1891c4f990b53bcca7dcfc2c4401d6afae82028d802fc0861b706be4fc02c3ea432af8d7fd47f0565822ff4435aeaf0b23acb2ca9af3804093a30b350c4178df"
- "1d7f3f2b11f689b22149b369dd1d6261c2c5ffc77a27e5351596597d790a1066a1765511975e8260188db8d48f8c5dbabb2375dba60027316c8e3809591c9b4f"
+ "7fd2eddefe52776fc5125be318a444540deec6166ea7d4fb1b9504a9341ec741915a8c74cfb6c16a909f7e74668c6721d2b416a2c2b453a56606de3b571ca376"
+ "d0fff3abb41f93104e60d1659cfe27a5512836fa4dd7a0ab859438345f016681465959e907346d840f26b9d8f850758f81ee92b576d71b6fed9659d50602286e"
+ "7386c8f93d262a09baac34f815487c10e8998439416bd9276a61405e2b85e2087f77db91a1bb4b34d428c01775bdb40f8ea6f68f4927ae527cd4e42c8b505bb8"
"718d0a44567a32a9ae4e875df8ee905b93f52bc6570dd7b75120bd5f801d2d350ae6d378e84b243cb8af80ccf85c1c873f43a8138efb880f27df8e356a2bcfce"
)
-_instname=WeChat
+
build() {
nativefier \
- --name "WeChat" \
+ --name "${_instname}" \
--icon "${pkgname}.png" \
- --user-agent 'Mozilla/5.0 (X11; Linux x86_64; rv:88.0) Gecko/20100101 Firefox/88.0' \
--internal-urls ".*?" \
- --tray \
--file-download-options '{"saveAs": true}' \
"${url}"
}
diff --git a/wechat-nativefier.css b/wechat-nativefier.css
index a0aeecf547cb..dcda04b204f0 100644
--- a/wechat-nativefier.css
+++ b/wechat-nativefier.css
@@ -11,97 +11,16 @@
max-width: 100% !important;
}
-.panel {
- background: #eeeae8 !important;
-}
-
-.header .info .nickname .display_name {
- color: #000 !important;
-}
-
-.search_bar .frm_search {
- background-color: #dad8d8 !important;
- color: #989898 !important;
-}
-
-.recommendation .contact_title {
- color: #000 !important;
- background-color: #ddddde !important;
-}
-
-.recommendation .contact_item {
- background-color: #e9e7e6 !important;
-}
-
-.recommendation .contact_item.on {
- background: #c6c6c6 !important;
-}
-
-.recommendation .info .nickname {
- color: #000 !important;
-}
-
.tab {
- background: #eeeae8 !important;
display: flex !important;
flex-direction: row !important;
justify-content: space-around !important;
}
.tab .tab_item.ng-scope {
- display: none;
-}
-
-.tab .tab_item::after {
- display: none !important;
-}
-
-.tab::after {
- display: none !important;
-}
-
-.chat_item {
- background-color: #e9e7e6 !important;
- border-color: #00000000 !important;
-}
-
-.chat_item.top {
- background-color: #ddddde !important;
-}
-
-.chat_item.active {
- background: #c6c6c6 !important;
-}
-
-.chat_item .info .nickname {
- color: #000 !important;
-}
-
-.chat_item.active .ext, .chat_item.active .info .msg {
- color: #989898 !important;
-}
-
-.chat_item .info .msg {
- color: #989898 !important;
-}
-
-.contact_list .contact_title {
- background: #ddddde !important;
-}
-
-.contact_list .contact_item {
- border-color: #00000000 !important;
- background-color: !important;
-}
-
-.contact_list .active {
- background: #c6c6c6 !important;
-}
-
-.contact_list .info .nickname {
- color: #000 !important;
+ display: none !important;;
}
.web_wechat_screencut {
display: none !important;
-}
+} \ No newline at end of file
diff --git a/wechat-nativefier.desktop b/wechat-nativefier.desktop
index 60c080e1441b..128063ce55ba 100644
--- a/wechat-nativefier.desktop
+++ b/wechat-nativefier.desktop
@@ -7,5 +7,6 @@ Icon=/usr/share/pixmaps/WeChat.png
Encoding=UTF-8
Terminal=false
StartupNotify=true
+StartupWMClass=wechat-nativefier-4418c7
Type=Application
-Categories=Network;Chat;InstantMessaging;Application;
+Categories=Network;Chat;InstantMessaging;Application; \ No newline at end of file
diff --git a/wechat-nativefier.js b/wechat-nativefier.js
new file mode 100644
index 000000000000..041f930132a9
--- /dev/null
+++ b/wechat-nativefier.js
@@ -0,0 +1 @@
+document.title = '微信'; \ No newline at end of file