summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorqvshuo2021-01-30 17:04:39 +0800
committerqvshuo2021-01-30 17:04:39 +0800
commitf4864940eb2ab6a4f9268935ebcb619c1ddca536 (patch)
treed2b4be36c69b39a1f69c9725dbb3f4416ca9239a
downloadaur-f4864940eb2ab6a4f9268935ebcb619c1ddca536.tar.gz
init
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
-rw-r--r--wechat-nativefier.css179
-rw-r--r--wechat-nativefier.desktop12
-rw-r--r--wechat-nativefier.pngbin0 -> 3365 bytes
5 files changed, 252 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac5c46f8b25f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wechat-nativefier
+ pkgdesc = WeChat desktop built with nativefier (electron)
+ pkgver = 20210130
+ pkgrel = 1
+ url = https://wx.qq.com/
+ arch = x86_64
+ license = MIT
+ makedepends = imagemagick
+ makedepends = nodejs-nativefier
+ makedepends = unzip
+ source = wechat-nativefier.css
+ source = wechat-nativefier.desktop
+ source = wechat-nativefier.png
+ sha512sums = a5cbabd4eb17c89fe7cee345a5a3a3263306e6510ad34b06f6cee1f9221da18d7d38158a8e9cd102efe7f220efe862a8ec08d7422840e5587b19e611667280c2
+ sha512sums = 9195f78fd33008091e4c88462e5c5c1c7ed5fe4193fb18b8d62da12bc401ef03fdfdc798c69de7efbc208abf4278a0a9f9d1426fad6eae2c27cadc7e14f8bec3
+ sha512sums = a2102da15457059aeb60636246ee1557aa8a7833af1ebdc28661d1541bc563b0e14710261736890e4b59089249914171d3fdb8212217d8778626366c1290d9d0
+
+pkgname = wechat-nativefier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19df4cf49e94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: qvshuo
+
+pkgname=wechat-nativefier
+pkgver=20210130
+pkgrel=1
+pkgdesc="WeChat desktop built with nativefier (electron)"
+arch=("x86_64")
+url="https://wx.qq.com/"
+license=("MIT")
+makedepends=("imagemagick" "nodejs-nativefier" "unzip")
+source=(
+ "${pkgname}.css"
+ "${pkgname}.desktop"
+ "${pkgname}.png"
+)
+sha512sums=(
+ "a5cbabd4eb17c89fe7cee345a5a3a3263306e6510ad34b06f6cee1f9221da18d7d38158a8e9cd102efe7f220efe862a8ec08d7422840e5587b19e611667280c2"
+ "9195f78fd33008091e4c88462e5c5c1c7ed5fe4193fb18b8d62da12bc401ef03fdfdc798c69de7efbc208abf4278a0a9f9d1426fad6eae2c27cadc7e14f8bec3"
+ "a2102da15457059aeb60636246ee1557aa8a7833af1ebdc28661d1541bc563b0e14710261736890e4b59089249914171d3fdb8212217d8778626366c1290d9d0"
+)
+
+build() {
+ nativefier \
+ --name "${pkgname}" \
+ --icon "${pkgname}.png" \
+ --inject "${pkgname}.css" \
+ --hide-window-frame \
+ --tray \
+ --file-download-options '{"saveAs": true}' \
+ "${url}"
+}
+
+package() {
+ install -d "$pkgdir"/opt "$pkgdir"/usr/{bin,share/pixmaps}
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+
+ cp -rL $pkgname-linux-* "$pkgdir"/opt/$pkgname
+ ln -sf /opt/$pkgname/$pkgname "$pkgdir"/usr/bin/$pkgname
+ ln -sf /opt/$pkgname/resources/app/icon.png "$pkgdir"/usr/share/pixmaps/$pkgname.png
+
+ chmod 666 "$pkgdir"/opt/$pkgname/resources/app/nativefier.json
+} \ No newline at end of file
diff --git a/wechat-nativefier.css b/wechat-nativefier.css
new file mode 100644
index 000000000000..341f91a3cc93
--- /dev/null
+++ b/wechat-nativefier.css
@@ -0,0 +1,179 @@
+/* 语言选项 */
+.lang {
+ display: none !important;
+}
+
+/* 版权声明 */
+.copyright {
+ display: none !important;
+}
+
+/* 主体高度 */
+.main {
+ height: 100% !important;
+ padding-top: 0 !important;
+}
+
+/* 主体宽度 */
+.main_inner {
+ max-width: 100% !important;
+}
+
+/* 左侧面板背景 */
+.panel {
+ background: #eeeae8 !important;
+}
+
+/* 自己的昵称 */
+.header .info .nickname .display_name {
+ color: #000 !important;
+}
+
+/* 搜索框 */
+.search_bar .frm_search {
+ background-color: #dad8d8 !important;
+ color: #989898 !important;
+}
+
+/* 搜索候选菜单标题 */
+.recommendation .contact_title {
+ color: #000 !important;
+ margin-top: 0 !important;
+ background-color: #ddddde !important;
+}
+
+/* 搜索项 */
+.recommendation .contact_item {
+ border-bottom: 0 !important;
+ background-color: #e9e7e6 !important;
+}
+
+/* 选中搜索项 */
+.recommendation .contact_item.on {
+ background: #c6c6c6 !important;
+}
+
+/* 搜索项文字 */
+.recommendation .info .nickname {
+ color: #000 !important;
+}
+
+/* 导航栏 */
+.tab {
+ background: #eeeae8 !important;
+ padding-top: 0 !important;
+ padding-bottom: 0 !important;
+}
+
+/* 导航栏分割线 */
+.tab .tab_item::after {
+ border-right: 0 !important;
+}
+
+/* 导航栏底边 */
+.tab::after {
+ border-bottom: 0 !important;
+}
+
+/* 聊天列表 */
+.chat_item {
+ background-color: #e9e7e6 !important;
+ border-bottom: 0 !important;
+}
+
+/* 置顶聊天 */
+.chat_item.top {
+ background-color: #ddddde !important;
+}
+
+/* 当前聊天 */
+.chat_item.active {
+ background: #c6c6c6 !important;
+}
+
+/* 聊天名称 */
+.chat_item .info .nickname {
+ color: #000 !important;
+}
+
+/* 选中聊天的时间 */
+.chat_item.active .ext, .chat_item.active .info .msg {
+ color: #989898 !important;
+}
+
+/* 选中聊天的内容 */
+.chat_item .info .msg {
+ color: #989898 !important;
+}
+
+/* 公众号标题背景 */
+.read_item_hd {
+ background-color: #ddddde !important;
+}
+
+/* 公众号标题 */
+.read_item_hd .info .username {
+ color: #000 !important;
+}
+
+/* 公众号列表 */
+.read_item {
+ border-bottom: 0 !important;
+ background-color: #e9e7e6 !important;
+}
+
+/* 当前公众号 */
+.read_item.active {
+ background-color: #c6c6c6 !important;
+}
+
+/* 公众号文章标题 */
+.read_item .title {
+ color: #000 !important;
+}
+
+/* 公众号间隔 */
+.read_list .just_for_bg {
+ padding-top: 0 !important;
+}
+
+/* 联系人列表标题 */
+.contact_list .contact_title {
+ background: #ddddde !important;
+}
+
+/* 联系人列表 */
+.contact_list .contact_item {
+ border-bottom: 0 !important;
+ background-color: !important;
+}
+
+/* 选中联系人背景 */
+.contact_list .active {
+ background: #c6c6c6 !important;
+}
+
+/* 联系人名称 */
+.contact_list .info .nickname {
+ color: #000 !important;
+}
+
+/* 聊天框背景 */
+.box {
+ background-color: #f5f5f5 !important;
+}
+
+/* 聊天框标题 */
+.box_hd .title_wrap {
+ background-color: #f5f5f5 !important;
+}
+
+/* 自己发送的消息 */
+.bubble.bubble_primary {
+ background-color: #9eea6a !important;
+}
+
+/* 截图按钮 */
+.web_wechat_screencut {
+ display: none !important;
+}
diff --git a/wechat-nativefier.desktop b/wechat-nativefier.desktop
new file mode 100644
index 000000000000..78a3b2a7c392
--- /dev/null
+++ b/wechat-nativefier.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=WeChat
+Name[zh_CN]=微信
+Comment=WeChat desktop built with nativefier (electron)
+Exec=wechat-nativefier
+Icon=wechat-nativefier
+Encoding=UTF-8
+StartupWMClass=wechat-nativefier
+Terminal=false
+StartupNotify=true
+Type=Application
+Categories=Network;Chat;InstantMessaging;Application;
diff --git a/wechat-nativefier.png b/wechat-nativefier.png
new file mode 100644
index 000000000000..f56acd481080
--- /dev/null
+++ b/wechat-nativefier.png
Binary files differ