summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-03-15 16:29:21 -0700
committerBenjamin Denhartog2020-03-15 16:29:21 -0700
commit4617f9f4eec5a22e6f778a828caaa3c77ed02c7d (patch)
treee49f81555ddf51401079a6e4538c7eee3d7dae98
parente753ed112ce73e4d25c06a5a6f4f73f0528f1219 (diff)
downloadaur-4617f9f4eec5a22e6f778a828caaa3c77ed02c7d.tar.gz
chore: remove msg2 invocations
This patch removes the calls to the internal function `msg2`, moving the post-installation instructions and informational messages (e.g. "Installing the plugin...") to comments within the PKGBUILD. This results in less output when building the package. The post-installation instructions are helpful to display, but are out of place in various scenarios, such as when the user builds the package in a chroot environment, or as a different user than their own on the host machine.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index babe438de276..c6d10526440f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wee-slack-git
pkgdesc = A WeeChat plugin for slack
pkgver = 2.3.0.r105.g1af420e
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/wee-slack/wee-slack
arch = any
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index ee1972466bc3..a57f2fa8be8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,19 +5,19 @@
# POST-INSTALLATION INSTRUCTIONS
#
# WeeChat is unable to source files from outside of a user's home directory.
-# Because of this limitation, this package *DOES NOT* make the Slack plugin
-# available to WeeChat without end user interaction.
+# Because of this limitation, this package *DOES NOT* make this plugin available
+# to WeeChat without end user interaction.
#
-# Each user who wants to enable the Slack plugin needs to create symlinks in
-# the WeeChat configuration directory for their user (by default, ~/.weechat).
-# The following commands will accomplish this:
+# Each user who wants to enable this plugin needs to create symlinks in the
+# WeeChat configuration directory for their user (by default, ~/.weechat). The
+# following command(s) will accomplish this:
#
# $ ln -s /usr/lib/weechat/weemoji.json ~/.weechat/weemoji.json
# $ ln -s /usr/lib/weechat/python/wee_slack.py ~/.weechat/python/autoload/wee_slack.py
pkgname=wee-slack-git
pkgver=2.3.0.r105.g1af420e
-pkgrel=2
+pkgrel=3
pkgdesc="A WeeChat plugin for slack"
arch=('any')
url="https://github.com/wee-slack/${pkgname%-git}"
@@ -40,12 +40,12 @@ pkgver() {
package() {
cd "${srcdir}/${pkgname%-git}"
- msg2 "Installing the wee-slack plugin"
+ # Install the plugin script
install -Dm644 wee_slack.py "${pkgdir}/usr/lib/weechat/python/wee_slack.py"
- msg2 "Installing the emoji tab completion dictionary"
+ # Install the emoji tab completion dictionary
install -Dm644 weemoji.json "${pkgdir}/usr/lib/weechat/weemoji.json"
- msg2 "Installing license"
+ # Install the plugin license
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
}