summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenjamin Denhartog2020-05-06 18:33:04 -0700
committerBenjamin Denhartog2020-05-06 18:33:04 -0700
commite3ae86c07baee0b8063f026ad53cfaf0fec32dbd (patch)
treeed8b1efa5affab1581a59270c972dfbb5a882a69
parent22eafdbaee2c3eb8bb2d74c551f01684aa725d0f (diff)
downloadaur-e3ae86c07baee0b8063f026ad53cfaf0fec32dbd.tar.gz
feat(wee-slack-git): use an install script to present post {,un}installation instructions
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD16
-rw-r--r--wee-slack-git.install30
3 files changed, 34 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5b575291329..e6621b4665e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = wee-slack-git
pkgdesc = A WeeChat plugin for slack
pkgver = 2.6.0.r0.gf224e2f
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wee-slack/wee-slack
+ install = wee-slack-git.install
arch = any
license = MIT
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index 03b49a3f244f..ab71a3f3cce9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,9 @@
# This PKGBUILD is managed at https://github.com/sudoforge/pkgbuilds
-# POST-INSTALLATION INSTRUCTIONS
-#
-# WeeChat is unable to source files from outside of a user's home directory.
-# Because of this limitation, this package *DOES NOT* make this plugin available
-# to WeeChat without end user interaction.
-#
-# Each user who wants to enable this plugin needs to create symlinks in the
-# WeeChat configuration directory for their user (by default, ~/.weechat). The
-# following command(s) will accomplish this:
-#
-# $ ln -s /usr/lib/weechat/weemoji.json ~/.weechat/weemoji.json
-# $ ln -s /usr/lib/weechat/python/wee_slack.py ~/.weechat/python/autoload/wee_slack.py
-
pkgname=wee-slack-git
pkgver=2.6.0.r0.gf224e2f
-pkgrel=1
+pkgrel=2
pkgdesc="A WeeChat plugin for slack"
arch=('any')
url="https://github.com/wee-slack/${pkgname%-git}"
@@ -29,6 +16,7 @@ depends=(
makedepends=('git')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
+install=$pkgname.install
source=("git+${url}.git")
sha256sums=('SKIP')
diff --git a/wee-slack-git.install b/wee-slack-git.install
new file mode 100644
index 000000000000..3fd560134477
--- /dev/null
+++ b/wee-slack-git.install
@@ -0,0 +1,30 @@
+_install_update_msg() {
+cat <<EOF
+
+
+WeeChat is unable to source plugin scripts from outside of the process
+owner's configuration directory. Because of this limitation, this package
+**DOES NOT** make the plugin available to WeeChat without additional end
+user interaction.
+
+Each user who wants to enable this plugin should create a symlink in the in
+the configuration directory for their user (by default, ~/.weechat):
+
+ \$ ln -s /usr/lib/weechat/weemoji.json ~/.weechat/weemoji.json
+ \$ ln -s /usr/lib/weechat/python/wee_slack.py ~/.weechat/python/
+
+To load the script on start up, you'll also need to symlink it into the autoload folder:
+
+ \$ ln -s /usr/lib/weechat/python/wee_slack.py ~/.weechat/python/autoload/
+
+
+EOF
+}
+
+post_install() {
+ _install_update_msg
+}
+
+post_upgrade() {
+ _install_update_msg
+}